Antidote a de gros soucis avec macOS Mojave et Safari 12

Mickaël Bazoge |

macOS Mojave resserre un peu plus encore la sécurité autour des applications, en particulier les autorisations pour accéder aux données de l’utilisateur, à la webcam et au micro (lire : Sécurité : dans macOS Mojave, un notaire pour arrêter les frais). Quitte à en faire trop, comme ces alertes incessantes demandant à l’utilisateur d’autoriser le contrôle d’une app par une autre.

Comme tous les ans à chaque changement de version de macOS, des logiciels mettront un peu de temps à s’adapter à la nouvelle donne. Si vous êtes tributaire d’un logiciel spécifique pour votre travail, mieux vaut donc se renseigner auprès de l’éditeur et réfréner, le cas échéant, l’envie de mettre à jour votre Mac (la version finale de Mojave sera disponible lundi prochain). Ce sera le cas pour les utilisateurs d’Antidote.

Druide Informatique, l’éditeur du fameux correcteur, prévient dans un courriel qu’Antidote a beaucoup de difficulté à fonctionner correctement dans macOS Mojave. « Les nouvelles restrictions [dans macOS 10.14] sont très sévères, et causent des problèmes de communication entre Antidote et certains logiciels », écrit-il.

L’accès général via le menu contextuel n’est ainsi plus possible, sauf si on accepte de désactiver SIP. Cela concerne Outlook, Nisus Writer, les versions plus anciennes de Pages, Numbers et Keynote, ou encore Scrivener (mais pas Word). Par ailleurs, et décidément ce n’est pas la bonne semaine pour Druide, le connecteur d’Antidote a été désactivé dans Safari 12.

Le navigateur web de Mojave, qui est proposé depuis cette semaine aux utilisateurs de macOS Sierra et High Sierra, est donc à éviter le temps qu’Apple valide la nouvelle extension d’Antidote (le lien sera fourni à cette adresse).


avatar Malouin | 

Qui blâmer ? J’utilise Druide depuis des années et j’en suis très satisfait.
Comme je suis satisfait de mon Mac depuis des années... La sécurité me paraît essentielle.

avatar r e m y | 

@Malouin
On ne peut certainement pas blâmer la volonté de sécuriser macOS.

Mais la sécurité ne sera effective que si Apple est un peu plus sérieuse dans la validation des extensions autorisées qu'elle ne l'est pour les applications vendues sur l'appStore!
Il ne faudrait pas que les éditeurs de malwares fassent valider leurs extensions aussi facilement que leurs utilitaires (faux antivirus, faux dezippeurs de fichiers, faux anti malwares...) qui réapparaissent régulièrement sur le store (et en bonne place dans le top 10 des ventes).

avatar Yoskiz (non vérifié) | 

Manque de préparation de Druide ?
Druide ne découvre rien il me semble que Mojave est en version bêta depuis Juin.

avatar Bigdidou | 

@Yoskiz

"Manque de préparation de Druide ? "

Oui, récurrent.

avatar Yoskiz (non vérifié) | 

@Bigdidou

Oui j’en ai bien l’impression, l’année dernière c’était déjà la même histoire. ?

On dirait qu’ils découvrent les nouveautés du système au moment où il est disponible pour le grand public, pas très sérieux.

avatar Fennec72 | 

@Yoskiz

Druide fait le coup chaque année à chaque version majeure de macOS.

J’ai posé la question une année au support téchnique de Druide.
Ils ne semblent pas vouloir travailler avec les beta, considérant, si je me souviens bien, que travailler sur les beta n’est pas pertinent car Apple changerait parfois au dernier moment des éléments concernant le fonctionnement d’Antidote.

avatar Yoskiz (non vérifié) | 

@Fennec72

Ah d’accord intéressant.
Merci pour l’info ??

avatar Phiphi | 

Heureusement que je peux me passer d’antidote dans Safari car vous arrivez après ma bataille. Quand à installer Mojave avant quelques mois, comment dire, chat échaudé... Quand on utilise un ordinateur régulièrement, ne jamais faire de changement de version système trop vite, et prévoir le temps de restaurer une sauvegarde dans son planning.

avatar YSO | 

@Phiphi

+10000 ?

A quoi bon se jeter dessus. Mieux vaut attendre les premiers correctifs.

avatar DeluxePainter | 

En même temps l’intégration dans les logiciels n’est pas pour moi essentielle.

Je n’ai jamais installé l’intégrateur dans les navigateurs. Un copier/coller ou le plug-in de PopClip me vont bien.

avatar bugman | 

Je connais Antidote, l’utilisant depuis longtemps...
... Une raison comme une autre pour sortir une version 10 (mise a jour payante, naturellement).

avatar Bigdidou | 

@bugman

"Une raison comme une autre pour sortir une version 10 (mise a jour payante, naturellement)."

Ça,'est pas forcément choquant. Et puis c'est pas certain.
Le manque d'anticipation est de réactivité chronique est en revanche problématique.
Il manque un concurrent sérieux à Druide.

avatar Mr Bob | 

Exactement.

avatar Artefact3000 | 

Druide préfère Windows, c'est clair.

avatar fte | 

@DareMac

J’imagine que les grands efforts de Microsoft à assurer une compatibilité ascendante y est pour quelque chose, là ou Apple n’en a rien à battre de péter petites ou grandes applications.

avatar Artefact3000 | 

@fte

En effet.

avatar Moonwalker | 

Rien de nouveau avec Antidote. Au fur est à mesure des années on peut même dire que cela s’est amélioré puisqu’il arrivait qu’il fasse planter les applications à la moindre mise à jour.

avatar Le docteur | 

Druide traîne la patte et accuse Apple. Ce neT pas nouveau : ils jouent à ça depuis quelque temps avec Pages.
Par contre, ça ne marche pas si mal si on se rappelle qu’on peut activer les services Antidote dans la configuration générale des services.
Ça ne fonctionne pas dans Safari mais à peu près partout ailleurs (Pages et TextEdit marche par ailleurs direct sans cela).
PopClip, pour une raison que j’ignore marche moins bien que le menu service : il ne conserve pas les styles.

J’ai expliqué cela dans le fîl sur les applications dans Mojave.

Druide, ça me ferait mal de leur refiler du fric : ils soutiennent les associations pro réforme de 90.

Mojave me semble mieux fonctionner en bêta que High Sierra « finalisé »

avatar pim | 

@Le docteur

Pro réforme de 90 ? Tu veux parler de la réforme de l’orthographe, ce que l’on appelle l’orthographe « rectifiée » ?

À la première lecture on a l’impression qu’ils ont une section clandestine dans l’IRA ou dans les brigades rouges ! ?

?

avatar Le docteur | 

C'est pas faux.
Une minorité qui a tenté de noyauter tout ce qu'elle pouvait a poussé à l'adoption du projet de réforme de 90. Ils ont multiplié les arguments fallacieux pour tenter de faire passer cette connerie et comme personne ne leur résistait.
En ce qui me concerne, je les ai contré sur le site de Dicollecte. Comme quoi on pouvait leur résister : ils étaient trois pelés et leurs arguments valaient peau de balle.
C'est une secte, mais ce sont eux qui ont gagné, au final.

avatar Shralldam | 

@Le docteur

Euh, faut pas exagérer, à l’installation le logiciel laisse le choix (on peut même changer le paramètre a posteriori dans les préférences).

avatar Le docteur | 

Je n'exagère pas.
Druide a déclaré qu'il soutenait les associations qui promouvaient l'orthographe rectifiée. Il faut bien comprendre qu'ils leur apportent des moyens pour leur propagande.
De plus, ils ont sans doute joué un rôle actif pour ce qui est de souffler à l'oreille d'Apple et MS que le système du double dictionnaire était réclamé à corps et à cris par les français.
Du coup ça fait belle lurette qu'on a un dictionnaire à la con dans MacOS et dans IOS.
MS au moins donne encore le choix dans Word, Apple ne nous laisse plus le choix (ça doit dater de Snow Leopard).

avatar lll | 

Ils pourraient très bien activer par défaut l'orthographe rectifiée dans Antidote mais ne le font pas. Sur Dicollecte, est-ce que ces personnes parlaient au nom de Druide ou en leur nom ?

Personnellement, je préfère des gens qui utilisent Antidote et qui prennent position sur la réforme de l'orthographe (qui n'a pas que du mauvais, du reste) que des gens qui écrivent mal et n'en ont rien à faire.

Au passage, Druide n'est pas le seul éditeur de logiciels à m'envoyer des messages quelques jours avant la mise à jour Mojave.

avatar ofabriceo | 

Slt, comment fait tu pour le faire fonctionner dans pages ?
Car je suis obligé de copier/coller le texte

avatar Stpaul | 

@Bigoudou
Il y a Prolexis que j'utilise depuis une bonne vingtaine d'années (disquettes à l'époque). Il fonctionne, chez moi, avec les Beta de Mojave.
Prolexis est très réactif (ils sont en France) avec les clients.
Ce serait bien un article sur cette entreprise française.

avatar Bigdidou | 

@Stpaul

Ah, merci !
Je pensais qu'ils avaient disparu.
Je vais regarder de près, du coup.

avatar Khrys | 

Je viens regarder par curiosité. La license de base coûte plus de 300€ ?
Je ne doute pas de la qualité du logiciel, mais à ce prix là, je vais rester sous HighSierra, et attendre qu’Antidote soit totalement compatible avec Mojave... ?

avatar DarkHorse | 

@Stpaul: D'accord sur tout ??— et notamment sur leur réactivité?. Je leur ai écrit il y a quelques jours et ils m'ont assuré qu'ils préparaient la compatibilité avec Mojave depuis des mois et qu'ils espéraient être en mesure de proposer une mise à jour dans les jours suivant sa sortie.
Prolexis (le correcteur) est tout simplement excellent. S'il est moins connu qu'Antidote, j'y vois deux raisons : 1) son prix élevé ; 2) il est très bien protégé et "impiratable", lui…
ps: je suis moi aussi un "vétéran Prolexis": j'ai connu la version 1.0 qui tenait sur deux disquettes noires… ? (l'actuelle est la 6.5.7)

avatar Almux | 

Antidote/Safari 12: ça m'a fait le coup.
TextEdit permet de "contourner" le problème et de corriger des textes en deux temps... c'est relativement laborieux.
Inutile de dire que je vais attendre le plus longtemps possible, avant de mettre à jour MacOs!
Par contre, ayant reçu de Druide une mise en garde ce matin, j'y ai lu l'incompatibilité avec Skrivener. Ceci n'est que partiellement vrai. Car, en cliquant sur la première icône (en haut à gauche) du menu de la fenêtre d'un document Skrivener, Antidote est proposé au bas du menu contextuel. Et cela fonctionne à merveille.
J'espère que mon poste pourra être utile à des écrivain-e-s assidu-e-s...

avatar Le docteur | 

Prolexis est trop onéreux.
Si je ne m'abuse c'est le Robert Correcteur qui a pris la suite du petit Prolexis.
Je pense que je me démerderai tout seul ou changerai pour le Robert Correcteur si il faut en passer par une mise à jour payante d'Antidote pour continuer à l'utiliser.
Plus probablement j'utiliserai ma version même sur trois pattes, jusqu'à ce que ça devienne ingérable ou tout simplement impossible.

avatar Bigdidou | 

@Le docteur

« Si je ne m'abuse c'est le Robert Correcteur qui a pris la suite du petit Prolexis. »

Oui, j’ai vu ça, du coup.
100€ pour le Robert correcteur.
La seule question, c’est est ce que ça vaut Antidote ?
Qu’est ce qu’apporte Prolexis de plus ?

avatar Le docteur | 

Pour Prolexis, je ne sais pas, mais j'avais testé le Robert (et avant, le petit Prolexis). C'est en-dessous d'Antidote au niveau de l'intégration (quoique bientôt Antidote n'aura rien à leur envier à ce niveau), plus laborieux à utiliser et a priori il y avait plus d'oublis.
Je crois qu'il n'y avait pas de mécanisme rapides et pratiques comme l'anti-oups ou la correction en un clic de la typographie. Je ne suis pas sûr qu'il analysait le style non plus.
Bref ! Plus austère et sans doute un peu moins efficace.
Je ne sais pas ce qu'apporte le Prolexis.

avatar Bigdidou | 

@Le docteur

Ah, merci beaucoup de ton retour.
J’ai installé le Robert en version d’essai (1 mois, je crois), je testerai demain.

avatar Feflefoo | 

Je suis ravi d'apprendre que certains ont reçu un mail de Druide.
Pas moi...

avatar 7X | 

Personnellement, ça fait trois jours que je bataille pour installer High Sierra sur une partition test. Je crois avoir une application qui fait planter le système et échouer le démarrage. J'en suis réduit à délaisser l'Assistant migration et les réinstaller une à une avec un clonage à chaque étape. Je vais me garder mes app Adobe et le pilote de ma carte Sonnet en dessert.
Depuis Mac OS X 10.2, je n'ai jamais connu une telle galère !
Pour Mojave, je crois que je vais attendre.

avatar Jacti | 

Une nouvelle version tous les ans, ça me fatigue. Il y a longtemps que j'ai abandonné. Je suis toujours sous Yosémite (sur mon iMac Retina de fin 2014) qui ne me satisfait qu'à moitié. Où est le bon vieux temps de Snow Leopard (que j'ai toujours sur un iMac de mi 2011) et qui correspond toujours pleinement à mes besoins.

avatar Patrick | 

Quelqu’un peut m’expliquer à quoi servent les 12-13 bêta qu’Apple relâche tous les ans avant la finale publique
De même pour les comptes dev

avatar bugman | 

@Kikool

Pour les comptes devs, cela permet le développement et les tests des nouvelles fonctions qui seront proposer au public dans la prochaine version de L'OS. Cela permet aussi au devs d'assurer la compatibilité de leurs logiciels avec l'OS à sa sortie.
Les bêtas publiques permettent à ceux qui le veulent de remonter à Apple les différents bugs rencontrés.

avatar John Kay | 

Le souci se pose à chaque nouvelle version de macOS. Je ne comprends pas pourquoi Druide ne modifie pas en conséquence son logiciel – préférant inviter les utilisateurs d'Antidote à mailer Apple pour leur réclamer une API (c'est pas une blague, ils l'écrivent noir sur blanc dans l'une des réponses, sur leur page FAQ).

Vu qu'une version majeure d'Antidote sort tous les trois ans, Antidote 10 devrait être présenté cet automne. Si lui non plus n'est pas compatible comme il faut, ça promet…

Après, il ne fait aucun doute qu'Apple ne facilite pas la vie aux éditeurs de logiciel, quitte à multiplier les bâtons dans les roues. Mais ce n'est pas aux utilisateurs de subir cette situation.

avatar Artefact3000 | 

@John Kay

"Vu qu'une version majeure d'Antidote sort tous les trois ans, Antidote 10 devrait être présenté cet automne. Si lui non plus n'est pas compatible comme il faut, ça promet…"

Pour avoir testé la beta, ça promet pas des tonnes...

avatar pagaupa | 

Quelle belle communication entre Apple et les éditeurs! Admirable!

avatar JeevesGre | 

@John Kay
Et Druide n’est pas seul …
Ergonis aussi a ses problèmes de mises à jour, même non directement liés a la version de macOS.
Sur 10.11.6 / El Capitan par exemple :
Utilisateur enregistré de Typinator et PopChar ayant déjà fait plusieurs mises à jour sans problème, une notification m’a récemment informé d'une nouvelle, proposant comme d’habitude de cliquer pour l’installer. Ce que j’ai fait, sauf qu’un message bref est apparu :
“Échec du téléchargement" ! Je vais voir sur le site sécurisé de l’éditeur, blocage et message de Safari : “Ce certificat a été signé par un émetteur non approuvé” (Comodo RSA).
Ouverture de Firefox, aucun problème de connexion (Comodo est signalé) ni de téléchargement de la nouvelle version.
Ce qui me gène très profondément, c’est le doute instillé via les blocages de Safari.
Il se résume en une seule question :
Quel organisme, hormis Apple, est habilité à “approuver” la validité d’un certificat ?

avatar Erravid | 

> Quel organisme, hormis Apple, est habilité à “approuver” la validité d’un certificat ?

Les autorités de certification (CA – Certificate Authorities) : https://fr.wikipedia.org/wiki/Autorit%C3%A9_de_certification
Ensuite, ces autorités et certificats peuvent être ajoutés aux listes de confiances directement dans les systèmes (comme Apple) ou les navigateurs (comme Firefox).

Il y a en réalité plus de paramètres rentrant en compte dans l'acceptation d'un certificat (force du chiffrement, algorithmes supportés, etc.) qui font qu'un certificat peut être accepté sur un système ou navigateur, et rejeté sur un autre.

avatar BenAndBen | 

Essentiellement le CAB Forum (cf. 2.1 Qualifying for Forum Membership au sein du document ci-après).

Il s'agit évidement des grands de ce monde (les GAFAM et autres institutionnels bien établis sur le web).
https://cabforum.org/wp-content/uploads/CABF-Bylaws-v.1.9_4APR18.pdf

C'est un processus long qui demande des audits et qui reste à la main de l'éditeur du logiciel qui accepte sa liste de certificats racines [les Root CA] (chez Mozilla, il faut compter au moins 2 ans pour y figurer), chez Adobe c'est réputé plus rapide ... quoique ... et chez Apple, je compte à cette heure à peine 175 racines trustées dans mon trousseau Mojave (la liste la plus courte qui existe à ma connaissance).

avatar JeevesGre | 

Merci pour cette réponse appuyée par le lien.
J'avoue y voir plus clair.

avatar SyMich | 

Réponse des développeurs d'Antidote sur la raison pour laquelle ils n'ont pas profité de la phase de bêta test pour mettre à jour leur application :
"We can't use a beta XCode to seriously build a release software. We had to wait for the new version of XCode updated for Mojave"

CONNEXION UTILISATEUR