macOS 10.15.7 : en cas d'emballement du processus accountsd 🆕

Stéphane Moussie |

Mise à jour le 2 octobre : vous avez été plusieurs à nous signaler dans les commentaires ou par email d'autres types de manipulations qui ont résolu le problème. Notez bien que celles-ci ne fonctionnent pas à tous les coups :

Par ailleurs, nous avons ajouté une précision sur la manipulation liée aux lignes de commande. Après avoir saisi ces lignes dans le Terminal, il faut copier le contenu du dossier ~/Bibliothèque/Accounts/Backup vers le répertoire ~/Bibliothèque/Accounts/ et après cela éventuellement redémarrer l'ordinateur.


Depuis l'installation de macOS 10.15.7 sorti la semaine dernière, des utilisateurs se plaignent d'un emballement du processus accountsd. Chez certains, ce processus lié aux comptes enregistrés sur le système s'accapare toute l'activité du processeur, entraînant un ralentissement général du Mac.

Si vous constatez des lenteurs sur votre Mac depuis la dernière mise à jour, ouvrez le Moniteur d'activité et regardez si l'occupation CPU de accountsd est exagérée. Si elle est de 400 %, par exemple, c'est qu'il y a un problème.

Dans ce cas-là, Mr. Macintosh suggère diverses opérations à tester. Un simple redémarrage ou réactivation du Wi-Fi suffit parfois à résoudre le souci. Autrement, il faut tenter la reconnexion à iCloud et aux autres comptes internet dans les Préférences Système.

Si ça ne donne rien, il faut dégainer le Terminal pour redémarrer manuellement le processus défectueux en saisissant ces lignes de commande (au passage, une sauvegarde de la base de données iCloud est effectuée) :

sudo -v ; killall -9 accountsd com.apple.iCloudHelper ; defaults delete MobileMeAccounts ; mkdir ~/Library/Accounts/Backup; mv ~/Library/Accounts/*.sqlite* ~/Library/Accounts/Backup/ ; killall -9 accountsd com.apple.iCloudHelper ; sudo reboot

Après avoir saisi ces lignes dans le Terminal, il faut copier le contenu du dossier ~/Bibliothèque/Accounts/Backup vers le répertoire ~/Bibliothèque/Accounts/.

Si le problème persiste après ça, un rétropédalage sur macOS 10.15.6 à l'aide d'une sauvegarde est à envisager sérieusement.

Mise à jour à 14h11 : comme vous êtes plusieurs à le signaler, macOS 10.15.7 n'est pas le seul touché par ce problème. Des versions antérieures sont également concernées, tout comme Big Sur. Après l'installation de la neuvième bêta de macOS 11, le processus accountsd a fait tourner les ventilateurs et tourner en bourrique l'un de nos Mac. Un redémarrage a suffi à régler le problème.


avatar Azorbar | 

Je pense que vous avez des * qui ont disparues de la commande terminal.

avatar Stéphane Moussie | 
@Azorbar : en effet, c'est corrigé.
avatar ljb | 

@stephmouss

A l'aide! la commande de terminal rend la reconnexion à iCloud impossible chez moi (Après introduction du mot de passe, boite de dialogue "Echec de la vérification. Une erreur inconnue est survenue"). Une idée?

avatar yelmo | 

Pareil chez moi, avez vous trouvé la solution pour pouvoir reconnecter ses comptes ?

avatar yelmo | 

J'étais en 10.15.6, je viens de faire la mise à jour vers 10.15.7 mais je ne peux toujours pas me connecter à icloud ni rien... en tout cas, accountsd continue sans s'emballer ... mais à quel prix, ni synchro de calendriers ni de rien...

avatar Gwynpl@ine | 

@ljb

Vire dans iCloud, si tu as un iPad ou iPhone le Mac de ton compte. Tu le supprimes de ta liste.

Personnellement mon MBP 16" s'est emballé, impossible de travailler avec, Safari en PLS et l'ordinateur super lent. J'ai viré de iCloud mon Mac via mon iPhone, puis redémarrer mon Mac. Problème résolu de cette façon.

avatar dirtyswift | 

Est ce que tu as trouvé une solution, moi impossible de me reconnecter, même en éliminant mon MBP dans la liste de mes devices iCloud...

avatar Ducletho | 

Ça va c’est assez intuitif pas comme win10

avatar byte_order | 

J'aime beaucoup ce commentaire.

avatar lepoulpebaleine | 

@byte_order

Second degré 😂

avatar huexley | 

Des postes en 10.15.6 sont également touchés.

avatar bent.o | 

C'est ma surprise du matin, MacOs inutilisable et accountsd pleine balle après la mise à jour d'hier soir.. Désastreuses ces dernière MAJ 😤, ça fait deux jours que j'annulais leur exécution et mon intuition était bonne!
Une simple déconnexion de mon ID a résolu ce symptôme, mais qu'en est il de l'intégrité du reste du système? ...
(Merci macg pour les astuces et l'article!)

avatar JohnS2B | 

Exact. Ça m’est arrivé hier soir.
350% et un Mac carrément inutilisable.

J’ai même forcé l’extinction en faisait un Reset SMC car même en restant appuyé sur le bouton d’alimentation 5 secondes, le MacBook Pro ne répondait pas.

En ce qui me concerne, le redémarrage a suffit pour rétablir la machine.

À voir si cela se reproduira.

avatar beber666 | 

Le problème est déjà présent sur la 10.15.5 mais avec une situation différente
C'est assez simple à vérifier:
- Il faut un compte exchange dans mail
- Couper la connexion internet

Profiter....

avatar andr3 | 

@beber666

Problème effectif avec les versions antérieures à 10.15.7 et Office 365.

Solution dans mon cas, virer le compte Office 365 (pas utilisé temporairement) et virer les «  résidus » de celui-ci dans Mail.

avatar Nico1576 | 

Bonjour, comme j'aurais aimé voir cet article ce matin quand mon accountd caracolait à 500% du processeur et que je ne trouvais rien qui puisse m'aider.
Ne trouvant pas de solution, j'ai restauré macOS 10.15.7. Ca a pris une heure bien sûr, mais plus de problème depuis.
Si ça revient, je sais où trouver la solution rapide :-)

avatar occam | 

À suivre au jour le jour la langue de bois de Cupertino, ça déteint forcément, mais il y a des sous-entendus qui blessent et des nuances qui fâchent.

Non, les utilisateurs ne se plaignent pas de l’emballement d’accountsd, ils le constatent, ils le signalent, ils s’en inquiètent (et ils ont raison !), parfois même ils s’en alarment (et, encore une fois, ils ont raison !).

C’est ce dysfonctionnement de macOS 10.5.7 qui fait tache, et non pas les utilisateurs qui s’en rendent compte.

avatar raoolito | 

@occam

10.5.7 va bien, rassurez-vous pour lui :)

10.15.7 par contre j’ai eu aussi, et en farfouillant sur internet apparement c’etait lié aux comptes, à Mail, à je ne sais quoi.. Je ne sais plus ce que j’ai fiat mais d’un coup c parti
pas su pourquoi ca arrivait, pas su pourquoi c’etait parti...

avatar occam | 

@raoolito

😉

avatar MacGruber | 

De mémoire, sur un site anglais, il est que c’est Photos qui indexe. À moins que je confonde.

En tout cas, je suis touché par ce problème.

avatar Crunch Crunch | 

Un fil existe sur le forum de MacG:
https://forums.macg.co/threads/desactivation-du-wifi-accountsd-semballe-et-charge-processeur-au-max.1338329/page-2

J'ai perdu 4h de travail à cause de ce truc. Mac inutilisable car "accountsd" prenait TOUT le CPU ! Rien que l'ouverture de l'app "Contact" prenait 5 min…

Et dire que la màj de 10.15.7 est passé par un beta test !!!
Il travaille avec les pieds chez Apple ?

PS:
C'est la 2ème màj Apple qui me fait perdre énormément de temps en 3 semaines !!!
Le coup des widget iOS 14 qui fait disparaitre les dossiers d'app c'était génial aussi ! Bref, j'annonce officiellement que Apple peut attendre entre 2 et 4 ans, avant que j'applique leurs prochaines màj !!! Fâché, que je suis !!!

avatar reborn | 

@Crunch Crunch

Fermer le process n’a pas été suffisant pour reprendre la main ?

avatar raoolito | 

@reborn

je confirme que non, il revenait

avatar Crunch Crunch | 
avatar raoolito | 

@Crunch Crunch

vous comptez installer souvent les mises à jours systeme comme ca?
Meme sur windows ils ne le font pas. (en tous cas pas sur des machines de travail)
attendez une semaine.

maintenant , je dis cela mais je l’ai fait et j’ai eu le meme soucis. Coup de chance je n’avais pas commencé à travailler, c’etait durant le WE je bricolais un autre truc..

avatar Crunch Crunch | 

Non, plus jamais !
Apparemment Apple ne sais plus faire de beta test ?!?

avatar raoolito | 

@Crunch Crunch

vous ne saveez pas ? Leur QA sont en vacances eternelles :)
ca fait quelques années, souvenez-vous de High Sierra:

user: root
mdp:
>acces au système avec tous les privilèges.. Par défaut, si c pas beau !

avatar r e m y | 

@raoolito

Si ça peut vous rassurer, HighSierra souffre exactement du même problème (tout comme Mojave), le problème étant lié à la dernière mise à jour de sécurité (livrée seule pour HighSierra et Mojave, et integré à la mise à jour de l'OS pour Catalina)

Il semble qu'il y a un problème de syntaxe dans le dialogue d'autorisation d'accès aux serveurs d,authentification d'iCloud (qui renvoie un message d'erreur signalant une commande "mal formée").
Soit c'est la même erreur de syntaxe embarquée dans la mise à jour de sécurité des 3 OS, soit c'est une modification volontaire d'Apple au niveau de macOS, mais ils ont oublié de mettre à jour leur serveur pour qu'il accepte cette nouvelle syntaxe...

avatar Crunch Crunch | 

Mouais…
C'est limite en effet. Il faudrais remettre un peu d'ordre dans la partie développement !

De toute manière, avec le switch sur ARM, la plantée ne sera pas permise !

avatar byte_order | 

@Crunch Crunch
> Apparemment Apple ne sais plus faire de beta test ?!?

Il me semble qu'Apple sous-traite ses beta-tests à ses clients. Y'a p'tet un lien...

avatar MarcMame | 

@Crunch Crunch

"J'ai perdu 4h de travail à cause de ce truc."

J’espère que tu assumes ta part de responsabilité dans ce petit malheur ?

avatar Crunch Crunch | 

Pas vraiment non !
Apple met en production une mise à jour. A mon sens TOUT devrait avoir été testé !

Et là, on ne parle pas d'une exception. Une bonne partie des utilisateur Mac semblent avoir été bien ennuyé par ce problème !

avatar MarcMame | 

@Crunch Crunch

"Pas vraiment non !
Apple met en production une mise à jour. A mon sens TOUT devrait avoir été testé !"
———————
Soit tu es naïf, soit tu n’as aucune expérience des mises à jour.
Les tests exhaustifs sont impossibles et ne l’ont JAMAIS été.

Ta décision d’appliquer une mise à jour de quelque nature que ce soit et sans aucun recul t’appartient.
Personne ne te tord le bras pour le faire.
C’est ta part de responsabilité qu’il faut assumer.

avatar rolmeyer | 

@MarcMame

euh j’osais pas réagir...tu as osé. Installer une mise à jour dans les jours qui suivent sur une machine de travail ...😳😩.
Certes, on a pu être en confiance ces dernières années, mais tout de même, les règles n’ont pas changé.
Et l’herbe est pas plus verte ailleurs, ça reste tout aussi (encore plus dirais je) sur Windows. La version correcte pour ma Surface Pro 5 update de avril 2020 a été déployée début septembre. donc 20/04 s’est transformé en 20/09 et encore je l’ai pas appliqué vu que certaines machines perdaient leur connexion internet..

avatar Jef74 | 

Même problème ! A défaut de trouver une solution (moniteur d'activité, réinitialisation pRam et redémarrages, j'ai fini par réinstaller Catalina et problème résolu. Je ne connaissais pas les astuces décrites ci-dessus.

avatar raoolito | 

@Jef74

un truc du genre « un process qui surchauffe » ca se trouve sur le net.
par contre, il fallait avoir un iphone ou ipad à coté (ou un autre ordi)

avatar thibparis | 

J’avais déjà ce problème depuis le passage à Catalina sur deux MacBook Pro 2019, un 13 pouces et un 15 pouces. Dès que l’ordinateur n’a plus internet, c’est parti pour le processus qui s’emballe, les ventilateurs à fond et la batterie qui descend en flèche. Très très relou et aucune mise à jour n’a jamais réglé le problème, j’envisage une clean install de Big Sur quand il sera sorti...

avatar raoolito | 

@thibparis

ah pas bete, je crois que j’avais eu ce soucis à cause du VPN qui avait cafouillé, et ca a commencé apres en effet !
bien v u!

avatar reborn | 

@raoolito

Nordvpn en sortie de veille m’affichait 90go de RAM utilisé (16 go + le reste en swap bien sur..)

🤷‍♂️

avatar raoolito | 

@reborn

moi aussi j’ai nordVPN ?
….
MMHMMMMMMMm...

avatar GameAndWatch | 

J'ai eu ce problème en rentrant de week end en 10.15.6 :(
J'ai suivi le conseil du signout icloud > reboot > sign in icloud > reboot. Pour l'instant ca va. Seule différence vu que je ne n'utilise plus Mail, c'est que je n'ai pas réactivé les comptes internet.

avatar r e m y | 

Le problème est identique sur Mojave après la dernière mise à jour de sécurité.

avatar Rollingman | 

Chez moi, j'ai ce problème dès que Rambox se lance, et en particulier avec WhatsApp.
Si je n'ouvre pas Rambox… Pas de souci, du coup j'utilise WhatsApp dans son application Web desktop que l'on télécharge sur l'App Store et tout roule.

avatar ssssirhc | 

de mon côté le reset NVRAM a fonctionné du premier coup :
alt+cmd+p+r

avatar péhèm | 

J'ai eu ça lundi. Après quelques recherches : En allant dans sa bibliothèque (celle qui est caché) j'ai mis le dossier Accounts de coté, j'ai redémarré. Ça recrée un dossier Accounts et plus de soucis. Ensuite j'ai remplacé le nouveau dossier Accounts par l'ancien, redémarrage et plus de problème depuis.

avatar alextoolsbe | 

Pour ma part aucune solution ne fonctionnait (celles de l'article et d'autres). Mais après l'utilisation de Onyx tout est rentré dans l'ordre

avatar vache folle | 

@alextoolsbe

Quelle procédure?

avatar alextoolsbe | 

A peu près toutes les maintenances (sauf l'effacement des instantané de Time Machine car la dernière fois, cela a provoqué un reset de ma sauvegarde)

avatar Krys_666 | 

@alextoolsbe

Bonjour, vous cités Onyx pour remédier au problème (que je viens de constater hier, sans avoir fait la mise à jour Apple), quel est le processus ONYX que vous avez utilisé ?
Merci

avatar bl@ck warrior_69 | 

Sur mon ancien MacBook Pro j'avais déjà ce processus qui bouffait tout et faisait chauffer l'ordi avec les ventilo a fond sans raison. En général je quittait complètement Mail et ça résolvait le problème. Mais je me souviens pas si le but était apparu en passant à Catalina ou si c'était déjà présent avant sous Mojave.

Pages

CONNEXION UTILISATEUR