Mojave ne télécharge plus les anciennes versions de macOS [MàJ]

Nicolas Furno |

Comme le note Le journal du Lapin, il n’est plus possible de télécharger macOS Sierra ou OS X El Capitan sur Mojave. Si vous cliquez sur ce lien par exemple, le Mac App Store s’ouvrira normalement, puis le panneau des Préférences Système dédié aux mises à jour, mais vous obtiendrez alors ce message d’erreur :

Impossible de télécharger El Capitan ou Sierra sur macOS Mojave…

Sur les quatre versions du système proposées via le Mac App Store, deux ne sont plus disponibles si vous êtes passés à macOS 10.14 : El Capitan et Sierra. En revanche, macOS High Sierra est encore proposée au téléchargement :

En revanche, High Sierra est encore accessible.

Cette politique n’est pas nouvelle, El Capitan ne peut pas non plus être récupéré sur un Mac avec High Sierra. À chaque mise à jour de son système, Apple ne permet de télécharger sur sa boutique que la version en cours et la précédente. Ce n’est pas forcément un problème, mais si vous avez besoin de réinstaller le système sur un vieux Mac, c’est un paramètre à connaître.

Le plus sûr est de garder une copie de macOS, sur un coin de disque dur ou mieux, sur une clé USB prête à emploi. Si vous n’avez pas de copie de Sierra, vous n’aurez plus le choix, il vous faudra un Mac sous High Sierra pour en récupérer une. À défaut, une machine virtuelle peut faire l’affaire, comme le rappelle le blog.

[MàJ 29/10/2018 10h26] : si vous avez besoin d’une ancienne version de macOS, une autre solution consiste à passer en Apple Store. Apple dispose de toutes les versions de son système sur ses serveurs et le constructeur peut vous les installer sur votre Mac, y compris si vous voulez revenir à une ancienne version du système.

Dans ce cas, vous devrez faire une sauvegarde avant toute chose, car le volume de stockage sera formaté. On nous indique aussi qu’il faut absolument prendre rendez-vous et compter au minimum une heure pour la réinstallation du système. C’est une solution officielle malgré tout, même si elle implique d’habiter à proximité d’un Apple Store et de pouvoir déplacer le Mac.

avatar jacquemin | 

C'est pénible. Il devrait être possible de contourner ça et de charger la version du système dont on a besoin avec la machine que l'on veut. Toutes ces restrictions ne rendent pas la vie facile aux utilisateurs.

avatar pagaupa | 

@jacquemin

Du Signé Apple!

avatar Pipes Chapman | 

vous vous rendez compte des types comme pagaupa, des pauvres mecs, des pauvres types qui se lèvent le matin juste pour aller sur un site apple poster un petit caca luisant de bile dans le pot...

c'est sa vie, c'est ce qui "le remplit" mais vous ne vous demandez jamais "c'est quoi sa vie" pour en être rendu là ? C'est triste

avatar oomu | 

"Toutes ces restrictions ne rendent pas la vie facile aux utilisateurs."

répétez après moi :

faciliter la vie aux acheteurs, AUX ACHETEURS !

avatar occam | 

@oomu

"faciliter la vie aux acheteurs, AUX ACHETEURS !"

Justement.
Ces systèmes, on les a payés en achetant des Mac.
Payés, mais pas achetés, puisque leurs seigneuries de Cupertino nous font la grâce de nous en concéder l’utilisation dans les termes et pour la durée de leur bon plaisir souverain.

Et avec ça, il y en a qui s’émeuvent de l’achat de Red Hat par IBM.

Il serait grand temps pour Ridley Scott de refaire une version de son spot 1984, revu et corrigé, 35 ans après.

avatar Shralldam | 

J'ai justement une VM sous Mavericks pour ce genre de situation… Sauf que ça a complètement mis le désordre au niveau de mon identifiant Apple avec l'identification à 2 facteurs, plus possible de le déverrouiller sous cet OS.

avatar fredsoo | 

Impossible de trouver un .dmg?

avatar MalikDev | 

bah la n'est pas le problème des DMG de Capitan ou sierra il y en a en pagaille sur les sites de DLL !!! le plus gros des problèmes est qu'il n'y a toujours pas de webdriver Nvidia pour Mojave 10.14 ni de Cuda Apple et Nvidia se renvoient la balle !!! moi j ai 2 tours Apple avec des GPU Nvidia sous Mojave et bien pas d'acceleration matériel pas de QE/CI et mon pote qui a une entreprise en a 12 imaginez le problème en programme DEV !!! ont ns demande de faire la MAJ vers Mojave mais les pilotes ne suivent pas !!!

avatar 0MiguelAnge0 | 

@MalikDev

J’ai laissé mon MacPro 5.1 sous Sierra pour bénéficier du support des Web Driver.
Je ne comprends pas le choix de passer à 10.14 et ensuite de se plaindre. Ai-je loupé un truc?

avatar MalikDev | 

hello 0MiguelAnge0 si tu est sous High Sierra Apple te demande de faire la MAJ vers Mojave pffff et en general quand une nvlle version sort les pilotes Nvidia suivent dans la foulée et la que dalle !!! va falloir attendre 6 voir 8 semaines pour le webdriver ainsi que cuda comme il y a bcp de changement ds les GPU Apple Fermi /Metal / .......etc en fin de compte vaut mieux rester sur High Sierra ou sierra !!!

avatar Benitochoco | 

Tu n'auras pas de Webdriver pour Mojave.

avatar MalikDev | 

hello Benitochoco aux derniéres infos Nvidia travaille avec Apple pour cela !!! etant donné que bcp d'application de developpement et d'encodage ne fonctionne pas sous Mojave pour l'instant a cause des latences GPU!!!! Nvidia demande de ne pas faire la MAJ vers Mojave tant qu'une solution n'aura pas ete trouvé avec Apple en particulier Cuda https://devtalk.nvidia.com/default/topic/1042279/cuda-setup-and-installa...

avatar 0MiguelAnge0 | 

@MalikDev

Je suis resté sous Sierra... Stable.

Il semble que Nvidia prenne son temps avec la compatibilité Metal 2.

avatar adixya | 

A mon avis revenir sous high sierra ne devra se faire que pour des cas extrêmes. Mais pour el capitan ou sierra, oui c’est un peu chiant leur politique.

avatar armandgz123 | 

Il ne suffit pas de les télécharger sur internet ?

avatar r e m y | 

@armandgz123

C'est le meilleur moyen de récupérer une version assaisonnée de multiples malwares...

avatar armandgz123 | 

@r e m y

Il doit bien y avoir un site fiable à l’image de ipsw.me ...

avatar SidFik | 

@r e m y

Je pense qu’en réalité cela doit etre plutot rare

avatar Vostorn | 

@armandgz123

J'ai téléchargé El Capitan depuis le Mac App Store et le garde bien au chaud sur un disque dur externe. Juste au cas où 🙂

avatar marc_os | 

@Vostorn
Ça ne suffira pas le jour où tu en auras besoin, car sa signature ne sera plus valide. Tu devras bidouiller et te générer une clef USB bootable avec par exemple DiskMaker X.

avatar Moonwalker | 

Le jour où le certificat ne sera plus valide, tu n’auras de toutes façon plus aucune machine pour le faire tourner, ou au moins plus aucun intérêt pratique à cela.

avatar Biking Dutch Man | 

Sur mon serveur j’ai un copié de chaque version depuis la 10.0!

avatar lepoulpebaleine | 

@Biking Dutch Man

Bravo !
Pareil pour moi mais seulement depuis 10.5 Leopard.
Mon premier Mac est de 2007 (avant j’étais un manchot 🐧).

avatar oomu | 

Tipiak qui parasite le Juste Commerce d'Apple de vendre des machines neuves aux systèmes à jour et au bon abonnement Adobe Creative Cloud à jour. Avec vos copies de vieux logiciels vous arriverez à vous démerder avec une machine dépassée ou récupérée d'occaz, alors que sinon vous auriez eu le civisme, que dis je ?, l’héroïsme d'acheter du neuf.

bouhouhouhou #jaiMalAuCapital

avatar marc_os | 

« Ce n’est pas forcément un problème »
Si c'est un problème !
Si vous utilisez des logiciels rendus incompatibles par Apple avec ses nouveaux systèmes.
J'ai une amie dont le MBP était resté sous 10.10, et impossible d'y installer simplement El Capitan. J'ai dû ruser pour y arriver. :(

Pages

CONNEXION UTILISATEUR