Xprotect mis à jour pour bloquer les anciennes versions de Flash

Anthony Nelzin-Santos |

Pour la première fois depuis le mois de septembre 2013, Apple a procédé à une mise à jour de Xprotect, l’anti-malware intégré à OS X. Celle-ci bloque l’installation et l’exécution de toutes les versions du plug-in Flash inférieures à la 12.0.0.44.

Publiée hier, celle-ci bouche une faille de sécurité permettant de prendre le contrôle d’un ordinateur à distance. Si vous utilisez Flash, il vous suffit de vous rendre dans l’onglet Avancé de son panneau de préférence pour vous assurer que vous disposez de la bonne version (et vous mettre à jour sinon).

Dans OS X Mavericks, l’option qui permet de désactiver Xprotect a été supprimée. Vous pouvez cliquer sur ce lien pour vérifier le contenu de son fichier d’exclusion sur le serveur d’Apple, et taper la commande more /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist dans le Terminal pour vérifier le contenu de ce fichier sur votre Mac.

avatar rondex8002 | 

Question bête : comment savoir si Flash est installé sur son Mac ? Il me semble que le flash n'est plus installé automatiquement sur OS X. Et je crois aussi que chrome embarque sa version de flash qui est intégrée native moment dans le navigateur.

Un petit aparté, je ne vois pas du tout l'utilité de Flash concrètement. Avant, ça posait un certain problème sur iOS. Maintenant, Adobe va abandonner Flash sur mobile. Et sûrement à moyen ou long terme sur les ordinateurs.
Là où je veux en venir, c'est qu'en naviguant sur le net depuis mon Mac, depuis mon iPhone ou iPad, je ne vois aucune différence.
Avant, les vidéos posé pas mal de problème, car beaucoup de sites utilisées exclusivement flash. Maintenant, je ne me souviens pas d'avoir je joue moins récemment, ne pas pouvoir lire une vidéo sur iOS. Même si le site propose toujours une vidéo avec Flash, il y a toujours une version « non flash ».

Je suis le seul dans ce cas ? Ou il y a encore des utilisations où flash est incontournable ?

avatar fromdisco | 

certains sites ne fonctionne qu'en Flash (ex : https://www.fdj.fr/accueil/ ).
Si tu n'as pas Flash tu ne pas jouer/parier.

Pour rentrer dans ma banque avec mon Mac, je dois saisir le mot de passe dans un module Flash.....
Sur mon iPhone et mon iPad j'ai une Apps donc pas de soucis.

Je suis d'accord que plus le temps avance et moins Flash est obligatoire mais on ne peut pas s'en passer à 100%.

avatar aimstar | 

Si on peut se passer de flash grace au HTML5

Mais il y a encore des gens de la vieille école qui ont galéré pour apprendre flash donc veulent continuer a lutiliser (certains developpeurs)

Et dautres qui ne connaissent rien et pensent que flash "ca fait beau" (certains clients)....alors que c'est bourré de failles de sécurité et que ca ne passe pas sur les iDevices

avatar Dan DT | 

Sur mes iPad/iPhone j'utilise Puffin qui permet de lire le flash
Il y a encore beaucoup de site en Flash hélas :-/

avatar Almux | 

Hier, j'ai eu ce blocage, suivi d'une impossibilité de télécharger la dernière version à cause de mes filtres de protection…
Finalement, j'ai trouvé un désinstallateur sur un forum.
J'ai désinstallé Flash… mais, l'impossibilité de terminer l'installation automatique depuis le site Adobe…
Dix minutes plus tard, je refait une tentative de visionnement de séquences Flash… et ça fonctionne!
…Pas bien compris, ni pourquoi, ni comment, d'ailleurs…

avatar fleuger | 

Ne s'est pas mis à jour chez moi :
MinimumPluginBundleVersion String 11.8.800.94
le fichier XProtect.meta.plist a été créé le 08/10/2013 et dernière modification le 02/12/2013
J'ai ouvert Mise à jour de logiciels... > sans effet
iMac 21.53 OS X 10.9.1

CONNEXION UTILISATEUR