Logic Express : en cas de problèmes avec les AU sous Lion

Anthony Nelzin-Santos |
logicUn contributeur de Mac OS X Hints a été confronté à quelques problèmes avec des Audio Units 32-bits et Logic Express 9 sous Lion. La solution ? Forcer le démarrage de Logic Express en 32-bits le temps qu'il mette à jour la base d'AU, puis à nouveau le relancer en 64-bits. Les AU 32-bits seront alors pleinement opérationnels.

Pour lancer Logic Express en 32-bits, ouvrez son panneau d'informations (⌘ + I sur son icône dans le Finder), et sélectionnez « Ouvrir en mode 32-bits ». Faites la manipulation inverse pour repasser en 64-bits.

32b

Ce n'est malheureusement qu'un des problèmes de Logic sous Lion. Si la 9.1.4 a ajouté officiellement la compatibilité Lion, Logic souffre encore de nombreux bogues (notamment avec… la Magic Mouse !), bogues que la 9.1.5 proposée hier n'a pas éradiqué.

avatar boubou777 | 
Ce n'est pas à cause de lion, cela était déjà le cas sous snow Leopard, je faisais cette manipulation pour activer les AU 32 bit sur le 64 bit....
avatar mickestrat | 
Sachez que Logic Pro 8 (acheté avec Logic Studio au prix fort) ne s'installe tout simplement pas sur Lion. Le Support Technique Apple se refuse à tout geste commercial pour faciliter un upgrade et me propose juste de retourner sous Snow Léopard. J'ai bien expliqué que tous mes autres logiciels fonctionnent sous Lion. MAIS NON. C'est le logiciel que j'ai payé le plus cher qui ne fonctionne plus (un comble !!!) On me force la main ... mais le Support Technique m'a dit clairement que personne ne m'a obligé à acheter Lion.
avatar BadoqueAlex | 
@mickestrat Bien souvent, c'est l'installateur qui n'est pas compatible et pas le logiciel en lui même. Essaye de trouver un extracteur d'archives pour exporter le contenu de l'archive d'installation et l'installer par tes propres moyens.
avatar Nesus | 
@BadoqueAlex : Inutile. Logic 8 ne fonctionne bel et bien pas avec Lion. Par contre il y a un petit mensonge puisque la mise à jour de Logic 9 est bien moins cher quand on possède déjà la version antérieur. Il suffit d'acheter la mise à jour. C'est le cas depuis Logic platinium vers 7. Le prix exact je ne me souviens plus (cela fait un moment que je l'ai acheté, mais c'est moins de deux cent euros), on se retrouve avec le même Logic que tout le monde sauf qu'il y a un petit autocollant avec écrit upgrade. Donc les facilités de mise à jour existent. Pour le reste la réponse du SAV est vrai. Surtout que l'incompatibilité avec Logic 8 est su depuis un moment.
avatar Mark Twang | 
C'est vraiment pénible ça... L'équipe de développement de Logic etait-elle mobilisée pendant la phase de test de Lion ? C'est étrange.
avatar Nesus | 
Pour ne pas faire que cracher mon fiel (entre guillemets bien sûr) http://store.apple.com/fr-business/product/MB795 dans la colonne de gauche cliquer sur Mise à niveau à partir de Logic Pro ou Logic Studio* et hop le prix tombe à 199 €.
avatar mickestrat | 
J'étais évidement au fait des tarifs Mise à Niveau (je viens de Logic Express 7). Mais c'est une question de principe. Je me répète. C'est le seul logiciel que je possède (qui est aussi le plus cher et qui est développé par Apple, rappelons-le) qui ne tourne plus sous Lion.
avatar iBook 68 (non vérifié) | 
Quand un logiciel ne fonctionne plus avec l'OS le plus récent, tout le monde dit que c'est la faute de l'éditeur (Microsoft Office blablabla, il n'avait qu'a utiliser les betas de l'OS dispo depuis longtemps, blablabla toussa...). Là c'est quand même un soft Apple qui ne fonctionne plus avec l'évolution de l'OS. Je suppose que tout le monde va trouver ça normal ? Je me répète mais j'ai de plus en plus de mal à accepter de racheter toute une brouette de logiciels le jour où je change d'OS (rachat d'une machine par exemple, ça m'étonnerai qu'on puisse installer SL les prochains Mac).
avatar fif | 
@ibook68 Hopla, Logic ce n'est pas un logiciel Apple à la base. Donc il y a surement du code qui traine programmer par l'ancien éditeur. Il y a fort à parier que Logic X sera réécrit par Apple...
avatar iBook 68 (non vérifié) | 
@fif A la base c'est du Emagic c'est vrai mais bon ça fait quand même un moment que ça a été repris par Apple (à la version 6 si mes souvenirs sont bons). Je n'ose pas faire l'addition que m'ont couté toutes les mises à jour depuis la version 4 mais ça commence à faire cher la petite blague là.
avatar mickestrat | 
Il y a certainement une raison technique valable ... mais quand même !!! Une première personne au Support Technique a compris mon problème et m'a dit d'attendre pour voir une éventuelle remise. J'ai attendu. On m'a passé une autre personne qui, très sèchement, m'a dit qu'aucun geste commercial ne sera envisagé et qu'il fallait ré-installer Snow Léopard. Sincèrement, j'aurai accepté de faire la MAJ si un geste avait été fait. Je n'ai eu que du mépris.
avatar redchou | 
Logic Pro 8 ça date, mets-toi à jour mec. Genre tu as acheté Lion 30€ et ils vont t'offrir la maj de logic pro...
avatar Lesperluette | 
Logic 8 n'a pas été écrit pour le 64-bit , alors que Logic 9 , lui , il l'a été... c'est fatiguant de voir des utilisateurs s'empresser de changer d'OS dès qu'un nouveau sort sans vérifier la compatibilité de leurs soft/système , et après gueuler après le fabricant parce que ça ne marche plus ..ce n'est pas comme si apple et les sites d'info sur le mac et Co n'avait pas fait plusieurs articles sur les compatibilités de Lion ... Il est plus facile de râler après coup , que de bien s'informer avant coup ...
avatar Monsieur Albert | 
@[b]mickestrat[/b] Sérieusement ? Vous vous plaignez qu'un logiciel sorti en septembre 2007 (il y a 4 ans et 2 OS) ne tourne pas sous le nouvel OS sorti il y a 3 semaines, en faisant abstraction de la MÀJ majeure intervenue en 2009 (à un prix minoré), sur laquelle vous vous estimez de surcroît légitime à demander une remise ? Vraiment ? Et en plus c'est pas de votre faute si vous n'avez pas pris la peine de vous renseigner ? Sinon les gars, vous pouvez faire comme tout le monde si le fonctionnement optimal de Logic est important pour vous: continuer à bosser sous SL le temps (long) que les choses se tassent ou que Logic X arrive. Bref, comme à chaque fois qu'il y a de gros changements quoi. Ça ne vous empêche pas d'installer Lion sur une autre parto pour le fun, et si vous êtes entre deux projets et que le coeur vous en dit, de mettre Logic sur dessus pour voir comment ça se tient. C'est quand même des pratiques de bon sens tout ça.
avatar mickestrat | 
Je suis tout a fait sérieux ... et juge ma revendication et mes propos modérés. Ce n'est qu'un coup de gueule. Je ne suis pas du style à courber l'échine en ouvrant mon porte-feuille. Pour information, j'ai évidement partitionné mon disque dur pour avoir les deux systèmes et continuer à utiliser Logic 8.
avatar Monsieur Albert | 
Hé bien, lol, alors.
avatar brouttegazon | 
Ceci dit, pour avoir fait la Maj de Logic Pro 8 vers 9 l'an passé, elle vaut le détour ! Et elle est moins chère ici : http://www.univers-sons.com/audio/apple-logic-pro-ou-studio-logic-studio-9-mb798.html
avatar dtb06 | 
Le problème n'est pas seulement que les softs ne tournent plus sur le nouveau système, mais qu'Apple ne permette pas d'installer les anciens OS sur du nouveau matériel. Exemple : vous achetez au prix forts des logiciels pros sur un mac, deux ans après ce mac tombe en rade et la seule solution sue vous avez est d'acheter un Mac neuf avec une nouvelle licence (souvent plus cher que le matériel). Ca n'arrive pas sur PC, il suffit de réinstaller Windows XP sur un PC de 2011 et les logiciels payés à prix d'or continuent à fonctionner...

CONNEXION UTILISATEUR