OpenCore Legacy Patcher gère des Mac de 2011 et la dernière bêta de Monterey

Nicolas Furno |

OpenCore Legacy Patcher est un programme qui permet d’installer les versions récentes de macOS sur des Mac qui ne sont plus pris en charge par Apple. Je l’ai utilisé avec succès sur mon MacBook Pro de 2014 et macOS Monterey tourne parfaitement dessus depuis cet été.

J’ai installé macOS Monterey sur mon MacBook Pro de 2014 abandonné par Apple

J’ai installé macOS Monterey sur mon MacBook Pro de 2014 abandonné par Apple

Ce programme est en bêta et son développement se poursuit rapidement. Courant août, il a gagné une interface graphique qui évite d’avoir à bricoler dans le terminal. Et sa dernière version sortie il y a quelques jours est l’une des plus grosses jamais proposées, avec plusieurs nouveautés significatives et notamment la prise en charge de Mac plus anciens. En particulier, elle active l’accélération graphique de macOS Monterey sur des modèles qui ne sont pas compatibles avec Metal, l’API graphique maison d’Apple.

Pour le moment, cette nouveauté concerne deux générations de processeurs Intel, dont la famille Sandy Bridge qu’Apple a utilisée en 2011. Tous les Mac sortis cette année-là devraient ainsi pouvoir bénéficier de macOS Monterey grâce à OpenCore Legacy Patcher. Le programme ajoute aussi ce qu’il faut pour les puces Wi-Fi et Bluetooth de ces anciens Mac, si bien que la prise en charge devrait être correcte. Par ailleurs, les fonctions de sécurité natives du système seront aussi maintenues sur ces modèles.

L’autre grosse nouveauté concerne la dernière mise à jour de macOS Monterey. La bêta 7 ne pouvait pas s’installer avec les anciennes versions du programme, son processus d’installation était correctement lancé mais le Mac redémarrait au milieu de la procédure et on restait bloqué sous la bêta 6. C’était le cas sur mon Mac et a priori pour tous ceux qui utilisaient cette solution.

Pour continuer à bénéficier des dernières versions de macOS 12, téléchargez OpenCore Legacy patcher 0.2.5 (choisissez le fichier GUI par simplicité) et cliquez sur le bouton « Build and Install OpenCore » pour mettre à jour l’installation. Pensez bien à faire une sauvegarde du Mac avant toute chose, redémarrez après la procédure et si tout va bien, la bêta 7 pourra être installée dans la foulée.


avatar iftwst | 

Tentant certes ….mais quid d’une maj de sécurité qui fera potentiellement voler en éclat cette belle initiative ?

avatar Nesus | 

@iftwst

Ça ne pose pas de problème. Ça ne modifie que l’efi. En gros, ça dit à MacOS que l’appareil utilisé est compatible. Du coup, même traitement que pour tous les autres macs. D’où certaines incompatibilités qui sont patchées au fur et à mesure.
Si vous voulez voir comment ça s’installe, j’ai fait le détail en vidéo et avec les commentaires, je pense qu’il y a toutes les réponses aux possibles problèmes.

https://m.youtube.com/watch?v=WwrO1C0M10I

avatar mat16963 | 

@Nesus

Il faut juste espérer que ça reste toléré par Apple… car s’ils voulaient vraiment mettre des batons dans les roues ça deviendrait plus délicat je pense…

avatar idhem59 | 

@mat16963

Depuis le temps, si ça dérangeait Apple, ça n'existerait plus depuis longtemps.
D'autant plus que cette pratique va s'écrouler d'elle-même quand macOS ne supportera plus x86 dans quelques années.

avatar Nesus | 

@mat16963

Si vous le dites. Juste pour info c’est la méthode qui permet d’installer les hackintosh. Donc si Apple avait dû faire quelque chose, il y a longtemps que cela serait fait.

avatar starsk | 

merci ! Très bien la vidéo, je partage

avatar Nesus | 

@starsk

Avec plaisir

avatar Faabb | 

Le grand avantage d’OCLP est justement de pouvoir ensuite bénéficier des mises à jour tout naturellement via les préférences système.

J’ai basculé un MBP 13 " mid 2012 vers Big Sur grâce à Opencore. C’est très simple à faire et tout fonctionne parfaitement. 🤩
Je suis très reconnaissant pour le travail de toute cette communauté de devs !!
Merci à MacGe pour l’info et les articles qui m’ont convaincu d’essayer ! 🤓

avatar 0MiguelAnge0 | 

@Faabb

Cela montre à quel point Apple fait de l’obsolescence programmée. Sans sous-estimé le boulot extraordinaire de ces devs, je pense que lea devs d’Apple pourraient faire pareil.

Sauf qu’un Mac ayant une nouvelle jeunesse est un client en moins à court terme. Belle bande d’hypocrites au sujet de la protection du climat.

J’utilise le patcher sur mon MacPro 2012. K’ai mis à jour sa carte Wifi et il est compatible metal. Donc sur le papier tout est ok. Mais sans le patch cela fait 27kg d’alu obsolète…

avatar starsk | 

Bien joué. J'utilise toujours Mojave sur mon MacPro 2010, avec Open Core pour acceleration Gpu, il tourne comme une horloge depuis 1 an. Migration vers Cataline ou Big Sur prévue bientôt. Avec un nouvel Os par an ( quelle plaie ) Apple force l'obsolescence... Mon MacPro à 10 ans, il tourne toujours impec

avatar Wutanggg | 

Super nouvelle ! Je vais pouvoir passer mon Mac Mini mi-2011 au dernier système ! 🏆

avatar Spike2311 | 

L’accélération graphique est elle disponible sur un iMac 21’ de 2011 ?

avatar Nicolas Furno | 

@Spike2311

J'ai un doute, parce que ce modèle dispose d'une carte graphique dédiée. Il faudrait voir si cette dernière est prise en charge, je pense que oui, mais à vérifier.

avatar Spike2311 | 

@nicolasf

Merci pour la réponse. Je vais tester sur mon iMac 2011, il faut juste que je trouve le temps de le faire :)

avatar lll | 

Je serais curieux de savoir si ça peut fonctionner sur un iMac mi-2011 (pas Metal, donc). Cette page semble dire que oui, mais avec des réserves :

https://dortania.github.io/OpenCore-Legacy-Patcher/MODELS.html

avatar Spike2311 | 

@nicolasf

Si c’est le cas c’est super car sans l’accélération c’est pas terrible (testé avec Catalina à l’époque).

avatar Nicolas Furno | 

@Spike2311

Oui c’est clairement important. À voir si ça marche bien par contre.

avatar coink | 

@nicolasf

Les iMac 21 et 27 2009-10-11 sont supportés. L’accélération graphique sur les Radeon 4-5-6k est en bêta mais fonctionne bien. Pour profiter de l’accélération métal sans patch ni petit bugs graphiques il faut changer le GPU. Perso j’ai mis une amd wx4130 a 100$. Ça tourne Big Sur en natif sans soucis. Avec les upgrades ÔTA fonctionnelles

avatar Tagazok | 

@nicolasf

Je vais poser une question de béotien, mais où est-ce que je peux trouver l’info de savoir si ma carte graphique de mon mac serait correctement prise en charge ? Par « correctement », j’entends « ne pas faire reposer la partie graphique QUE sur l’Intel Iris pro graphics, mais utiliser mon GPU (GeForce GT 750M) »…

Si jamais quelqu’un a déjà la réponse, je parle donc d’un MBP Retina 15” late 2013

Je m’inquiète peut être pour rien, mais je lisais que des vieilles CGU n’étaient plus prises en charge et si Monterrey doit reposer uniquement sur le chipset Intel, je resterai sans doute sur BS.

avatar Nicolas Furno | 

@Tagazok

C’est une bonne question mais je préfère être honnête : je n’ai pas la réponse. 🙂

Il faudrait vérifier pour ce modèle précis ou au moins la génération en question de carte graphique.

avatar coink | 

@Tagazok

Sur le site web d’oclp tu as un tableau de compatibilité pour tous les modèles

avatar Tagazok | 

Merci beaucoup d’avoir pris le temps de me répondre, je vais aller regarder sur le site !

avatar MystR | 

Après avoir testé PatchedSur sur mon vieux MBP mi-2012, j’ai finalement choisi OCLP plus complet.
Au moins passer sur Big Sur ou Monterey permet entre autre de profiter de la musique en Lossless HR et Atmos/PCM 5.1 sans avoir à acheter pour le moment une tv 4K 😁

avatar anthony0104 | 

J’ai installé Big Sur sur mon iMac 2013 avec patchsur mais j’aimerai passer sur OCLP comment je peux faire car je ne trouve nul par des indications ?

Merci à ce qui pourront m’aider 😁

avatar Faabb | 

Clairement, vu le fonctionnement sans soucis sur mon MBP mid 2012, je vais aussi basculer mon imac mid 2014 vers Monterey lorsque l’OS sortira en version finale.

avatar Darkgam3rz | 

Big sur sur mon modeste iMac 2012 tourne très très bien ! C’est simple, tout fonctionne ! Juste les mise à jour qui sont un poil, comment dire…énorme vu que je suis passé par patcher sur (a chaque mise à jour je dois télécharger l’os entier)

Par contre j’utilise big sur sur un disque dur externe, je pense faire la manip pour monterey…mais est ce que je vais pouvoir garder catalina/big sur/monterey en même temps 🧐?

Puisque l’efi va de nouveau être modifié j’ai un doute 🤔

avatar sinbad21 | 

J'utilise OCLP sur mon MBP mid 2012 (non retina) depuis la première bêta de Monterey, et je n'ai jamais pu faire de montée de version en passant par mise à jour de logiciels. Pour la simple raison que la nécessité d'avoir à patcher le système pour que l'OS puisse utiliser la CG Intel (les drivers HD4000 sont absents de Monterey) fait que les mises à jours système ne sont plus proposées dans les préférences "Mise à jour de logiciels".
Avec la bêta 6 j'ai décidé de ne pas patcher le système, et la bêta 7 m'a bien été proposée, mais la mise a jour en passant par mise à jour logiciels a complètement foiré.

Bref, je suis obligé à chaque nouvelle version de l'OS de me créer une clé USB avec le système complet, et de faire la mise à jour par ce moyen, en prenant bien soin de passer par OCLP à chaque redémarrage, et il y a 4 redémarrages en tout. On ne peut pas le laisser se mettre à jour et faire autre chose en même temps, car il faut être là pour appuyer sur la touche option au moment opportun.

À part cet inconvénient, Monterey marche très bien.

avatar ⚜Dan | 

Correctif. Utiliser la version TUI et non GUI lol

avatar J_r_m | 

@⚜Dan

Il y a une différence ?

avatar starsk | 

super !

avatar tibcheshire | 

Salut! merci pour la nouvelle j'étais bloqué pour la beta 7 avec un MBPr 2014 je ne comprenais pas pourquoi, mais du coup la beta 8 est sortie quelqu'un a testé?
EDIT oui ça fonctionne je suis passé de beta 6 à 8

avatar olivierfaure | 

Attention Monterey beta9 ne supporte plus les cartes Nvidia, du coup pour l'instant, ça ne fonctionne plus sur les iMac 2013... je ne crois pas qu'OpenCore va proposer les drivers dans l'EFI, aucune idée si c'est faisable

CONNEXION UTILISATEUR