Un curieux bug entre Mail et ses dossiers VIP et Marqués

Florian Innocente |

Parmi les bugs de Mail dans Mavericks il en est un d'étrange qui touche le moteur de recherche ainsi que les dossiers « VIP » et « Marqués ». Pour faire simple, ils ne marchent plus. La recherche dans Mail ne retourne aucun résultat, le dossier des courriers marqués d'un drapeau est vide aussi alors que plusieurs mails en ont, et pas mieux sur les VIP.

Les captures ci-après illustrent le problème. La boite d'arrivée contient des éléments marqués d'un drapeau, mais ils n'apparaissent plus et ne sont même pas comptabilisés dans leur dossier dédié. Cela vaut autant pour des messages Gmail que iCloud.

Même dysfonctionnement chez cet autre utilisateur repéré sur un forum d'Apple, plusieurs courriers sont marqués d'un drapeau rouge, mais aucun n'est décompté dans le dossier « Flagged/Marqués ». Il arrive aussi que ce dossier « Marqués » disparaisse tout simplement de la colonne. En affectant à nouveau un drapeau à un message, il revient, mais avec les problèmes cités précédemment.

Plusieurs mails sont marqués d'un drapeau, mais le dossier qui les compile ne les voit pas

Il y a assez peu de retours d'utilisateurs sur ce problème dans les divers forums (1 & 2), mais on trouve parfois des occurrences qui remontent aux débuts de Mavericks. Les solutions proposées sont restées inefficaces : reconstruire l'index de Spotlight ; supprimer le compte mail affecté et le recréer (pas mieux en le faisant dans Mail dans un autre compte utilisateur sur le même Mac), réindexation des messages dans Mail, etc.

Chose curieuse aussi, les même comptes mail, sur une autre machine, avec la même version de système, ne présentent pas ces problèmes (et l'application de la bêta 1 du 10.9.4 ne change rien non plus). Un utilisateur explique avoir réglé ce dysfonctionnement en réinstallant son système de zéro. Un autre a contacté Apple qui lui a expliqué que ce comportement bizarroïde était connu, mais qu'ils n'avaient pas de solution à proposer pour le moment.


avatar bordchamp | 

Une solution provisoire existe : passer à Airmail. Ce dernier remplit son office, mais souffre néanmoins lui aussi d'un problème : il lui faut plusieurs minutes pour démarrer et s'initialiser complètement. Une fois lancé, il me donne toute satisfaction.

avatar Dimitri64500 | 

J'ai l'impression qu'à Mac, on passe sa vie sur l'application Mail :)
Y'a énormément d'autres bugs ailleurs !

avatar Florian Innocente | 
Ben disons que dans notre boulot on a plus besoin de Mail et ses cousins que de Snapchat :-)
avatar jujuv71 | 

Je suis rassuré, ça ne vient pas de moi...

Le bug est pas nouveau... Depuis 10.9.3

avatar lezardon | 

Un curieux bug chez macgeneration pour cet article qui apparait deux fois

avatar Yumie | 

Il y'a aussi ce bug de recherche dans les mails sur un compte iCloud. Pas de problème de recherche dans la boîte de réception mais dans un dossier c'est assez aléatoire et on obtient pas les mêmes résultats que dans la recherche sur la boîte de réception.
J'ai ce problème aussi bien sur sur l'application mail que l'interface web

avatar jujuv71 | 

@Yumie :
Idem

avatar i33210 | 

J'ai eu le même problème avec l'application "Control Center" qui permet d'activer ou de désactiver certain paramètres système dont "Spotlight". Je l'avais désactivé par mégarde et j'ai rencontré exactement les mêmes problèmes décrit dans l'article. J'ai cherché un moment avant de m'apercevoir que j'avais désactivé Spotlight. Une fois réactivé la réindexation c'est faite et tout est revenu dans l'ordre. Donc la solution est peut être de désactiver Spotlight et de le réactiver par la suite ?
Je laisse le lien de l'application "Control Center" pour ceux qui veulent essayer la manip : http://www.cindori.org/software/controlcenter/
PS : Vous pouvez la tester gratuitement

avatar Florian Innocente | 
C'est ce que j'ai fait, comme dit dans l'article, j'ai aussi refait l'indexation Spotlight mais pas mieux.
avatar PerePlex155 | 

J'ai ce problème depuis Mavericks et cela est très gênant car je gère 6 boites mails, j'ai beau activer et desactiver l'indexation de Spotlight rien ne change. Par contre la recherche marche bien sur iOS (iPad et iPhone). Va comprendre Charles !

avatar Fennec72 | 

Moi, j'ai un autre bug dans Mail.

Souvent, au lancement de Mail, la liste des VIP disparaît en cours de lancement.

Il faut quitter Mail et le relancer, parfois à plusieurs reprise, pour que la liste des VIP réapparaisse dans la colonne de gauche.

avatar iRobot 5S | 

1000 ans plus tard !

A croire que certains récoltent les bugs !

avatar popeye1 | 

Y a plus de doute, la meilleure application jamais sortie par Apple, c'est Mail ! Tout ça à cause du CLOUD probablement...

avatar MacMarc | 

Bonsoir,

Perso, ce bug de la recherche dans Mail, ça ne m'arrive qu'une fois de temps en temps.

Dans ces moments-là, j'ai beau taper le ou les mots recherchés, Mail se conduit exactement comme si je n'avais rien fait. Puis je passe à autre chose, et pas longtemps après je tais une recherche, et ça marche...

Bizarre...

avatar bradepitre | 

Le bug des VIPs est une vraie catastrophe non résolue par Apple. Comme seul Mail gère les VIPs, il est difficile de s'en passer si on utilise cette astuce sympa. En général quand la boite VIP ne fonctionne pas, il en est de même pour la boite aujourd'hui, les boites intelligentes et même les recherche dans Mail. Les solutions sont diverses et en principe inefficaces (réindexation de Spotlight; reconstruction des boites, bidouille dans Maildata ... et j'en passe). Perso, j'ai tout réinstallé. Merci Apple de m'avoir fait perdre une journée. La facture, je peux l'envoyer à Apple ;-)

A+

avatar bich63 | 

Bonjour à tous,

Le problème décrit est exactement le mien.
A votre connaissance, toujours pas de solution autre que d'utiliser airmail? la réinstallation, c est formater le mac et repartir de zero?

Merci

avatar bradepitre | 

J'a eu le problème 2 fois. La 1ère fois j'ai tout commencé à ZERO, bonjour le job pour ne rien oublier. Mais ça marche. Sur une autre machine, j'ai simplement installé Yosemite par dessus, ça a aussi marché.

avatar bich63 | 

je suis sous yosemite et le bug est apparu depuis je crois.

A ton avis, je meux reinstaller yosemite et faire une restauration a partir de ma time capsule? ou ca me restaurerra le bug...

avatar bradepitre | 

J'avais essayé la restauration de la TC et aussi depuis un clone. Sans compter tout le reste (réindexer spotlight, supprimer les fichier "envelope", reconstruire les boites: pas de résultat probant. Le problème de la restauration est, si tu restaures alors qu'une sauvegarde a déjà eu lieu, tu vas réimporter le bug.

avatar psfayt | 

récidive avec sierra : les services de recherche de mail et calendrier ne fonctionnent pas, spotligth n'est guère plus brillant et très capricieux en fonction des dd rattachés ou non, exclus ou non de l'indexation ...

des idées pour stabiliser?

la solution sur le forum : virer le fichier "/.Spotlight-VT100" ... tout repart normalement!

avatar tuile | 

bonjour. J'ai installé big sur et je constate la même bizarrerie à propos des drapeaux dans mail : ils n'apparaissent pas, ce qui rend selon moi leur utilité caduque. Contrairement à Florian, chez moi, dans les boîtes dédiées, ces drapeaux sont comptabilisés, classés par couleur et reprennent les mails correspondants. Cependant, quel est l'intérêt de placer un drapeau pour identifier un mail mais pour s'en apercevoir, il faut chercher ailleurs ?! Tout autre chose, si je puis me permettre : sauvegarde de l'iphone impossible (pas de barre d'outil apparente dans la fenêtre, seule l'option "restaurer" apparaît mais ne fonctionne pas, l'iphone étant quand même reconnu !). Problème sous catalina mais non résolu suite à l'installation de big sur (à l'inverse, les drapeaux de mail se voyaient à côté du message sous catalina). Quelqu'un aurait une piste ? merci

CONNEXION UTILISATEUR