Boot Camp gérera Windows 7 d'ici la fin de l'année

Christophe Laporte |
A l'occasion de la sortie de Windows 7, Apple a fait savoir qu'elle proposerait d'ici la fin de l'année une mise à jour de Boot Camp pour Snow Leopard afin de pouvoir installer la dernière version du système d'exploitation de Microsoft (Home Premium, Professional, et Ultimate).


Toutefois, Apple a fait savoir que tous ses ordinateurs ne seront pas supportés pour faire fonctionner Windows 7. Sont disqualifiés :
- iMac (17-inch, Early 2006)
- iMac (17-inch, Late 2006)
- iMac (20-inch, Early 2006)
- iMac (20-inch, Late 2006)
- MacBook Pro (15-inch, Early 2006)
- MacBook Pro (17-inch, Late 2006)
- MacBook Pro (15-inch, Late 2006)
- MacBook Pro (17-inch, Early 2006)
- Mac Pro (Mid 2006, Intel Xeon Dual-core 2.66GHz or 3GHz)

avatar Edge@51 | 

Ahhhhhhh, mon macbook pro n'est pas suporté, c'est quoi cette histoire!!!! Windows 7 est 32bit, je ne vois pas pourquoi les CoreDuo seraient exclus (à moins que ça ne vienne de l'EFI???). Mince, ça m'arrange pas tout ça :(

avatar cousinhube | 

bizarre, bizarre, je suis entrain de laisser ce message sous Windows 7 avec un MacBook Pro sur lequel j'ai installé l'OS ce matin et ce avec l'assistant Bootcamp et les drviers intégrés au DVD d'install de Snow Leopard...

avatar Nitiel | 

Et pour leopard ?

avatar ALEX95 | 

@cousinhube

Effectivement, ça me semble bien du apple tout ça.

M'en fiche, mon iMac 24' est supporté, mais je paierai pas la peau de mes chères fesses un OS qui ne lira que mes jeux, XP le fait très bien, pas besoin de cette nouvelle demie-daube M$ =P

avatar arsinoe | 

[quote=cousinhube]
bizarre, bizarre, je suis entrain de laisser ce message sous Windows 7 avec un MacBook Pro sur lequel j'ai installé l'OS ce matin et ce avec l'assistant Bootcamp et les drviers intégrés au DVD d'install de Snow Leopard...[/quote]

En fait, toute machine faisant tourner Vista fait tourner Windows 7.

La plupart des drivers sont les mêmes.

Et si ces drivers ne sont inclus dans le package Bootcamp, ça n'a aucune importance vu que Windows 7 va les chercher en ligne et que sur du matériel aussi répandu et récent que des Macintel même coreduo, ça ne pose aucun problème.

Bref un pipeau complet cette annonce d'Apple.

avatar tib51 | 

Ben mince alors !
Mon MacBook Pro Core 2 Duo late 2006 est exclu ! Je ne vois pas pourquoi, alors que 7 fonctionne sur des config beaucoup plus petites !

avatar wooper69 | 

@ arsinoe
avant de poster et dire qu'une infos c'est du pipeau, tu devrais connaître ton sujet avant.
les drivers de Bootcamp sont écris par Apple, pour tenir compte des particularités du hardware Apple (clavier, souris, carte mère, etc)

avatar foudeapple | 

incroyable mais vrai : mon macpro 2,66 Ghz n'est pas supporté ?? étrangement, windows 7 fonctionne nickel.... pas clair cette histoire...

avatar Superboy58 | 

Alex95 : C'est pas évident...justement aujourd'hui une news sur Clubic indique qu'un jeu qui sortira prochainement sera le 1er à ne plus supporter Directx 9 c'est à dire que la config minimal est Vista/Seven. Pourquoi ? tout simplement parce que XP a maintenant fais largement son temps et les nouveaux jeux piétinent à cause de XP et de ses technologies vieillissante.
Donc je pense que d'ici 6 mois voir 1 an maxi, Directx 9 c'est entièrement finis.

avatar valentinnb | 

euh, Seven tourne sur mon iMac depuis maintenant 1 mois sans le moindre souci.

Donc je rejoins arsinoe : ça relève bcp plus de l'effet d'annonce qu'autre chose, vu que tout fonctionne déjà parfaitement.

avatar Superboy58 | 

Sinon concernant la news je confirme que Seven tourne sur des config plus petite : c'est bien simple, à la fac on a déjà certaines salles équipées sous Windows 7 Pro et ça RAM pas alors que les même machines avec Windows 2000 c'était horrible à utiliser. Donc la limitation est un peu bête d'autant que Seven 32bits tourne sur des Intel Atom à 1,10 Ghz --> cf la nouvelle tablette tactile de Archos annoncé aujourd'hui sous Windows 7

avatar divoli | 

Et sur les machines qui sont éligibles, mais un peu "vieilles" (je pense notamment à celles de 2007, équipées de C2D), est-ce que l'on pourra installer et booter sur une version 64 bits de 7 ?

On ne peut pas sur ces machines booter en 64 bits avec SL.

avatar ALEX95 | 

l@Superboy58 : Y'a une version pirate (hoouh, pas biiiien) de Direct X10 pour XP, ça marche sans soucis.

Bon, si en plus 7 va chercher les drivers sur le Net, alors pourquoi y aurait-il des restriction ? Evitez de mettre à jour Bootcamp si vous avec un Mac listé, ça vous coûtera à tout les coups votre 7

avatar Frodon | 

@wooper69

Cela est partiellement vrai ce que tu dis, seul les drivers des périphériques spécifiques Apple sont écrit par Apple, ce qui concerne donc:

- Clavier (touches de fonction, layout, retro-eclairage...)
- Trackpad (Multitouch)
- Ecran (réglage de luminosité...)

A par cela, les drivers des composants standards sont fait par leur constructeurs respectifs:

- Chipset (Intel ou NVidia)
- Carte graphique (Intel, ATI ou NVidia)
- Carte son (Intel)
- SATA (Intel)
...etc.

Donc ce que tu dis n'est vrai que pour quelques périphériques Apple, mais pour la majorité du matériel qui est standard (chipset carte mère, CPU, GPU, Puce son, WiFi, Bluetooth...etc), Apple ne fait que redistribuer les drivers des constructeurs respectifs.

avatar Frodon | 

@divoli

Je pense que oui. Si certaines machines C2D sont exclu du boot 64 bits de SL c'est pour l'une des deux raisons suivantes:

- EFI 32 bits (Apple n'a visiblement pas jugé bon de développer une passerelle pour pouvoir lire les paramètres PRAM des EFI 32bits depuis SL booté en 64 bits)
- Drivers 64 bits non encore disponibles pour certains composants (notamment il n'y a pas de driver 64 bits pour les machines utilisant un chipset graphique Intel (GMA 950 ou X3100), il semble que la 10.6.2 apporte des versions 64 bits de ces drivers).

Windows 7 n'a pas d'autre choix que de supporter le BIOS qui n'est même pas 32 bits en général, puisque la majorité des PC sont équipé de BIOS. Du coup puisque BootCamp utilise une couche de compatibilité BIOS, il n'y a aucune raison pour que 7 64 bits ne boot pas.

avatar hendack | 

Ouaip Win7 ultimate tourne très bien sur mon macpro dualcor 2x2,66 et sur le macbook pro unibody, avec les driver boot camp de snow leopard... pourquoi attendre ?

avatar Neopollux | 

Une seule chose à dire : magnez-vous le popotin pour Boot Camp, parce que j'ai 7 officiel depuis ce midi au boulot et ça envoie le bois :o) (passage XP -> 7)

avatar Almux | 

Cela m'étonnerait énormément que VMware sur mon MacPro 2006 ne puisse virtualiser W7... Faudra bien que je puisse tester les sites sur les dernières versions de IE... A moins que...

avatar arsinoe | 
avatar Superparati | 

Étrange de la part d'Apple, c'est une liste de machines dite Pro, à part les iMacs.

Un MacPro dans la liste ^^ impossible, s'il tourne sur des MacBooks quels qu'ils soient, W7 ne pourra que mieux se comporter ! (logiquement)

avatar lemail2mi | 

La news ne dit pas que win7 ne marche pas sur ces machines, elle dit que apple n'apportera aucun support pour bootcamp sur ces machines. Il y a une nuance, quand apple arrête le support d'un type de machine elle n'arrêtent pas de fonctionner par magie.
Apple dit seulement qu'il ne garantissent pas le fonctionnement de leurs drivers avec win7 sur ces machines. Maintenant si vous arrivez quand même à faire fonctionner win7 tant mieux pour vous.

avatar Atlante | 

La liste d'Apple ne veut rien dire. Son présent les iMac 17pouces mais pas les mini CoreSolo? Toutes les machines cités seront supportés officieusement, pas de quoi s'inquiéter.

avatar mac-fan | 

je men fou jais jamais mis bootcamp et je le ferais jamais.

avatar lukasmars | 

Enfin une news ou personne ne gueule aprés Apple et ses limitations ( alors qu'ils devraient ) et personne ne gueule contre Windows !
Mince Gimli fils de gloin, viens prêcher la sainte parole !

avatar skhattane | 

+1 lemail2mi
J'ai compris comme toi, à savoir qu'Apple ne fait plus de support pour les machines cités lors d'une utilisation sous windows 7 via bootcamp. En gros, ils ne feront plus de mises à jours de drivers spécifiques à windows 7 pour les composants de ces machines. En aucun cas il est question d'une incompatibilité hardware, software empêchant l'installation de 7 sur lesdites config.

avatar whyn0t | 

J'ai 7 avec MSDN depuis plus d'un mois, les pilotes parfaitement fonctionnels 32 et 64 bits pour macbook pro unibody sont sur le boot camp de SL depuis le début, je ne comprends donc pas trop le sens de la news puisque c'est pas une nouveauté en fait. J'ai loupé un truc ?

avatar smitch | 

J'ai déjà Windows seven ... et il est très bien supporté depuis le début ...

avatar Hubcube | 

Ne vous fiez pas trop à ces limitations et essayez vous-même. Moi j'ai installer Windows 7 sur mon macbook 2007, tout est supporté parfaitement et fonctionne encore mieux que XP. Par contre il faut changer des drivers, dont celui du clavier et du trackpad que vous devez désinstaller en version 3.0 pour réinstaller ces composants 2.0, ce qui est assez étrange. Au moins ça fonctionne ;)

avatar angealexiel | 

cette news doit etre mal traduite ya aucune raison que windows seven ne marche pas sur ces config... c impossible ... donc paniquer pas si vous installer vista vous mettez seven , va fait depuis 1 an que je suis sous seven sur mon macbook pro alu fin 2008 et mon mac pro debut 2008

avatar MacFly | 

Quand Apple dit "pas de support" ca veut pas dire que ca marche pas, mais juste qu'ils n'aideront pas a régler les problèmes !

avatar Liam128 | 

Personne n'a relevé ce qu'a dit ALEX95, dommage car c'est une connerie :
Il n'existe pas de DX10, même pirate, pour XP. Ce serait techniquement à peu près infaisable, DX10 reposant sur le nouveau modèle de drivers graphiques.
Il existe un wrapper qui transmet les instructions DX10 à OpenGL (qui dans ses dernières versions a des fonctions équivalentes, et qui lui ne repose pas sur le nouveau modèle de drivers), pour qu'elles soient ainsi exécutées par OpenGL.
C'est assez différent, et c'est surtout assez loin de "marcher sans soucis", ce sera probablement à peu près inutilisable pour un gros jeu qui utilise les technologies DX10/11 (hé oui Seven est fourni avec DX11) en masse, car ça reste de la bidouille et c'est assez buggé/incomplet.
Au bout d'un moment il faut accepter de vivre avec son temps. Win7 arrive et il assure pas mal. Aller dans les bidouilles les plus hallucinantes pour essayer de vaguement émuler DX10 sous XP alors que le 11 est déjà là, ça n'a plus beaucoup de sens.

Mais bon, je sais quel est le vrai problème pour beaucoup... c'est pas une question de perfs ou de qualité de l'OS, mais c'est surtout que WinXP est très très facile à pirater, alors que Win7 l'est beaucoup moins.

avatar mochi | 

Ca marche très bien Windows 7 avec boot camp et snow leopard...
J'ai installé la x64 Professionnal il y a 3 semaines, ce n'est ni une beta ni un pirate mais une version "ecole".

avatar BadoqueAlex | 

JE crois qu'ils ont oubliés de préciser quelque chose ... Windows 7 32 bits est compatible sur TOUS les macs intel. Cependant, la version 64 bits n'est seulement compatible qu'avec les macs ayants un EFI 64 bits, ce qui exclue donc ceux cités dans cette news.

avatar dachmt | 

J'ai un macbook pro de septembre 2009, et j'ai installé Windows 7 Pro via Boot Camp. Je n'ai eu aucun problème du peu que j'ai testé... Du moins tous les pilotes fonctionnent bien.

avatar gsinomed | 

lukasmars [22/10/2009 22:34]

Enfin une news ou personne ne gueule aprés Apple et ses limitations ( alors qu'ils devraient ) et personne ne gueule contre Windows !
Mince Gimli fils de gloin, viens prêcher la sainte parole !

EH ! ne le cherche pas , il a planté son vieux Mac en essayant d'installer crosoft en cachette !!! ;-)

avatar fcb | 

La RC fonctionne très bien sur un iMac de Juin 2009...

avatar DrFatalis | 

Qui aurai cru, il y a quelques années, que des "mac" users pourraient trouver regrettable de ne pas installer la dernière version de windows sur leur machine...
R.I.P., Macintosh...

avatar olivmc | 

Quelqu'un a-t-il testé Windows 7 sur un :

[i]Mac Pro (Intel Xeon Dual-core 3GHz) ?[/i]

Merci !

avatar BadoqueAlex | 

Il est installé chez moi sur un MacPro 2,66 Ghz. Tout fonctionne parfaitement (Sauf le clavier qui n'à pas les fonctions spéciales bien évidemment).

avatar husker42 | 

Etrange ca fait 1 mois que je tourne avec Windows 7 PRO et ca marche, quoique bootcamp n'est pas parfait, et j'ai pu installer le 64 bit, mais c idiots d'apple, bloquent bootcamp. Vivement mon thinkpad.

avatar husker42 | 

Apple et ca limitation EFI 64, suivi de pas de mise a jour pour les macbook unibody est complétement absurde. Soit il ne savent pas ou ils naviguent et n'on pas de plan à long terme, soit ce sont des gens qui se foutent des clients. Le résultat est le même, ce sont des mononeurones. Quoique cette logique s'inscrit parfaitement avec leur bouse d'iTunes. Douce merde d'Artémis, le mac c'est fini.

avatar slash63 | 

Pour ma part c'est pareil Windows 7 tourne sans problème grâce a bootcamp sur mon iMac 2009 et mon Macbook pro 2008, et tout fonctionne nickel, souris, pad, clavier etc...
bizarre cette annonce.....

avatar bcldvd | 

Moi j'ai Seven sur le dernier MBP, ça marche tres bien, en bootcamp, les drivers sont ok, tout marche parfaitement....

avatar PER180H | 

Y'a pas le Powerbook G4 Titanium dans la liste des disqualifiés ?
Bonne nouvelle :D

avatar Bmastro | 

j ai un mac book pro de septembre 2009, tout fonctionne avec W 7 (64)sauf le trackpad, et bien bien d'autres choses, avant de donner des recettes certains feraient bien de contrôler, il faut effectivement attendre la mise à jour de Bootcamp, prévue par apple. Par contre bien entendu tout fonctionne avec Parallel, avec la parttion virtuelle crée avec bootcamp (mais ceci est une autre histoire...)...

avatar eliotus | 

Ils vont nous sortir les drivers le jour de nöel si ça continue... Moi j'ai un macbook 2ghz 9400M De début 2009 et selon bootcamp mon ordinateur n'est pas compatible...

avatar Sebang | 

Y'a-t-il une raison véritable au non support des configurations ci-dessus ou c'est de la limitation à la Apple pur jus ?

avatar Benlop | 

Étonnant que le MacBook 2006 soit supporté (et ouf ! J'en suis.) alors que le Pro ne l'est pas... !

CONNEXION UTILISATEUR