macOS 10.15.7 : en cas d'emballement du processus accountsd 🆕

Stéphane Moussie |

Mise à jour le 2 octobre : vous avez été plusieurs à nous signaler dans les commentaires ou par email d'autres types de manipulations qui ont résolu le problème. Notez bien que celles-ci ne fonctionnent pas à tous les coups :

Par ailleurs, nous avons ajouté une précision sur la manipulation liée aux lignes de commande. Après avoir saisi ces lignes dans le Terminal, il faut copier le contenu du dossier ~/Bibliothèque/Accounts/Backup vers le répertoire ~/Bibliothèque/Accounts/ et après cela éventuellement redémarrer l'ordinateur.


Depuis l'installation de macOS 10.15.7 sorti la semaine dernière, des utilisateurs se plaignent d'un emballement du processus accountsd. Chez certains, ce processus lié aux comptes enregistrés sur le système s'accapare toute l'activité du processeur, entraînant un ralentissement général du Mac.

Si vous constatez des lenteurs sur votre Mac depuis la dernière mise à jour, ouvrez le Moniteur d'activité et regardez si l'occupation CPU de accountsd est exagérée. Si elle est de 400 %, par exemple, c'est qu'il y a un problème.

Dans ce cas-là, Mr. Macintosh suggère diverses opérations à tester. Un simple redémarrage ou réactivation du Wi-Fi suffit parfois à résoudre le souci. Autrement, il faut tenter la reconnexion à iCloud et aux autres comptes internet dans les Préférences Système.

Si ça ne donne rien, il faut dégainer le Terminal pour redémarrer manuellement le processus défectueux en saisissant ces lignes de commande (au passage, une sauvegarde de la base de données iCloud est effectuée) :

sudo -v ; killall -9 accountsd com.apple.iCloudHelper ; defaults delete MobileMeAccounts ; mkdir ~/Library/Accounts/Backup; mv ~/Library/Accounts/*.sqlite* ~/Library/Accounts/Backup/ ; killall -9 accountsd com.apple.iCloudHelper ; sudo reboot

Après avoir saisi ces lignes dans le Terminal, il faut copier le contenu du dossier ~/Bibliothèque/Accounts/Backup vers le répertoire ~/Bibliothèque/Accounts/.

Si le problème persiste après ça, un rétropédalage sur macOS 10.15.6 à l'aide d'une sauvegarde est à envisager sérieusement.

Mise à jour à 14h11 : comme vous êtes plusieurs à le signaler, macOS 10.15.7 n'est pas le seul touché par ce problème. Des versions antérieures sont également concernées, tout comme Big Sur. Après l'installation de la neuvième bêta de macOS 11, le processus accountsd a fait tourner les ventilateurs et tourner en bourrique l'un de nos Mac. Un redémarrage a suffi à régler le problème.


avatar moitoutsimplement | 

@bl@ck warrior_69

Moi aussi je l’avais sous Mojave, et les versions antérieures de Catalina.

D’ailleurs ça fait un moment que ça ne me l’a pas refait.
Le problème me semblait venir de Mail et d’un compte Exchange.

avatar calvojc | 

Je suis sous OS 10.15.6 et je viens d’avoir ce problème aussi sur un MacBook Pro 13 2020 la température surveillée par TG pro indiquait 90*

avatar Darkgam3rz | 

Bonjour à tous

Je viens de contrôler sur mon iMac 2012 (je sais c’est un dinosaure le machin), sur le moniteur d’activité je suis à 3% d’utilisation système, parfois moins, et heureusement 😅

J’ai juste parfois la roue colorée quand j’ouvre réglages, le temps que mon compte iCloud apparaisse, je ne sais pas si c’est normal.

Je dois prendre un portable rapidement (sans pouvoir attendre les arm) mais quand je vous lis je me demande si je ne vais pas plutôt me diriger vers un pc 🤨

avatar raoolito | 

@Darkgam3rz

il suffit de voir les effets derniere mise à jour windows 10 pour comprendre que de ce coté vous ne verrez pas de différence...

avatar Darkgam3rz | 

@raoolito

Bonjour

En effet je viens de voir les résultats sur Google ☹️

avatar raoolito | 

@Darkgam3rz

je compatis.
Le plus terrible ici, c’est que catalina ou (pire) mojave, ce sont des OS rodés à la Xeme mise à jour donc globalement les plus fiables qu’on puisse imaginer…
Et là, patatra...

avatar r e m y | 

@raoolito

Mais ce n'est pas vraiment l'OS qui deconne, mais le dialogue d'authentification avec les serveurs iCloud qui n'aboutit pas en raison d'une erreur de syntaxe ...

avatar andr3 | 

@r e m y

C’est aussi la «  complexité » d’authentification mise en place par Microsoft 2FA sur Office 365.

Les latences existent et peuvent engendrer les soucis comme ceux rencontrés par accountsd.

avatar Pimentpub | 

SURTOUT PAS AVEC LE TERMINAL !
J'ai appliqué cette solution, cela à flingué mon Mac mini 2018 et donc en final, une belle boite noir inutile !
J'ai passé plus de 4 heures pour réinstaller un système: effacer le disque dur, ensuite installer d'abord Mojave et après Catalina 10.15.6 (pas eu le choix, du fait que mes sauvegardes sont en APFS)

avatar raoolito | 

@Pimentpub

pour installer catalina comme OS propre, c’est tres facile, demarrez avec option+Command (pomme)+R
le système qui demarrera du net sera catalina et l’installation sera catalina derniere mise à jour.
Evidement si vous vouliez reinstaller votre setup depuis un backup c’est autre chose.

avatar sergiobzh | 

J’ai eu ca juste après la mise à jour 10.15.7 sur mon MBP 16" , dans les 500-600% de CPU.
Reboot, wifi Off-On , rien ne changeait . A noter que je n’ai pas de compte Exchange (souvent suspecté sur les forums US) .
J’ai laissé tourner et comme par miracle ça a fini par disparaître !!

avatar Kep Che | 

Pour moi le redémarrage n’a pas suffit j’ai utilisé le logiciel maintenance et depuis c’est ok

avatar ljb | 

Le logiciel de maintenance c'est quoi?

avatar raoolito | 

@ljb

onyx / maintenance, vous trouverez

avatar ljb | 

La commande de terminal fonctionne, mais quand je tente de me reconnecter à iCloud, le problème s'envenime: le processus de connexion n'aboutit pas de me connecter + accountd qui utilise 500% de processeur… Double effet kiss cool!

avatar Compaylyon | 

Meme problème que vous. J'ai passé la commande dans le terminal. Les ventilos se sont arrêtés, mais impossible de reconnecter le compte iCloud depuis. Que faire ?

avatar r e m y | 

@Compaylyon

Attendre qu'Apple règle le problème qui touche TOUTES les versions de macOS ayant reçu la dernière mise à jour de securite (high Sierra, Mojave et Catalina)

MacG a fait un article hier sur ce problème touchant Mojave en déconseillant d'appliquer la mise à jour de sécurité, celui-ci concerne Catalina, mais c'est bien le MÊME problème.

avatar Compaylyon | 

ok, merci. J'attends la prochaine mise à jour

avatar mk3d | 

Sinon déconnecter de iCloud et reconnecter. Presque du 100% en résultat. iCloud est une charognerie pour ça, un grain de sable et tout bloque. La déconnection/reconnection résout bien souvent tous les problèmes liés à iCloud. Bon courage.

avatar louik | 

Un coup d’Onyx est bien plus rapide et indolore dans mon cas qu’une resynchronisation des photos en cas de déconnexion d’iCloud.

avatar mimot15 | 

@louik : oui complètement d'accord. La synchro peut effectivement être très longue et ce même avec une bonne connexion, j'en ai fait la triste expérience il y a quelques jours. En plus Onyx ne fait pas de bobo au système..

avatar mimot15 | 

Bon, super qu'il y ait des solutions qui apportent des réponses.. mais une petite question quand même : comment se fait-il qu'absolument personne chez Apple (ou chez les développeurs ?) n'a vu ce problème qui s'est fait jour dès la parution de la MàJ ?

Il y a encore quelqu'un qui teste chez Apple, je pense que non ? Même un stagiaire fraîchement arrivé chez Apple aurait vu ce bug s'il avait eu la config en main. Bug ? Non, MàJ pas terminée !

avatar Hideyasu | 

J’avais ce problème sur la .6, le passage sur la dernière maj a régler le soucis.

avatar docmib | 

Chez nous le problème a été réglé de manière simple:

Désactivation d’iCloud sur les ordinateurs concernés et redémarrage en attendant la prochaine mise à jour... on a pas revu le problème depuis !

avatar unfolding | 

Ce qui est vraiment idiot est que ce problème est venu (chez moi) avec 10.15.7. Ça me rappelle le bon vieux temps quand quelque chose ne marchait plus après une mise à jours correctives vous Windows.

avatar Darkgam3rz | 

J’espère que ce ne sera pas la dernière version de catalina, parce que les gens qui ne traînent pas sur les d’infos comme macge, ils font comment ? Et pareil pour les bécanes qui ne peuvent passer a big sur 🤦🏻‍♂️

avatar Biking Dutch Man | 

Un an plus tard, révision .7 et toujours un goût de beta inachevée. CATAlina porte décidément tellement bien son nom.

avatar r e m y | 

@Biking Dutch Man

Ce n'est pas un problème lié à Catalina. Les version HighSierra et Mojave ont exactement le même problème avec la dernière mise à jour de sécurité.
Le problème vient du dialogue avec les serveurs de d'authentification iCloud qui se plaignent d'une requête comportant des erreurs de syntaxe.
Soit une même erreur de syntaxe a été embarquée avec la mise à jour de sécurité des 3 versions de macOS qu'Apple suit encore, soit'Apple a volontairement modifié la syntaxe de ce dialogue d'authentification et a juste "oublié" de mettre à jour les serveurs pour qu'ils acceptent la nouvelle syntaxe.

avatar YakaYaka | 

juste un truc en passant.
La commande dans le Terminal déplace les comptes de Mail.
Gros stress chez ma femme qui n'avait plus aucun mail ni comptes dans l'application.

Il serait bon d'ajouter dans l'article qu'il faut ensuite recopier les fichiers du répertoire Backup vers le répertoire parent.
Pour ceux qui connaissent le sens des commandes dans le Terminal, ça semble évident, mais pour le néophyte c'est la panique.
Dans notre cas, je suis simplement passé par le Finder pour recopier le contenu du backup à sa place originale.
Le processus ne s'emballe plus depuis.
Ce qui reste surprenant c'est que nous avons de machines similaires (MBP) et que (jusqu'à présent) je n'ai pas été touché par ce désagrément.

Une autre constatation aussi, impossible de se reloguer sur son compte Apple. Le mot de passe (qui fonctionne sur la page web iCloud.com ) n'est pas reconnu.
Ce n'est qu'après avoir remis les fichiers à leur place, que le compte s'est reconnecté tout seul.

avatar davidmi | 

Bonjour,
J'ai exactement ce problème, mais je ne vois pas comment récupérer les fichiers déplacés. Pouvez vous préciser comment les retrouver ? (Désolé j'ai suivi bêtement les commandes dans terminal et depuis plus rien ne marche). Merci par avance

avatar Stéphane Moussie | 
@YakaYaka : en effet, c'est important, j'ai ajouté une précision.
avatar r e m y | 

Amusant la mise à jour de l'article: "comme vous êtes nombreux à nous le signaler, Catalina n'est pas le seul concerné..."

Vous devriez lire vos propres articles, parce que les 1ers à parler de ce souci,ici, c'est quand même VOUS, la rédaction, il y a déjà 2 jours!

https://www.macg.co/macos/2020/09/macos-mojave-cascade-de-problemes-avec-la-mise-jour-de-securite-116731

😂

avatar Stéphane Moussie | 
@r e m y : l'article que tu mets en lien parle d'un problème différent. Quand je dis que "macOS 10.15.7 n'est pas le seul touché par ce problème [d'accountsd]", je parle de macOS 10.15.6, par exemple.
avatar macbookpro2016 | 

hello j'ai désactivé le disque principal du mac dans spotlight dans confidentialité et c'est partie je suis sur imac 5K 2019

avatar Tetaroide Bleu | 

Oh misère... je pensais y avoir échappé, vu que je l'ai installée le jour même (je sais, c'est bête), et que je ne voyais rien arriver. Mais voilà que ce soir, d'un coup, alors que je regarde tranquillement une série, ça ventile à fond. Moniteur d'activité confirme le coupable... et après un redémarrage, rebelote direct...

avatar BessoGiovanni | 

Suppression du mot de passe dans « Keychain » du compte e-mail en erreur dans Mail. J’ai pu ainsi reconnecter mon compte mail et depuis je n’ai plus de problème lié au processus « Accountsd ».

avatar Gulivert | 

Même problème Mac inutilisable, le kill du process marche quelques secondes puis le process restart. Finalement j’ai désactivé tout mes comptes et plus de problème. Mais c’est quand même la loose. On bosse avec nos Mac et là franchement s’est inutilisable avec des comptes activés!

avatar raoolito | 

@Gulivert

ce qui m’etonne c qu’apple a reagit sur mojave mais pas de nouvelle pour Catalina...

avatar jacobinet | 

Même problème, solutionné avec une clean install et 12h de boulot pour tout réinstaller, paramétrer.

Cela-dit, elle était prévue... Je fais toujours ça lorsque macOS atteint sa dernière (?) itération. Pour le moment, Catalina n'a jamais aussi bien tourné.🤞🏾 🌳👈🏽

avatar cbrr | 

Après avoir lancé les lignes de commande, grosse galère pour me reconnecter sur le Macbook Pro et mes différents iBidules.

Maintenant tout est OK sauf que je n’ai plus la liste de mes appareils dans mes réglages iCloud (appareils approuvés non disponibles).
Bizarrement, quand je veux me reconnecter, je reçois pourtant les codes d’authentification que ce soit sur Mac, iPad ou Watch.
Par contre, depuis le navigateur web, mon compte, j’ai bien la liste au complet.

Ah et depuis, localiser ma watch ne m’est plus proposé 🤔

J’ai même tenté de tout déconnecter / reconnecter, mais ça ne solutionne pas mon soucis.

Un sacré bordel tout ça.

avatar Stéphane Moussie | 
@cbrr : Après avoir saisi ces lignes dans le Terminal, il faut copier le contenu du dossier ~/Bibliothèque/Accounts/Backup vers le répertoire ~/Bibliothèque/Accounts/.
avatar guslefou | 

J’ai eu le même problème sur la bêta Big Sur ce week-end, moi c’est justement en passant à la bêta 9 que ça a résolut le problème. Perso quand j’ai désactivé mes comptes Google j’ai plus eu le problème d’ailleurs... Pareil sans wifi j’avais plus le problème (mais bon c’est pas très pratique...)

avatar raf30 | 

Merci Mac G !! J'ai appliqué votre "solution"...., alors oui, je n'ai plus le bug de account mais je n'arrive plus à me reconnecter à mon compte iCloud, mail a viré tous mes comptes, plus aucun mail, et impossible de me reconnecter à aucun compte.... Sacré solution, merci ! Ne surtout pas passer par le Terminal. Une belle journée de réinstallation et réimportation des données Time Machine en réseau devant moi. Agréable journée.......

avatar yelmo | 

Pareil pour moi, si ca c'est une "solution"...

avatar Stéphane Moussie | 
@raf30 : ce n'est pas "notre" solution, mais celle indiquée par le site Mr. Macintosh (quasiment en dernier recours), comme précisé dans l'article. Cela étant, désolé si ça a mis le bazarre. Après avoir saisi ces lignes de commande dans le Terminal, il faut copier le contenu du dossier ~/Bibliothèque/Accounts/Backup vers le répertoire ~/Bibliothèque/Accounts/.
avatar raf30 | 

@stephmouss

Soit vous donnez la solution complète du premier coup, soit vous ne la donnez pas....surtout si la demie solution n’en n’est pas une et fout la zone comme chez plusieurs de vos lecteurs apparemment..Et puis la prochaine fois que vous rapportez des infos d’autres sites, vérifier, tester, les bidouilles avant de les publier, ça évitera de mettre vos lecteurs dans la galère.
Reconnaître ses erreurs, c’est bien aussi....ça donne confiance, pas l’inverse...

avatar Alex56 | 

Remède simple et efficace, sans effet secondaire :
- détruire le sous dossier au nom aléatoire dans ~/Library/Keychains
- redémarrer

avatar jegerober | 

1. Déconnecter le compte iCloud principal
2. Redémarrer
3. Re-connecter le compte iCloud principal

Tout ok pour le moment!
François

avatar OSX | 

J'ai été touché ce matin par ce blocage total de la machine. j'ai coupé le wifi et rallumé, et ensuite avec les commandes dans le terminal ça a solutionné.
Merci

avatar macbob | 

C'est le stagiaire du 3e qui as déconné lors de la mise à jour du serveur, il a cru bien faire en introduisant un code révolutionnaire qui allait tout accélérer sur les serveurs de connections iCloud ;)
Perso cela fait 3 jours que mon Mac ralentissait alors que j'était sous 10.15.6, et j'ai justement fait la màj pour solutionner le problème ;)))))))))))... et c'est en re-connectant mon compte que j'ai compris que le bug n'était pas lié à la version de l'OS !

Merci pour la ligne de code, mais dans mon cas, dé que je me re-connect, le problème revient fissa, donc pas de connexion iCloud jusqu'à ce qu'Apple solutionne le problème de son côté !
Une belle merde

Pages

CONNEXION UTILISATEUR