macOS 10.15.4 resserre la vis sur les extensions du noyau obsolètes 🆕

Nicolas Furno |

macOS 10.15 continue de renforcer la sécurité du système dédié aux Mac avec notamment un changement de taille : DriverKit. Ce nouveau mécanisme permet d’installer les extensions du système fournies par les apps tierces dans l’espace dédié à l’utilisateur plutôt qu’au niveau du noyau. Les « kexts1 » vont donc disparaître avec le successeur de Catalina, au profit des extensions utilisateur gérées par le biais de DriverKit :

Cela fait des années que les kexts sont utilisées par les apps toutefois et tout cet écosystème n’a pas disparu du jour au lendemain avec la sortie de macOS Catalina. Dans la dernière version du système, Apple franchit une étape supplémentaire en indiquant explicitement à l’utilisateur que son système utilise des extensions « obsolètes » qui seront bientôt désactivées. Si vous avez des extensions du noyau installées, la version 10.15.4 qui vient de sortir vous affichera une alerte.

L’alerte indique le nom du développeur qui a créé l’extension du noyau et un bouton renvoie vers cette page de support. On y apprend que l’alerte sera affichée lors du premier chargement de l’extension en question, puis de temps en temps par la suite. Sachant qu’avec le successeur de Catalina, l’extension ne sera plus chargée du tout et l’app associée ne fonctionnera probablement plus, ou en tout cas pas correctement.

Le message que vous verrez sur macOS Catalina si vous avez des apps associées à une extension du noyau (ici, LittleSnitch).

DriverKit est la voie du futur et les développeurs sont incités nettement plus fermement à l’utiliser avec macOS 10.15.4. Reste que cette nouvelle solution ne permet pas de répondre à tous les besoins qui motivaient auparavant la création d’une extension du noyau. Les cas les plus courants sont gérés par le nouveau mécanisme, mais il reste environ 25 % de cas qui ne seront plus pris en charge avec la prochaine mise à jour majeure du système.

MàJ le 25/03/2020 11:03 : si vous utilisez un hackintosh, vous n’avez pas à craindre ce changement. La nouvelle politique de macOS ne concerne que les extensions installées par les apps, elle ne touche pas aux extensions gérées par Clover ou OpenCore. J’ai d’ailleurs mis à jour mon hackintosh ce matin sans aucun problème et sans rien faire de particulier.


  1. Abréviation couramment utilisée pour les « kernel extensions », les extensions du noyau.  ↩

avatar juliuslechien | 

Cela va compliquer le hackintosh, non ?

avatar Dimemas | 

Oula j’en ai bien peur...
Après je suis resté sur Mojave tellement je n’aime pas Catalina...

avatar Nicolas Furno | 

@juliuslechien

Je viens de passer le mien à 10.15.4 et aucun souci à noter. Je n'ai d'ailleurs eu aucun message d'alerte comme celui de l'article.

Soit parce que SIP est désactivé, soit (à mon avis la vraie raison) parce que les kexts des hackintosh sont chargés comme ceux de macOS, c'est même toute l'idée.

En tout cas, il n'y a pas d'inquiétude à avoir à cause de ce changement qui concerne les apps tierces.

avatar occam | 

@nicolasf

Merci, Nicolas, de cette info, vitale si l’on est contraint de passer son hacktosh sur Catalina. Nous avons besoin d’un poste Catalina pour assurer la transition, et nous hésitions à mettre en péril les derniers vrais Macs qui nous restent. C’est donc un hack qui y passera.

avatar Nicolas Furno | 

@occam

Pas de souci ! Depuis que j’ai une carte graphique AMD, c’est un plaisir les mises à jour. C’est aussi facile que sur un vrai Mac, tout simplement.

avatar adamrose1309 | 

Totalement d'accord finalement l'arrêt des drivers Nvidia a été un gros plus car obligé de passer sur une ATI, une Radeon RX580 8Go pour être précis. Un bonheur. Et j'ai fait pareil il y'a quelques semaines pour la partie son qui est souvent un des points noir d'une mise à jour à une autre : résultats achat d'une SoundBlaster Play 3 Dac en USB ! Plus le moindre soucis désormais lors des mises à jours :)

avatar Gwynpl@ine | 

@Nicolas Furno

Je suis sur mon Hack avec le SIP activé et mise à jour faites aucun souci en 10.15.4. Sauf pour les pilotes de ma Wacom !

Je pense que je vais pas être tout seul !

avatar moh_schumi | 

J’ai eu ce message mais pour une ligne dans trousseau de clés ??? C’est du Apple, comment ça se fait qu’ils prennent plus en charge une partie de leur soft ?

avatar Fennec72 | 

J’ai eu 2 messages, Logitech et Intego.

Celui qui m’inquiète le plus, c’est Intego l’éditeur de mon antivirus.

avatar juliuslechien | 

@Fennec72

Profite en pour mettre ton antivirus à la poubelle 😜

avatar Fennec72 | 

@juliuslechien

Tu raisonnes à partir de la vieille idée, malheureusement obsolète, qu’il y a ni virus ni malwares sur Mac et tu oublies que, si l’on n’est pas égoïste, il ne faut pas être porteurs sains de virus vis-à-vis de nos correspondants sous Windows.

😉

avatar juliuslechien | 

@Fennec72

Non je raisonne plutôt qu’aujourd’hui la menace virus ne représente plus grand chose dans le % des menaces. Oui il y a des menaces malware, randsomeware... face à ces menaces mes antivirus ne sont pas efficaces, il y a par contre des outils plus performants et moins consommateurs de ressources machines comme les soft d’Objective see

avatar raoolito | 

@Fennec72

il suffirait aussi de voir si intego n'a pas de mises à jours, sinon ya avast qui est gratuit

avatar Fennec72 | 

@raoolito

Il y a eu effectivement une mise-à-jour d’Intego dans la foulée de macOS 10.15.4.

Il faudrait regarder dans les notes de version de cette mise à jour.

avatar raoolito | 

@Fennec72

voilà, cela ne m'etonne pas. au pire, ce sera pour une autre version. Et puis soyons clair: vous pouvez rester sur catalina encore une bonne année sans probleme particulier (je suis moi-meme sous mojave) car on ne doit pas switcher à l'aveugle chez apple, c'est suividair,e toujours attendr e la X.y.4 ou 5 :P

avatar curly bear | 

J’ai déjà décidé de ne pas passer à Catalina, ça ne me motive pas pour la suite. Le problème c’est que je ne peux plus acheter de nouveaux mac...

avatar pim | 

@curly bear

Vous êtes donc sur le chemin du hackintosh !

avatar jcp25 | 

@curly bear
J’ai déjà décidé de ne pas passer à Catalina, ça ne me motive pas pour la suite. Le problème c’est que je ne peux plus acheter de nouveaux mac...
---
Oui tout à fait.
Sauf à installer une VM avec un ancien système et travailler dessus.
Et dans ce cas, il vaut mieux, parfois, migrer sur Windows.
La question étant :
- puis-je utiliser avec le nouveau système l'ensemble de mes logiciels-metier ?
- si non, quelle est l'alternative la plus pérenne ? Et la moins chère en terme de mise en place.
Cela peut se résumer à :
Aujourd'hui, tout tourne bien avec 10.12 ou 10.13 ou 10.14 mais niet sur 10.15. Mes vieux ordis peuvent tenir 4 ou 5 ans. Mais quid si je veux acheter un nouveau Mac ? Et dans 4/5 ans ?
Changer les applications qui ne tournent plus va me coûter x milliers d'euros plus y milliers d'euros pour l'import des données plus z milliers d'euros pour la formation. En sachant que sur Apple, rien n'est pérenne.
Ou acheter un PC sous Windows qui fera tourner toutes mes applications métier et migrer doucement du Mac vers PC.
Comme tous les serveurs en entreprise sont sous Windows (ou Linux) ce sera un plus.
Et je travaille sur Mac professionnellement depuis 1986 (Mac 128). Pas trop concerné car dans 5 ans, j'aurais arrêté complètement mon activité. Mais pour mes clients.....

avatar joelcro | 

Même message pour Lulu (équivalent Little Snitch).

avatar Alex56 | 

Message à la Windows qui ne donne pas le nom de l'extension concernée !

avatar FloMo | 
J'ai eu le message dans AdGuard.
avatar monome42 | 

Je viens de faire la mise à jour ce matin et j'ai de nombreuses applications qui quittent de manières imprévues ou qui sont "impossibles à ouvrir".
Vous pensez que c'est lié à cette nouvelle sécurité ? Si quelqu'un à la solution pour régler ce problème, je la veux bien. J'ai désactivé SIP, réinstallé les applications en questions, rien ne marche…

avatar mat16963 | 

Soundflower est-il concerné ? Car je l’utilise assez couramment et je ne suis pas encore sous Catalina

avatar cfpsurf | 

D'accord avec Alex56 : on n'a pas le nom de l'extension concernée, mais juste celui du développeur (dans mon cas : "DEVGURU Co Ltd" ; ça n'aide personne, en tout cas pas moi qui ne sais pas lire dans le marc de café !

avatar vincentn | 

@cfpsurf

Cela pourrait être plus explicite en donnant le nom de l’app plutôt que celui de l’éditeur/développeur, effectivement.

Dans votre cas, c’est soit l’app Twomon, l’app EasyBee, ou l’app EasyCanvas… Une rapide recherche sur le net donne ça comme possibilités.

Pages

CONNEXION UTILISATEUR