La prochaine version de Transmit abandonnera El Capitan et Transmit Disk

Nicolas Furno |

Panic prévient sur Twitter que la prochaine version de son client FTP Transmit abandonnera une fonction et une version de macOS. La version 5.6 adoptera les nouvelles mesures de sécurité imposées par Apple dans macOS Catalina et notamment le « lancement renforcé » (Hardened Runtime) qui fait partie des nouvelles sécurités liées au système de notaire de Mojave.

La fonction Transmit Disk en action : la fenêtre du Finder affiche le contenu du serveur distant, également présent dans Transmit sur cette capture d’écran.

En appliquant ce lancement renforcé, une app ne peut plus modifier son propre code, ni utiliser de bibliothèques additionnelles si elles ne sont pas également signées. Dans le cas de Transmit, cette protection bloque Transmit Disk, une fonction qui permet d’accéder au contenu d’un serveur distant directement depuis le Finder. Dans la version 5.6, cette fonction sera donc retirée, mais l’éditeur ajoute qu’il travaille sur une nouvelle version qui permettra d’offrir cette fonction tout en gardant les protections de macOS. Apple propose des API pour s’intégrer au Finder et c’est probablement ce qui sera utilisé pour remplacer FUSE qui nécessitait une modification du noyau.

Autre victime de la transition, la prise en charge d’El Capitan (OS X 10.11) sera retirée et Transmit 5.6 nécessitera au minimum macOS 10.12. Si vous utilisez encore cette version du système ou si vous avez besoin de Transmit Disk au quotidien, mieux vaut vous en tenir à la version actuelle, la 5.5.2.

Transmit est traduite en français et l’app est vendue 45 $ sur le site de l’éditeur ou bien avec abonnement à 25,99 € par an sur le Mac App Store.


Tags
avatar marc_os | 

Peuvent faire ce qu'ils veulent chez Transmit, perso je suis resté fidèle à Fetch.

avatar - B'n - | 

…et moi à ForkLift, après de nombreuses années sur Fetch également.
Il est tellement pratique, surtout lorsque l'on gère beaucoup de sites.

avatar YAZombie | 

Pour ceux qui se poseraient la question, l'incompatibilité d'osxfuse a depuis été réglée avec les betas actuelles (ce qui ne veut pas dire pour autant que toutes les apps qui reposent dessus fonctionnent, ni que de futures betas casseront pas la compatibilité, mais le projet est loin d'être au point mort).

avatar marc_os | 

@YAZombie
Les anciennes versions d'OSXFuse ne sont pas vraiment "thread safe", d'où moult problèmes. OSXFuse c'est amélioré sur ce point, mais depuis je ne l'ai pas vraiment utilisé. Tout ce que je sais, c'est que depuis que j'ai mis en place un contournement dans nos logiciels à ce problème de thread safety, nos clients ne se plaignent plus de leur incompatibilité avec ces logiciels qui utilisent OSXFuse, Google Drive, Boxcryptor et pCloud essentiellement.

avatar vrts | 

j'en ai marre de Mac OS et de ses problemes de compatibilite d'apps d'une version a l'autre.
Je ne me souviens pas avoir ce probleme sur Windows, sur lequel j'utilise toujours des apps achetees il y a 15 ans et qui sont parfaitement compatible avec win 10 64bit.

Sur Mac Os j'ai mis pas mal d'apps au placard et une sonde de calibration car pour les drivers c'est le meme probleme. (sonde que je peux utiliser sur Windows d'ailleurs).
Je suis pas dev, pourquoi c'est si complique sur Mac ? J'en ai marre de pas pouvoir mettre a jours des apps achetees parceque les devs lachent le support (je les comprends hein, c'est juste penible pour le client).
(pas de mise a jour de Mac Os car stabilite des machines de prods)

CONNEXION UTILISATEUR