Homebrew prend (timidement) en charge macOS Mojave

Nicolas Furno |

Homebrew est un gestionnaire de paquets pour macOS, un outil qui permet d’installer des programmes à utiliser en général en ligne de commande, dans un terminal. Chaque année, il doit être mis à jour pour prendre en charge la mise à jour majeure de macOS et Mojave ne fait pas exception. Si vous utilisez les bêtas et Homebrew, bonne nouvelle, la version 1.7.0 qui vient de sortir commence à gérer le nouveau système.

Tant que les paquets prêts à emploi ne seront pas mis à jour pour macOS Mojave, il faudra toujours les compiler lors de leur installation, ce qui ralentit considérablement l’utilisation de Homebrew.

Pour le moment, cette prise en charge est encore minimale et les concepteurs de Homebrew préviennent qu’aucun support ne sera proposé pour macOS Mojave. En cas de problème, soit vous faites avec, soit vous essayez de trouver une solution à apporter, le projet étant open-source. C’est la politique comme chaque année, mais cette mise à jour assure que l’outil fonctionne correctement sur la bêta en cours. Et on peut toujours trouver de l’aide sur les forums dédiés à Homebrew, comme ce sujet qui vous permettra de mettre à jour ffmpeg sur macOS 10.14.

Indiquons encore qu’il faut pour le moment installer un paquet supplémentaire pour que Homebrew fonctionne correctement avec Mojave. C’est une mesure temporaire, comme l’a indiqué un développeur d’Apple aux responsables du projet et tout est expliqué la première fois que vous utiliserez la version 1.7. Au-delà de la prise en charge officielle de l’outil en lui-même, ce sont surtout les paquets qui devront être mis à jour pour ne plus les compiler à chaque fois. Et sur ce point, il y a encore beaucoup de travail, la majorité des paquets que nous avons mis à jour sur la bêta de macOS 10.14 passent par une compilation.

Homebrew est un projet gratuit et open-source. Pour découvrir comment l’installer et l’utiliser, toutes les informations sont disponibles sur la page d’accueil. Vous pouvez l’installer avec Mac OS X 10.5 ou plus récent, mais El Capitan est la version recommandée au minimum.

Pour aller plus loin :
avatar MacTHEgenius | 

Le rêve serait qu’Apple le prenne en charge officiellement et permet de l’installer avec Xcode comme pour les « Command line tools ».

Ça reste un rêve de fou...

avatar Nicolas Furno | 

@ MacTHEgenius

Le vrai rêve, ce serait de pouvoir installer Xcode (avec Cask par exemple), sans quitter iTunes. Bon, c'est un peu dingue, je sais, mais c'est un rêve alors tout est permis.

avatar occam | 

@nicolasf

Le vrai rêve, ce serait... mais non, il y a BSD ou Linux pour ça. Nous, on se contente de nouveaux emoji 🤐.

avatar ForzaDesmo | 

@MacTHEgenius

+ 1000

CONNEXION UTILISATEUR