macOS 10.15.7 : en cas d'emballement du processus accountsd 🆕

Stéphane Moussie |

Mise à jour le 2 octobre : vous avez été plusieurs à nous signaler dans les commentaires ou par email d'autres types de manipulations qui ont résolu le problème. Notez bien que celles-ci ne fonctionnent pas à tous les coups :

Par ailleurs, nous avons ajouté une précision sur la manipulation liée aux lignes de commande. Après avoir saisi ces lignes dans le Terminal, il faut copier le contenu du dossier ~/Bibliothèque/Accounts/Backup vers le répertoire ~/Bibliothèque/Accounts/ et après cela éventuellement redémarrer l'ordinateur.


Depuis l'installation de macOS 10.15.7 sorti la semaine dernière, des utilisateurs se plaignent d'un emballement du processus accountsd. Chez certains, ce processus lié aux comptes enregistrés sur le système s'accapare toute l'activité du processeur, entraînant un ralentissement général du Mac.

Si vous constatez des lenteurs sur votre Mac depuis la dernière mise à jour, ouvrez le Moniteur d'activité et regardez si l'occupation CPU de accountsd est exagérée. Si elle est de 400 %, par exemple, c'est qu'il y a un problème.

Dans ce cas-là, Mr. Macintosh suggère diverses opérations à tester. Un simple redémarrage ou réactivation du Wi-Fi suffit parfois à résoudre le souci. Autrement, il faut tenter la reconnexion à iCloud et aux autres comptes internet dans les Préférences Système.

Si ça ne donne rien, il faut dégainer le Terminal pour redémarrer manuellement le processus défectueux en saisissant ces lignes de commande (au passage, une sauvegarde de la base de données iCloud est effectuée) :

sudo -v ; killall -9 accountsd com.apple.iCloudHelper ; defaults delete MobileMeAccounts ; mkdir ~/Library/Accounts/Backup; mv ~/Library/Accounts/*.sqlite* ~/Library/Accounts/Backup/ ; killall -9 accountsd com.apple.iCloudHelper ; sudo reboot

Après avoir saisi ces lignes dans le Terminal, il faut copier le contenu du dossier ~/Bibliothèque/Accounts/Backup vers le répertoire ~/Bibliothèque/Accounts/.

Si le problème persiste après ça, un rétropédalage sur macOS 10.15.6 à l'aide d'une sauvegarde est à envisager sérieusement.

Mise à jour à 14h11 : comme vous êtes plusieurs à le signaler, macOS 10.15.7 n'est pas le seul touché par ce problème. Des versions antérieures sont également concernées, tout comme Big Sur. Après l'installation de la neuvième bêta de macOS 11, le processus accountsd a fait tourner les ventilateurs et tourner en bourrique l'un de nos Mac. Un redémarrage a suffi à régler le problème.


avatar macbob | 

Finalement, après plusieurs tentatives de re-connexion, ça a fini par ralentir (150%) puis en désactivant/ré-activant un à un les services iCloud, le process est revenu à 2,2% et finalement à 0,1%. Le pire ça a été en activant mon compte sur Apple Music… 460% !!!!

avatar yelmo | 

Les commandes mentionés ont résolu le problème, mais maintenant j'ai un autre... impossible de me reconnecter sur icloud, App Store, Yahoo, google... aparement je ne suis pas le seul... j'ai esasyé plusieures redemarranges, recopier les fichiers originaux déplacés dans le dossier Backup ... mais rien... des pistes ?

avatar Orus | 

Et allez encore un bug inadmissible. Ils font quoi chez Apple dans leur grand anneau, du vent ?

avatar raf30 | 

ils sont "concentrés" sur les additionnal updates !

avatar raoolito | 

@Orus

«  recherche gens du département QA de chez Apple-Cupertino. Aperçu dernièrement sur une plage des Bahamas à bronzer. »

avatar ech1965 | 

ou aux barabez pour avoir laissé passer des bugs

avatar MacMarc | 

Bonjour.

Perso, j'ai eu ce problème pour la première fois aujourd'hui, en démarrant le MacBook Pro. D'habitude, je le mets juste en veille la plupart du temps...

J'ai essayé de "tuer" le processus 2-3 fois via le moniteur d'activité sans grand résultat (il se réveillait très vite pour reprendre à plein régime...) et redémarré 2-3 fois le Mac sans résultat non plus.
Vu qu'il est question de comptes (via le réseau), j'ai eu l'idée de désactiver le Wi-Fi (pour interrompre les bavardages entre comptes sur internet et le Mac), ce qui a fait chuter le régime de + de 400 % à +/- 130 % ... Déjà mieux mais pas super...

J'ai donc éteint le Mac avec le Wi-Fi désactivé, pour le redémarrer "hors réseau".
Bingo! Accountsd s'est fait tout petit 😀
Même après avoir ré-activé le Wi-Fi et relancé Mail pour relever le courrier de mes 10 Boîtes aux lettres (panaché de iCloud, Gmail, Hotmail, OVH).

avatar Eric Lt | 

Bonsoir
Tout nouvel iMac installé le WE dernier. Constat de l'emballement du processeur à plus de 500% pour accounts. Le redémarrage me permet de régler temporairement le problème. Cela revient 'comme cela' sans trop savoir ce qui fait démarrer le accountsd.
Pas cool du tout. C'est la 1ère fois que cela m'arrive. Pour une machine à ce prix (au passage mon 3ème iMac 27 pouces), intolérable. Pensez-vous que Apple peut résoudre ce problème par une nouvelle version de Catalina ?

avatar raoolito | 

@Eric Lt

c’est un soucis système, la machine n’a rien à y voir.
Si vous voulez eviter ce genre d’aventures, n’installer jamais une mise à jour meme de sécurité des sa sortie, attendez 3-4 jours que certains essuient les peaux cassées.
Disons que les IT font cela tout le temps, mais dans le cas des utilisateurs solo, ben les IT c nous, alors on doit faire attention.

il y a plusieurs methodes, mais il semble que couper le reseau bloque le processus, ensuite desactiver/reactivez un compte internet ou deux dans les preferences (possiblement des comptes google) et redemarrez avec un reset PRam et ca devrait regler le soucis.
Je l’ai eu et si je ne sais pas trop d’où ca venait, il semble que bidouiller les comptes, desactiver temporairement le VPN ca a aidé. Une fois parti il n’est plus revenu

avatar matld | 

Bonsoir,
Sinon, une solution rapide, aller dans le moniteur d'activité et quitter le processus 'commerce'.
Pour le moment ça a résolu le pb sur mon MBP.

avatar kergariou | 

J'ai eu le problème alors que je venais juste de faire (sans le savoir) la dernière maj de Chrome qui indique les mots de passe dangereux. Du coup, j'ai cru me faire hacker. Bref de belles sueurs froides pour rien.

avatar valcapri | 

J’ai corrigé le problème sur Catalina en installant la combo update de macOS Catalina 10.15.7 par dessus la mise à jour 10.15.7.

https://support.apple.com/kb/DL2052

avatar winchestermann | 

Pour moi ce sont les ventilateurs de mon Imac 2020 27" 3,8GHz qui a trois jours de fonctionnement qui s'affolent. Sans aucune application d'ouverte, ils poussent au maximum.
J'ai eu Apple Care hier qui ne pensent pas que çà vient de la MAJ, UPS vient de me reprendre l'appareil pour un échange.

avatar QuickPwn | 

Problème résolu de mon côté en réinstallant la 10.15.7 en combo ici :
https://support.apple.com/kb/DL2052?locale=fr_FR

avatar cv21 | 

Merci MacG.
De mon côté, mini 2018 10.15.7, pour les procédures ci-dessous, accountsd s'emballe à chaque réouverture de Safari:
- PRAM
- un coup d'"Onyx nettoyant"
- arrêt/redemarrage connexion réseau.

La déconnexion du compte iCloud + arrêt + démarrage semble tenir. Tout se passe bien sauf en tentant de se reconnecter à iCloud. La déconnexion + redémarrage résout à nouveau ce pb.

Désormais Apple vise l'excellence même dans ses bugs ! J'ai bien ressenti l'expérience utilisateur bloqué devant son mac. Top niveau ! Jusqu'à présent, sur la machine perso, je laissais les mises à jour de sécurité en automatique. J'arrête.

avatar Crunch Crunch | 

Ha ha, j'ai adoré ton commentaire sur l'excellence !

Mais c'est exactement ça ! Un vrai problème, qui bloque le Mac, rendant le travail impossible.
Idem pour moi. L'expérience de l'utilisateur, bloqué devant son écran, est absolument magnifique.

Merci !!! :-(

P.S:
J'avais réussi à résoudre le problème "accountsd" pendant quelques jours (en déconnectant + re-connectant iCloud). Et là, paf, ce matin, "accountsd" repart à 200% :-(((

avatar lepori | 

Et bien merci pour ce post et toutes les infos j'avais ce problème depuis l'installation de la 10.15.6 et finalement c'est une desactivation du wifi + un lancement de maintenance de OnyX qui a fonctionné merci MacG !!

avatar 421 | 

Hier j’ai fait une déconnexion-redémarrage-reconnexion de mon bon vieux Mac Mini et tou est rentré dans l’ordre.
Aujourd’hui MAJ et tout va bien

avatar DuraLex06 | 

Je viens d'être confronté à ce problème, c'est bien la première fois que mon Mac est rendu inutilisable après une mise à jour... J'étais quand même rassuré de voir que le problème était connu et que ça ne venait pas de moi.
J'ai essayer les lignes de commande, la réinitialisation NVRAM, plusieurs redémarrages... sans succès.

Mais en me déconnectant complètement de mon Apple ID (préférences -> identifiant Apple -> vue d'ensemble -> se déconnecter), puis redémarrage, le problème était résolut.
Je me suis reconnecté et pour l'instant aucun soucis.

avatar Tetaroide Bleu | 

J’ai essayé toutes les solutions à part les déconnexions, parce que pour moi ça n’en est pas une puisqu’elle m’empêche d’utiliser mon ordi correctement. La seule qui a marché, c’est celle de quitter le processus "commerce". Cela m’a offert 24h de tranquillité, même entre plusieurs redémarrages, sans perturber mon workflow. Ensuite ça a recommencé, mais j’ai quitté le processus à nouveau et c’était bon ! je recommencerai jusqu’à ce qu’Apple réagisse enfin. Je pense @Macg, que vous devriez rajouter la possibilité dans votre liste à puce, je trouve que c’est la solution la plus rapide/moins compliquée/lente/risquée à mettre en place, et je n’ai trouvé personne dans les différents témoignages pour indiquer que cela ne fonctionnait pas pour eux.

avatar raf30 | 

Je confirme, killer "commerce" et vous êtes tranquille pour un moment...

avatar OSX | 

Après avoir lancé les lignes de commande j'ai été tranquille un peu temps puis c'est revenu et ça ma lache plus.

avatar icaro2005 | 

Parlé longuement avec le support Apple qui m’a fait refaire presque tout ce que j’avais déjà tenté, dont une réinstallation après avoir réparé les autorisations par le terminal...résultat toujours la même chose.
La fameuse ligne de commande m’a permis de me reconnecter à iCloud et de crier victoire durant 10 minutes et paf le process à plus de 400 pour cent... essayé à nouveau de me déconnecter, les resets etc...
J’abandonne et j’attends la mise à jour de la mise jour de la...;-)
J’ai un MacPro 2019...il tient bien la charge et je peux quand même travailler mais ça m’énerve...

avatar Crunch Crunch | 

Je confirme. La "CHOSE" se manifeste au lancement de Safari !!!

Bref, n'ouvrir Safari qu'en EXTREME nécessité…
Ou alors, utiliser un autre navigateur. FireFox de préférence ;-P

avatar loubalico06 | 

@Crunch Crunch

Moi justement c'est Firefox qui me déclenche l'emballement :/

avatar OSX | 

J'ai réinstallé la combo 10.5.7 et ça ne solutionne pas.
Se déconnecter du compte de sert plus à rien.
Les lignes de commande non plus... quelle galère.
Je vais repasser en 10.5.6

avatar paellota | 

Je me suis déconnecté de mon compte Icloud, et le problème semble avoir disparu. Après, évidemment, il ne faut pas avoir besoin d'Icloud.

avatar OSX | 

Je vous déconseille de copier coller les fichiers account/backup comme indiqué car ça a bloqué ma session, impossible de reconnecter à mon compte iCloud.
J'ai du contacter le support.-, voici ce qui a été fait:
On a effacé 3 styles de dénomination fichier dans le trousseau ( plus de 100 fichiers mais je me souviens plus des dénominations).
Ensuite j'ai du taper ces commandes une par une et non pas tout en une fois:
( il a précisé que les commandes ci dessous ne règleront pas le problème sans avoir effacé avant toutes la série des fichiers dans le trousseau.)

sudo -v
killall -9 accountsd com.apple.iCloudHelper
defaults delete MobileMeAccounts
mkdir ~/Library/Accounts/Backup
mv ~/Library/Accounts/*.sqlite* ~/Library/Accounts/Backup/
killall -9 accountsd com.apple.iCloudHelper
sudo reboot

Ensuite la système a accepté de me reconnecter sur mon compte et maintenant tout se réimporte.
Dans ce moment, je suis à 150% sur le processus accountsd et non plus à 500%. Je dois laisser travailler la machine. En principe ça devrait être rentré dans l'ordre. Si c'est pas le cas, je dois les recontacter pour procéder à une réinstalle.

avatar 406 | 

Merci pour la procédure. c'était devenu comme tu l'as dit chez moi aussi…

avatar Arnaud.A | 

Bonjour,
Merci OSX, j'avais le même problème, grâce à tes indications j'ai réinitialisé les trousseaux d'accès pour enfin me reconnecter.

avatar Varjo | 

j'ai réussi à réparer" account" avec OnyX Version 3.8.6 (200927)

avatar OSX | 

Où se trouve cette option dans Onyx svp?
Merci

avatar laflo15 | 

Bonjour,
Il m'est arrivée la même chose avec mon MacBook Pro 2019. J'ai appelé l'assistance Apple qui m'a fait réinitialiser le contrôleur de gestion du système (https://support.apple.com/fr-fr/HT201295).
Le problème n'est pas réapparu depuis. Je croise les doigts.

avatar Pimentpub | 

Cela revient encore… grrrrrr ! J'espère que Apple va faire une MAJ !

avatar Pimentpub | 

Même avec Onyx, cela ne change pas. Le problème revient après quelques jours et il y aussi le retour d'un autre problème : mon NAS Synology qui se déconnecte de temps en temps à nouveau !
Je me demande si cela n'est pas fait exprès pour nous inciter à adopter le futur OS Big Sur !

avatar NBovy | 

Je suis ce fil avec attention, je suis pour ma part repassé hier sous 10.15.6 via un recovery Time Machine. Dans la foulée hier du recovery : problème d'emballement d'Accountsd résolu. Démarrage de mon iMac ce matin : accounts à 642%... ventilés à fond.... bref... retour case départ... à n'y rien comprendre..

avatar Dexter Killer | 

Idem même problème que vous sur mon MacBook Pro 2019. Cette semaine ça m’a ralenti pour monter et surtout exporter les films sous FCPX ou des compositions d After par contre aucun souci avec Resolve. Je fais rarement des mises à jour aussi vite mais comme la semaine précédente j’ai mis à jour FCPX, Compressor et Motion je me suis dit qu’il était préférable de faire la MAJ 10. 15. 7 pour avoir une stabilité .. bah enfaite c’était tout le contraire 👀J’ai réinitialisé le SMC. Et tout se passe très très bien maintenant j’ai retrouvé toute la puissance.

avatar Bobleroy | 

Pour ma part, le processus s'emballe quand j'utilise safari. depuis que j'évite safari plus d'emballement...

avatar jbpfrance | 

Je suis au point mort... l'un de mes deux Macbook s'est emballé, celui avec lequel je travaille le plus. J'ai utilisé le Terminal suivant les recommandations. Et tous mes comptes de messagerie ont été effacés.
Je ne vois pas de backup dans Accounts... de la bibliothèque. Je ne peux transférer le dossier par conséquent.
Je ne peux recréer un compte de messagerie dans ce Mac, le logiciel Mail ne répond plus quand je clique sur la création d'un compte.
Onyx n'y a rien fait.
J'ai retéléchargé 10.15.7, Mail est toujours à l'arrêt.
En se connectant à iCloud sur l'appareil "en panne"... "une erreur est survenue...."

avatar switch | 

Encore une bonne raison de ne pas utiliser iCloud (sauf pour qqes synchros de données légères) et Mail (je l'ai vu cafouiller tant de fois…)

avatar cortex | 

Je me suis retrouvé avec cet emballement aujourd’hui (400%).
J’ai remarqué que le process « CommCenter » prenait aussi beaucoup de ressources en processeur et surtout en débit réseau (ça se voyait très bien sur LittleSnitch).

Après avoir tué ce process, je suis descendu à 240%.
Le process est revenu et je l’ai tué une seconde fois.
Le processeur a arrêté de s’emballé.

Y’a t’il une cause à effet ? Je ne sais pas.
Je donne simplement mon expérience.

avatar JYTX | 

Bonjour,

J'ai essayé plusieurs choses. Celle-ci semble avoir résolu le problème :

Me souvenant d'un problème similaire dans le passé, j'ai regardé mes comptes iCloud sur les autres appareils. Vérifiez votre compte icloud et si ce n'est pas le même votre compte iTunes sur ios 14 sur tous les appareils que vous avez upgradé. Il va vous demander une reconnexion pour "enregistrer une nouvelle empreinte".

Pour moi au redémarrage suivant de MacOs, plus d'emballement.

Essayez et partagez si ça marche pour vous

avatar V_I_P | 

Ayant eu le problème j’ai supprimé toute vérification et installation de mises à jour de macOS et le problème a disparu.

avatar Pimentpub | 

4 fois aujourd'hui ! Aucune nouvelle de Apple sur ce problème !

avatar LW | 

J’ai tout essayé mais en vain....
J’ai lu que si on installait la combo de Catalina cela réglait le problème!
Je l’ai fait..... plus aucun problème depuis!!!

avatar wichowe | 

Pas de soucis au début mais depuis qq jours cela revient tous le temps .... Le plus efficace pour moi est l'utilisation d'Onyx

avatar yelmo | 

Pour moi installer le combo 10.15.7 a resolu le problème. Et j'ai finalement reussi à reconecter mes comptes à partir d'un backup de Library/Accounts.

avatar jbpfrance | 

Ce matin, le dossier "Accounts/Backup" est apparu (que j'ai cherché depuis 2 jours sans succès...). J'ai donc copié le contenu de Backup dans le dossier parent "Accounts" (3 fichiers). On m'a demandé si je voulais remplacer les 3 fichiers nouvellement créés (quelques Ko alors que le Backup approchait les 2 Mo) portant les mêmes noms. J'ai accepté. Il m'a alors redirigé vers iCloud, demandé mot de passe, etc... et j'ai tout retrouvé: Contacts, Calendrier, Mails, etc...

Et l'ordinateur s'est mis à s'emballer comme il y a 3 jours !!!
J'ai coupé le Wifi immédiatement, et l'ai remis un peu plus tard. L'ordinateur est calme pour l'instant. C'est l'opération de secours immédiate.

Hier, j'avais re-téléchargé la mise à jour 10.15.7 qui n'avait pas amélioré les choses (plus d'emballement, mais plus mes mails, contacts suite à la manip effectué dans le Terminal conformément à la recommandation antérieure proposée ici).

Bon, je ne m'en sors pas trop mal pour l'instant.

Mon autre Mac est en 10.15.6, je ne touche à rien ! Je me retrouve au temps de Windows 95 où j'avais deux ordinateurs semblables pour être sûr qu'un des deux marche... :-)

avatar FTBZ | 

De mon côté, j'ai bien galéré 😤🤬avec ce problème aussi ces derniers jours. Le seul moyen efficace que j'ai trouvé étant de désactiver la synchronisation du trousseau iCloud 🔑... Après la désactivation, je n'ai plus rencontré le problème (même après reboot). C'est du temporaire, mais ça permet de pouvoir travailler au moins. 👨🏼‍💻

avatar lepoulpebaleine | 

J’ai essayé de faire le ménage avec OnyX.
Très drôle : après quelques secondes OnyX ne répond pas ! 🔥😂

Pages

CONNEXION UTILISATEUR