Les apps Electron devraient être à nouveau acceptées sur le Mac App Store

Nicolas Furno |

Les apps qui reposaient sur le framework multiplateforme Electron étaient bloquées sur le Mac App Store depuis début novembre. En cause, l’utilisation d’API privées, strictement interdites par la boutique d’Apple, au sein du framework. Le problème pour les développeurs concernés, c’est qu’à moins de compiler leur propre version, ils ne pouvaient rien faire tant qu’Electron n’avait pas été mis à jour.

Les concepteurs du framework ne sont pas restés les bras croisés à attendre évidemment. Ils ont travaillé pour supprimer les appels aux API privées et ont publié ces derniers jours deux versions qui ne devraient plus poser de problème à Apple : la version 5.0.13 et la version 6.1.7. Vous devez utiliser l’une ou l’autre, ou les mises à jour suivantes sur ces branches, si vous voulez que votre app passe la validation de l’App Store.

Electron 7 n’a pas reçu de mise à jour similaire, pas plus que la version 8 en développement. On sait au minimum que la version 7 pose aussi problème, le travail d’adaptation continue probablement pour le moment. Les développeurs concernés doivent s’en tenir aux versions 5 et 6 pour le moment.


avatar a_y | 

🤦🏻‍♂️🤦🏻‍♂️🤦🏻‍♂️

avatar Nesus | 

@pixel: Electron is a Trojan horse.

Abusing Electron Apps to Bypass macOS’s Security Controls https://buff.ly/36S7JXS

avatar occam | 

@Nesus

Entendez-vous par là que toutes les encombres qui nous font ch..., pardon, que macOS place sur le chemin de l’utilisateur avisé, couche-layette par couche-layette par couche-layette, se font bousculer par un des frameworks les plus répandus de la planète, un vulgaire ramassis de Chromium et node.js qui plus est ?

Si c’est ainsi, on peut légitimement se demander de quel côté se situe le vrai problème.

avatar heu | 

@occam

C’est assez usant ce mépris de classe.

avatar reborn | 

@Nesus

Faudra voir si ça marche encore avec la notarization

CONNEXION UTILISATEUR