Safari : le bug des liens Twitter bientôt réglé

Anthony Nelzin-Santos |

Si vous utilisez Twitter et Safari, vous aurez peut-être remarqué que les liens « raccourcis » avec t.co menaient régulièrement vers une page blanche. Ce problème sera bientôt réglé, assure le WebKit Developer Experience Manager Timothy Hatcher, qui est aussi le concepteur de Colloquy et de l’inspecteur web.

Ce bug, apparu avec Safari 9 sous OS X El Capitan, touche uniquement les liens t.co en HTTPS. Selon Hatcher, son origine est « de plus bas niveau que WebKit », ce qui pourrait expliquer qu’il traîne depuis près de quatre mois.

En attendant qu’une future mise à jour de Safari ne le règle, il suffit d’enlever le « s » de « https:// » pour charger les pages affectées.


Source
via The Verge
avatar Apollo11 | 

C'est pas le seul bogue de Safari, en tout cas.

Chez moi, il met souvent un temps fou à charger un lien vers une page sur un autre onglet.

Tellement frustrant que je suis passé à Chrome. Aucun problème de chargement de page ni de lien ou de recherche sur Google.

Safari, outre sa bonne gestion de la mémoire, est à la traîne sur la plupart des niveaux comparé à la concurrence. Même Firefox s'en tire mieux.

OS X, c'est extra. Mais les logiciels Apple, pas vraiment. Mail remplacé par Airmail. Pages remplacé par Word/LibreOffice, Message par Hanghouts, etc.

avatar françois bayrou | 

Pareil ici.
Autre chose : Quand j'ouvre un nouvel onglet vide, il mets un certain temps à me rendre la main pour entrer une URL ou taper une recherche.
C'est pas grand chose, environ 2 secondes, mais c'est assez frustrant.

Et sinon j'aimerais savoir pourquoi Safari est le dernier navigateur à ne pas prendre en charge WebRTC

avatar spoutnik | 

Moi aussi c'est souvent extrêmement long, je pensais que ça venait du site de redirection t.co !

avatar Dark-mac | 

Tiens, moi j'ai le même problème mais avec les liens twitter.com directement

avatar Timekeeper | 

Depuis iOS 9 j'ai une page blanche sur quasiment chaque page d'Amazon. Je vois la page se charger, puis elle devient blanche quand tout s'est affiché. Je la recharge, et elle apparaît.

Ça vous le fait aussi ?

avatar alitaliano | 

@Timekeeper :
Vérifie si ce n'est pas ton adblocker qui empêche le contenu de se charger. Essaie de le désactiver pour voir. Bon évidemment si tu en as un !

avatar legallou | 

@Apollo11 pareil pour moi Firefox, Postbox, Nisus, etc. En fait, je n'ai plus aucun logiciel Apple sur mon OS X à part AppleScript.

avatar joneskind | 

Bah moi j'utilise pas Twitter alors j'ai pas de problème. Tous mes sites marchent bien dans Safari et j'ai pas à me plaindre des apps d'Apple, du coup c'est les incontournables d'hier qui ont été remplacé par les solutions Apple (Chrome, Office, Dropbox, Cubase...)

Je dois être particulièrement chanceux !

avatar Fego-007 | 

Perso sur ios9 j'ai des problèmes sur les liens sponsorisés de Google . Page incorrect .
Idem sur certains liens ....

D'autres ont le souci?

avatar Alcoreylive | 

Et moi je ne peux plus aller sur Netflix avec Safari, la page d'accueil se charge sans problèmes, par contre quand il s'agit de me connecter il me dit qu'il y a trop de redirections et refuse de m'ouvrir la page...

CONNEXION UTILISATEUR