Mail : les premiers modules à jour pour 10.6.5 [maj]

Christophe Laporte |
C'est la même histoire à chaque révision mineure de Mac OS X : les plug-ins tiers de Mail ne fonctionnent plus et doivent être mis à jour. À ce petit jeu, certains éditeurs ont été plus prompts que d'autres.

Pas de soucis concernant le module de Mail d'Antidote, il suffit de se rendre dans le menu Aide du logiciel et sélectionner l'option "Recherche de mise à jour".



Gregory F. Welch a revu ses deux plug-ins pour le logiciel d'Apple. Le premier, MailRecent [1.2.3 - 1.4 Mo - US], ajoute des éléments récents dans le menu Message : afin de classer des mails plus rapidement au sein de dossiers que l'on utilise fréquemment. La liste de ces dossiers est générée automatiquement.



Le second, MailFollowup [1.4.3 - 1.8 Mo - US] a lui aussi le droit à sa révision pour Mac OS X 10.6.5.


Mail Unread Menu [3.2.5 - 2.1 Mo - US] a également été mis à jour pour fonctionner correctement avec la dernière version de Mail. Ce logiciel affiche le nombre de mails non lus dans la barre de menus.



Une mise à jour de WideMail [2.0pr3 - 1.6 Mo - US - Mac OS X 10.6] est disponible depuis peu. Cette extension permet d'avoir une présentation similaire à Outlook.



Herald [1.2.3 - 2.5 Mo - US - Mac OS X 10.6] et Mail.appetizer [build 151 - 255 Ko - US - Mac OS X 10.6] ont également été revus. Tous deux permettent de vous notifier de l'arrivée de nouveaux messages.

Si vous êtes impatient, voici une astuce permettant de contourner le mécanisme de Mac OS X désactivant les modules Mail. Voici la marche à suivre :
- Quittez Mail
- Allez dans le dossier Bibliothèque/Mail/Bundle (désactivé)
- Choisissez l'extension qui vous intéresse, sélectionnez le dossier Content, et ouvrez le fichier "Info.plist" à l'aide de TextEdit
- Dans le fichier, vous devez voir plusieurs lignes avec des chaines de caractères entourées de balises String. Il faut coller juste après :
<string>857A142A-AB81-4D99-BECC-D1B55A86D94E</string>
<string>BDD81F4D-6881-4A8D-94A7-E67410089EEB</string>


- Enregistrez puis déplacer votre extension dans le dossier Bundle
- Lancez Mail et le tour est joué.



Cette astuce a été validée avec succès avec WideMail, Herald et LetterBox.

Tags
avatar jerdopler | 

Herald aussi a été mis a jour

avatar guate | 

Merci pour l'astuce de contournement.

avatar nykk | 

L'astuce fonctionne aussi avec Mail Appetizer. Merci Macgé.

avatar corrs78 | 

toujours rien pour growlmail ?

avatar guate | 

Cela semble fonctionner aussi pour growlmail

avatar béber1 | 

pareil pour Letterbox

avatar Iounmoutef | 

Bonjour à tous. Pour LetterBox, un pas-à-pas qui fonctionne parfaitement :

http://newmacuser.com/mailapp-letterbox-fix/

avatar Homer Simpson | 

Merci de l'astuce MacG, ça marche très bien pour Growl !

Juste faire attention, j'avais plusieurs dossiers "Bundles (désactivé X)", il faut prendre le dernier :)

avatar Zeusviper | 

@corrs78 : essaye Herald! bcp plus pratique que GrowlMail!

avatar bigham | 

Pour compléter l'astuce du jour :

Si un plugin, en théorie compatible avec Mac OS X 10.6.5 ne fonctionne pas chez vous, vérifiez qu'il n'y a pas une vieille version de ce plugin dans le dossier /Library/Mail/Bundles (à la racine du disque, donc).

avatar gigab (non vérifié) | 

Je ne veux pas troller mais existe-t-il une liste des plugins pour Mail ?
Je ne connaissais pas du tout...

avatar mainserv | 

Moi non plus je ne connaissais pas ces extensions. Ou peut-on les trouver?
Du coup j'utilise thunderbird car je trouvais Mail "un peu pauvre", mais si il existe des extensions.....

avatar modrellik | 

@ Iounmoutef :

avatar corrs78 | 

Ok merci Zeusviper

avatar nykk | 

Mail Appetizer vient d'être mis à jour pour être compatible avec 10.6.5 !

avatar Pierre H | 

Widemail, quand on y a goûté sur un écran large (toute la gamme Mac en bref), il n'est plus possible d'utiliser la version de base.

avatar bigham | 
avatar gigab (non vérifié) | 

@Bigham

Merci :)) il y en a tout plein !

@ nykk

Où as tu vu que Mail appetizer était mis à jour ? lorsque je vais sur le site indiqué, ça dit que ce n'est pas compatible avec SL et c'est la version beta 1.3.1...

avatar jacques_dh | 

Merci pour ce "contournement" qui marche à la perfection :-)

avatar pierre.bed | 

Super
Merci++++

avatar ischiros | 

@ Gigab et mainserv :
C'est en effet un problème avec Mail : pas de lieu unique où télécharger les extensions. Il y a d'ailleurs le même avec Safari, et c'est la principale raison pour laquelle je garde Firefox : la simplicité pour télécharger des extensions est sans commune mesure. Apple ferait bien de s'inspirer de l'App Store pour ça aussi (d'abord).

Sinon, quand j'installe MailRecent (que je ne connaissais pas et qui me manquait cruellement), j'ai un superbe message admirablement incompréhensible : "La compatibilité de votre "MailBundle" semble être à 1 ou 2 (anciens plugins). contacter le développeur MailRecent si ovus êtes concerné, autrement continuer à votre propre risque."
Gnnnnn.... No comprendo ! (je suis encore sous 10.6.4, j'suis un gars prudent, mais normalement ça devrait pas poser de souci).
Une idée quelqu'un ?

avatar Pierre H | 

Widemail, une fois que tu y as gouté, tu ne peux plus revenir à Mail.app "normal" surtout avec les écrans au format horizontal. Chaudement recommandé !

avatar rei_vilo | 

Bonsoir,

WideMail ne travaille pas encore en Français !

CONNEXION UTILISATEUR