Astuce : installer iBooks Author sur Snow Leopard

Florian Innocente |
Il est possible de faire fonctionner iBooks Author sur Snow Leopard, c'est ce qu'a pu constater l'un de nos lecteurs. Cela passe par quelques manipulations, mais rien qui ne soit compliqué. En revanche, n'ayant de 10.6 sous la main, nous n'avons pu valider le bon fonctionnement au final. Aymeric, qui partage son astuce, a néanmoins pu constater que l'application s'exécutait parfaitement.

iBooks Auhtor

Il faut procéder comme suit :

- Localiser le document SystemVersion.plist situé à la racine du disque dur dans /Système/Bibliothèque/CoreServices



- Faire une copie de ce fichier sur le bureau et en faire également une copie de sauvegarde.

- Ouvrir le document copié sur le bureau dans un éditeur de texte (ex TextEdit) et modifier les deux lignes contenant 10.6.8 par 10.7.2

- Remplacer le document situé dans le précédent dossier système par le document qui vient d'être modifié sur le bureau.

- Télécharger iBooks Author dans l'App Store (rappel : il est gratuit), mais ne pas le lancer tout de suite.

- Remplacer le document SystemVersion.plist copié dans le système par le document d'origine de sauvegarde du bureau en veillant bien sûr à garder le même nom.

- Aller sur iBooks Author dans le dossier Applications.

- Faire un clic droit sur l'icône du logiciel et dans le menu contextuel sélectionner "Afficher le contenu du paquet" puis localiser le document Info.plist dans le dossier Contents. L'ouvrir dans l'éditeur de texte et chercher la ligne LSMinimumSystemVersion 10.7.2 et la remplacer par LSMinimumSystemVersion 10.6.8

Après l'enregistrement de cette modification, iBooks Author doit s'exécuter dans Snow Leopard.

merci Aymeric

avatar Anonyme (non vérifié) | 
Les amis, cela marche !! Je suis encore sous Snow car j'ai pas mal de logiciels qui ne tourneraient pas sous Lion (comme Guitar Pro) ou alors qui nécessitent une maj payante. Cela dit, étant légaliste, je passerai à Lion quand je serais certain que le système est vraiment au point (j'ai l'impression qu'il y a encore des couacs). Pour information, je fais partie de ces gens qui ont acheté Keynote ou Pages pour Ipad (et qui en sont très content). A ce moment là, je ne serai donc plus un hors la loi... Pour le moment, je pourrais donc tester Ibook author, logiciel qui me semble vraiment très bien, surtout quand on écrit des petits fascicules comme je le fais. Merci pour l'astuce.
avatar Marco_la_frite | 
avec la nouvelle version qui vient juste de sortir pour les écrans ipad retina on ne trouve plus dans le paquet infoplist la ligne concernant la version limitant à 10,7,2 il faut trouver un autre moyen pour contourner la limitation
avatar Anonyme (non vérifié) | 
j'ai suivi toute la procédure, et j'ai obtenu une version de iBook Author dans mon dossier application, dont l'icône était marquée par un signe d'interdiction (un cercle barré). quand je la lance, j'obtiens un message d'erreur disant rappelant que je dispose de 10.6.8 alors que 10.7.2 est nécessaire - pourtant j'avais bien édité la info.plist. j'ai remarqué que la version 1.1, qu'on télécharge aujourd'hui (juillet 2012) est postérieur à ce qui est dit ci-dessus - je me dis donc qu'ils ont trouvé une parade dans la dernière version pour inscrire la version minimale ailleurs. néanmoins j'ai pensé qu'il pouvait s'agir d'une rémanence de cache et j'ai dupliqué l'application (pomme-d) dans le dossier application : la nouvelle icône n'est pas barrée, et quand je lance l'appli je n'ai plus le message d'erreur. :)
avatar Very Dick | 
trés intéressant tout ça , mais à ce jour l'ap store ne veut pas que je prenne ibook author , je suis en 10.6.8.! ils ont dus se rendre compte de la manip .
avatar Log_Boy | 
hallelujah, m'en vais tester ça direct, merci ^^
avatar Aescleah | 
Si une manip' aussi simple suffit à faire fonctionner iBooks Author sur SL, et qu'il n'y a de fait pas de limitation d'ordre logicielle, Apple se fout un poil de la gueule du monde, pour le coup.
avatar Le_iPodeur | 
Bon ben @ggete va pouvoir rester sur Snow Leopard.
avatar BenUp | 
Encore une fois de plus la rétro-compatibilité d'Apple "So Easy" Ben oui il suffit de soit racheter un Mac, ou d'acheter le nouveau système. Dans un cas comme dans l'autre c'est gratuit quand tu es déjà passé au tiroir caisse !
avatar rizoto | 
Scandaleux
avatar BenUp | 
Et merci la bidouille ! Mais ça commence à devenir aussi casse tête que sous Windows !
avatar Log_Boy | 
Et ça marche parfaitement, merci bien ^^
avatar Toz | 
Oui, mais comment on fait pour le télécharger en 10.6? l'App store me l'interdit!
avatar PePeLaJoie | 
"Télécharger iBooks Author dans l'App Store (rappel : il est gratuit), mais ne pas l'installer tout de suite." puis "Installer iBooks Author dans le dossier Applications." Ben il s'installe par défaut dans le dossier Applications !
avatar curly bear | 
Oui.Si le programme est fonctionnel et ne plante pas sous Snow Leopard, c'est vraiment honteux. Il vaudrait mieux qu'Apple vende iBook Authors 23 € que de forcer les gens à mettre à jour vers Lion (et perdre Rosetta, etc.)
avatar BenUp | 
Si tu es en 10.6, papier crayon !
avatar PePeLaJoie | 
Le truc ne fonctionne pas puisque l'app s'installe par défaut dans le dossier Applications et donc devient illisible immédiatement après la fin du téléchargement.
avatar Log_Boy | 
Il faut le laisser s'installer dans le dossier appli, puis éditer le info.plist et ensuite relancer l'appli et la c'est nikel ^^ * Sans oublier de recoller le fichier original dans le system avant ;)
avatar Log_Boy | 
So far c'est super stable, et donc oui c'est carrément abusé de la part d'Apple. J'ai fait un test avec pas mal de chose, de l'audio, de la vidéo, du texte et tout un tas de truc avec preview sur iPad et c’est au top. Super appli en tout cas, ça donne envie de faire des tas de bouquins, au boulot!! ^^ *Merci Aymeric ;)
avatar Eaglelouk (non vérifié) | 
Il y a forcément une raison derrière. Il me tarde de voir le comportement lorsqu'on choisira de tester/publier et d'autres features un peu plus "coûteuses".
avatar Anonyme (non vérifié) | 
…et ça ne fait même pas taire les pleureuses !
avatar albert einstein | 
à Toz et BenUp Vous le faites exprès ou vous ne savez pas lire l'article ???? On vous explique comment l'installer avec 10.6 alors ne pleurer pas parce que cela ne s'installe pas avec 10.6
avatar ceddie | 
C t pas plus simple de le rendre tout de suite compatible ? C'est donc bel et bien du marketing à deux balles !
avatar Pascal 77 | 
Bon, ben ça marche. Le descriptif est un peu erroné, mais ça marche. En fait, lorsqu'on lance le téléchargement depuis l'Applestore, l'installation se fait d'elle même. Je pense qu'il fallait lire "ne le lancez pas", et non "ne l'installez pas". Par contre, lors du premier lancement, il garde sa vilaine icône de logiciel incompatible … Pas grave, il récupère son icône normale lorsqu'on le quitte … Du moins, dans le dossier "Applications", donc, après avoir quitté, il faut le supprimer du dock et l'y réinstaller pour virer le panneau d'interdiction dans le dock.
avatar Pascal 77 | 
Demain, j'essaie de le faire fonctionner sous Jaguar :D
avatar Toz | 
Dis Albert! J'ai parfaitement compris comment l'installer, mais avant ça il faut le télécharger. Or sur l'appstore, et pour l'instant il n'y a que par là qu'on peut se le procurer, je n'ai pas d'autre choix, après avoir appuyé sur le bouton"gratuit", que d'appuyer sur le bouton "installer". Si je copie le lien, je reviens à l'Appstore. Donc si tu peux me prouver que tu n'a pas usurpé ton illustre nom famille, je serais heureux que tu me donne une solution.
avatar Apple Addict 62 | 
Je ne comprends pas j'ai quasiment la même config que vous j'ai Snow Leopard et toutes les MAJ... [b]Et je n'ai pas de dossier -> CoreServices ni de fichier SystemVersion.plist !![/b] aucun résultat en réalisant les recherche dans finder !!?? Que faire !!??
avatar e.cornu | 
@ albert einstein : as tu essayé par toi même de suivre les indications de l'article avant de répondre à Toz et BenUp ?
avatar Ritchie_007 (non vérifié) | 
Bon, j'ai fait les manip. (modifié et remis le SystemVersion.plist et modifié Info.plist). Tout est bien en 10.6.8 ! Il me dit tjrs qu'il a besoin de 10.7.2 Marche pas ! @Apple Addict 62 : Dans Macintosh HD -> Système -> Bibliothèque -> CoreServices
avatar Switcher | 
Installable sous Snow… [i]si vous l'avez déjà récupéré d'un Mac Lion[/i]. Sinon, c'est [i]"iBooks Author ne peut pas être installé sur (votre Mac) car Mac OS X 10.7 ou ultérieur y est requis."[/i]
avatar clt92 | 
Nickel merci !
avatar fif | 
@Toz : tu signes ton OS en 10.7.2 tu télécharges (bouton installer) tu signes ton OS en 10.6.8 tu ouvres le paquet installé tu le signes en 10.68 et tu lances l'appli :)
avatar DrFatalis | 
Merci ! Je teste dès que posible! (et si cela marche, cela confirmera aussi tout le "bien" que je pense de l'attitude de Cupertino....)
avatar momo-fr | 
Bon, pour faire simple, la manip consiste à faire croire au Store que le système est un Lion (10.7.2), du coup le téléchargement s'effectue, mais… attention, une fois arrivé dans applications on remet de l'ordre dans le système en remettant le fichier SystemVersion.plist que l'on à sauvegardé auparavant PUIS on modifie l'application iBooks Author pour lui expliquer qu'elle peut fonctionner sous 10.6.8… et ça roule. C'est plus clair comme ça ? :-) Edit : merdum zappé par Fif… :-)
avatar senjy | 
C'est dommage de prendre les gens Pour des pigeons
avatar Apple Addict 62 | 
@Ritchie_007 ok désolé j'avais raté le Système... MERCI !
avatar romainhc | 
Juste pour mon info, l'effet de "tourné de page" n'existe plus pour les ibooks v2 ?
avatar lmouillart | 
Pour rappel la modification des produits logiciels d'Apple est interdite par le contrat de licence, si vous modifiez le logiciel vous n'avez plus le droit de l'utiliser.
avatar JohnnyTheSax | 
ÇA MARCHE !!!
avatar john_steed | 
hello, dans le paquet du logiciel mais rien n’y fait, il me signale toujours que le logiciel ne peut s’exécuter que sous Lion ... Quelqu’un a-t-il une idée ? J’ai pourtant suivi à la lettre le modus opérandi : j’ai pu télécharger sans problème le logiciel je ne l’ai pas lancé. Dans Applications, j’ai ouvert le paquet et modifié : LSMinimumSystemVersion 10.6.8 mais cela n’a rien changé, le logiciel refuse de se lancer car je ne suis pas sous LION d’après la fenêtre qui apparait...
avatar marenostrum | 
"C t pas plus simple de le rendre tout de suite compatible ? C'est donc bel et bien du marketing à deux balles !" et toi qui passe pas sur le système le plus récent, c'est quoi ? c'est pas plus mesquin ? en plus c'est plus facile pour le développement d'une application de ne prendre en compte que le dernier système. ça évite des bugs .... mais aussi ce logiciel s'adresse aux professionnels, donc c'est à toi d'investir (machine récente, système récent) pour l'utiliser.
avatar Anonyme (non vérifié) | 
Attention dans le fichier "SystemVersion.plist" il y a DEUX lignes à modifier de 10.6.x vers 10.7.2. Sans quoi ça ne fonctionne pas. Je pense que là Apple se f… de nous, mais ça va se savoir.
avatar john_steed | 
oui oui ça j’ai fait, d’ailleurs j’ai pu télécharger le logiciel ... C’est ensuite que ça bloque malgré le changement dans le paquet...
avatar frencheesushi | 
Merci pour l'astuce mais moi ça à tout foutu en l'air sur mon MacBook Air qui est en 10.6.8 : je ne peux plus ouvrir aucune application non compatible avec Lion ! J'ai pourtant re-modifié le fichier systemversion.plist en remettant 10.6.8 et réparé les autorisations... rien n'y fait... j'ai eu beau re-téléchatger itunes (qui se ré-installes mais ne se lance pas) et Safari (qui refuse de s'installer), c'est une vraie catastrophe... si quelqu'un sait comment indiquer au système que je suis bien sur SL et non Lion (autre que Systemversion.plist) ?
avatar CBi | 
Si on a une machine Lion sous la main pour télécharger l'application, il y a une façon de faire qui est peut-être plus simple = copier le fichier de l'app, faire "ouvrir le contenu du package" et modifier le fichier Info.plist de l'application (facile avec xCode) pour changer le système mini requis.
avatar Barijaona | 
Euh, je suggèrerais à la fin de la manip le rétablissement des droits Unix d'origine sur le fichier système... Ne pas le faire risquerait de perturber les mises à jour OS ultérieures. Sous Terminal : [quote] sudo chown root /System/Library/CoreServices/SystemVersion.plist sudo chgrp wheel /System/Library/CoreServices/SystemVersion.plist [/quote]
avatar DrFatalis | 
En ayant tout bien fait, authors s'est installé, mais refuse de se lancer et réclame son Lion même si son plist est maintenant modifié 10.6.8...
avatar pépé | 
J'ai le même problème que celui de frencheesushi. Merci à CBi et Barijaona pour vos suggestions, mais hélas, aucune des 2 ne n'a marché chez moi. Je suis vraiment embêté... Si quelqu'un a d'autres idées... merci d'avance.
avatar john_steed | 
sorry, je n’ai pas de solutions pour vous deux mais comme DrFatalis j’ai tout fait parfaitement : http://www.digitaltweaker.com/mac/mac-tips/2012/01/install-ibooks-author-on-os-x-snow-leopard-video/ à l’action près mais le logiciel demande toujours Lion... Pas grave : je vais attendre que quelqu’un trouve...
avatar h4l3 | 
Merci barijaona, on ne sait jamais en effet. Sinon j'aimerais bien avoir une explication de chez Apple car pour le moment on n'a aucun bug sous SL avec cette appli. Du coup... c'est quoi la raison du non portage? Parce que la réponse vaseuse de marenostrum juste au dessus c'est juste n'importe quoi. Payer d'accord, mais lorsque l'incompatibilité est avérée, or là c'est le contraire. Pour l'instant. Et qu'on nous fasse pas le coup du microphone pas adapté ou du processeur pas assez puissant, on n'est pas sur iGen ici.
avatar Barijaona | 
@john_steed et DrFatalis : j'ai le même problème que vous deux... il doit y avoir un cache quelque part qui perturbe. Par contre en lançant directement le fichier Unix contenu dans le bundle de l'application ( /Applications/iBooks\ Author.app/Contents/MacOS/iBooks\ Author ), ça passe...

Pages

CONNEXION UTILISATEUR