Certains logiciels sont endommagés sur votre Mac ? C’est « normal » !

Nicolas Furno |

Si vous voyez ce message d’erreur à chaque fois que vous essayez de lancer un logiciel sur votre Mac, c’est « normal ». Il y a un problème en ce moment avec la signature des applications téléchargées depuis le Mac App Store. Manifestement, OS X s’attend désormais à avoir une signature SHA256, plus sûre que la signature SHA1 qui était jusque-là en vigueur.

Cliquer pour agrandir

Le problème, c’est que certains logiciels n’ont pas la nouvelle signature et doivent la récupérer depuis le Mac App Store. Pour cela, une réinstallation fonctionne bien sûr, mais OS X est censé demander le mot de passe du compte iTunes Store utilisé et se débrouiller avec ça. Dans certains cas, cela ne suffit pas néanmoins et il faut alors se débrouiller autrement.

Si vous avez ce message d’erreur, vous pouvez effectivement réinstaller le logiciel concerné depuis le Mac App Store. Il y a une autre solution néanmoins, beaucoup plus simple. Déconnectez votre compte de la boutique, puis connectez-vous à nouveau et vous devriez retrouver tous vos logiciels. En théorie, cette étape règle le problème de signature, même si cela n’a rien changé pour l’un des Mac de la rédaction.

Si la déconnexion et connexion ne fonctionne pas, un redémarrage s’impose. Vous pourrez ensuite réinstaller les logiciels, voire repasser sur la version fournie hors Mac App Store si vous le pouvez. En espérant qu’Apple règle le problème au plus vite…

avatar Tiroly | 

Merci ! J'avais justement le problème...

avatar Olivier S | 

Moi perso, j'ai ce message avec un logiciel mais que je n'ai pas acheté sur AppStore mais sur le site de l'éditeur. Tous les 2/3 semaines, il faut que je le réinstalle !!! Est ce même problème ??

avatar YARK | 

Apple ne veut pas qu'on dévoile sa vie privée ?

OK, alors soyons logique : si cette société est quelque part intrusive sur ce que tu as installé,
rends-lui la monnaie de sa pièce en installant Little Snitch :

https://www.obdev.at/products/littlesnitch/index.html

Une fois ce "garde-barrière" installé, interdit à ton logiciel récalcitrant de faire des requêtes.
Sauf une fois de temps en temps pour le mettre à jour.
Avant d'être leur Mac, c'est avant tout le tien ! Nom di Diou !

Franchement ça se Microsoftise vachement chez Apple.
Vraiment plus la boîte sympa que j'ai connue...

avatar bonnepoire | 

Aucun rapport!

avatar Fahrenheit | 

Pareil le même problème à chaque syncro d'iPhone

avatar fosterj | 

pareil d! je ne suis donc pas seul !! De l'importance de lire Macg toutes les heures !!!!

avatar johannk | 

Je viens d'avoir le problème avec 1Password. J'ai un peu flippé...

avatar iRobot 5S | 

J'ai ce problème avec un logiciel que je n'ai pas téléchargé sur l'App Store.

Par contre j'ai un autre problème de bugs graphiques Quad j'utilise Firefox. Soit l'image se bloque soit il y a des endroits qui clignotent.

avatar inumerix | 

Ça s'arrange pas avec leur iCould...

avatar patrick86 | 

"Ça s'arrange pas avec leur iCould..."

aucun rapport avec iCloud.

avatar jipeca | 

Jamais de problèmes...

Maintenant, c'est vrai que je suis resté sur Snow... Ce qui explique tout !

avatar jackhal | 

Oui, effectivement. Cette news concerne un mécanisme de sécurité qui n'existait pas du temps de SL.
Mon père a un Mac qui ne peut pas installer une version plus récente que SL et c'est quand même un peu craignos : il y a des fonctionnalités des OS X plus récents qui me manquent quand j'utilise SL, il y a plein de logiciels qui ne peuvent plus être installés dessus, les navigateurs ne sont plus mis à jour, pas plus que l'OS et il est donc exposé à de belles failles de sécurité.

Donc en gros, s'il t'arrive un problème (qui sera potentiellement d'une ampleur toute autre que ce dont il est question dans la news), on pourra te dire que, "Maintenant, c'est vrai que tu étais resté sur Snow... Ce qui explique tout !".
Tu as l'air de croire que c'est une bonne idée. Selon moi c'est tout l'inverse.

avatar jipeca | 

" il y a des fonctionnalités des OS X plus récents qui me manquent quand j'utilise SL, il y a plein de logiciels qui ne peuvent plus être installés dessus,"...

Je cherche encore quel logiciel ne peut plus être installé sur SL qui n'existait pas avant ... ou même qui n'ait pas... perdu des fonctionnalités depuis la MàJ vers les os récents.
Je cherche encore les "fonctionnalités récentes", qui n'existaient pas déjà sous SL sous une forme ou sous une autre (même et souvent freeware d'ailleurs dont beaucoup ne sont plus installables maintenant et manquent cruellement ).

"Les navigateurs ne sont plus mis à jour..." ?
Certains, (Safari ?) sans doute, ce qui n'empeche pas d'en trouver, des navigateurs, dont Chromium, SWare (chromium aussi), Firefox, Opera, et d'autres encore plus récents encore en bêta tellement ils sont récents.... Et Chrome est toujours dispo à l'heure actuelle.

"Donc en gros, s'il t'arrive un problème (qui sera potentiellement d'une ampleur toute autre que ce dont il est question dans la news), on pourra te dire que, "Maintenant, c'est vrai que tu étais resté sur Snow... Ce qui explique tout !".
Ben en gros, sauf erreur, depuis quelques années, je compte les coups sur Lion, Mountain, Maverick et consort, et ca semble bien parti pour durer. D'autre part, les malwares et autre joyeusetés se mutiplient sur... les os récents avec un pompom particulier d'ailleurs pour iOS (vers lequel OSX se dirige à grand pas...) et pas sur SL... Ben dis donc !
Apparemment l'idée n'est pas si mauvaise jusqu'à maintenant.

D'autant que des travaux sous Photoshop identiques sur SL ou sur Yosémite ne mettent pas les nouveaux os particulièrement en valeur... Et l'idée ne semble toujours pas être si mauvaise.
d'autant que mes iMacs sont tout a fait répérables, .. et finalement l'idée me semble de - en - idiote...

avatar jackhal | 

Ah oui effectivement, il y a plus de trucs sous SL que sous Leopard, l'OS que mon père avait jusqu'à cet été. Reste que j'ai aussi été bloqué pour installer les logiciels que j'utilise souvent.
Et voilà pourquoi je l'ai passé à SL alors qu'il ne voulait rien changer, à priori : parce qu'il avait de nouveaux appareils qui ne fonctionnaient pas avec 10.5.

Au passage, Google a annoncé la fin du support des OS "anciens" : Avril 2016, et il faudra passer au minimum à Mavericks (ou 7, pour Windows)
http://chrome.blogspot.fr/2015/11/updates-to-chrome-platform-support.html
Toujours avec Google, par exemple, le Chromecast demande 10.7 ou plus récent.

"Ben en gros, sauf erreur, depuis quelques années, je compte les coups sur Lion, Mountain, Maverick et consort, et ca semble bien parti pour durer. D'autre part, les malwares et autre joyeusetés se mutiplient sur... les os récents avec un pompom particulier d'ailleurs pour iOS (vers lequel OSX se dirige à grand pas...) et pas sur SL... Ben dis donc !"

Ben dis donc quoi ? SL ne fait plus l'actu sur ce plan mais comment le ferait-il ? Apple ne fait plus les mises à jour de sécu de SL, donc tu n'en entends plus parler. Non pas parce que c'était un système super sécurisé, que maintenant les hackers ne s'en préoccupent plus et donc que le risque est passé, mais parce qu'il est à l'abandon. Quand une faille est trouvée qui concerne aussi les versions précédentes d'OS X y compris SL, SL n'est pas corrigé.
Et pourquoi chercher de nouvelles failles de SL s'il en existe déjà d'exploitables ?

Après je ne pousse pas au changement, hein. Si tu as une machine figée, isolée et qui tourne, il n'y a pas de raison de mettre à jour. Par exemple un studio d'enregistrement avec un Pro Tools qui ne sert qu'à ça et pas en plus à surfer : si la machine est parfaitement stable, pas la peine de changer pour changer. Mais pour un ordi "de loisirs", pour un utilisateur curieux de nouveautés (sinon pourquoi venir sur MacG)... c'est limite.

avatar Armaniac | 

Je sais que ce n'est pas le sujet du topic, mais je suis quand même curieux de savoir si je le seul à avoir cet autre souci, et dans le genre bug pénible c'est pas mal non plus : très régulièrement maintenant, j'ai un popup du Finder me disant "Erreur de paramètre -50", ou quelque chose dans ce goût la... Impossible de trouver des infos sur internet (je continue de chercher).

Quelqu'un d'autre a le souci?

avatar R1x_Fr1x | 

Je reste volontairement sur la version Twitbot 1.6.2 afin de conserver l'onglet "RT". Effacer l'app pour la retélécharger depuis l'AppStore est impossible car il me propose la dernière version. Bref, je l'ai dans l'os avec l'app qui ne s'ouvre plus depuis ce matin tel un vulgaire pirate alors qu'elle m'a couté 20 euros. Merci.

avatar GlobeTrotteur | 

Pour moi le problème subsiste même après les conseils prodigués :
- déconnexion/reconnexion du compte Mac App Store
- redémarrage du Mac

Je ne suis pas sorti de l'auberge si je dois m'emmerd** à reinstaller la tonne d'applications que j'utilise !
Plus ça va, plus ils m'agacent chez Apple

avatar XiliX | 

@GlobeTrotteur

"Plus ça va, plus ils m'agacent chez Apple"

Ah oui ça t'aggace toi d'avoir des logiciels plus sûr ?
Si c'est le cas, tu n'as qu'à désactiver le contrôle des applications installées dans les préférences.

avatar karayuschij | 

Oui enfin, cette paranoia de la sécurité elle a aussi bon dos……
(On nous "protège" pour nous faire sentir dans l'insécurité… c'est un excellent business pour beaucoup de gens)

avatar XiliX | 

@karayuschij

Donc d'après toi changer la clé de sécurité obsolète par une plus récente c'est une connerie ???
Dans ce cas pourquoi tu n'as pas désactivé purement et simplement le contrôle ? Apple ne t'embêtera plus avec ces avertissements, et laisser les autres qui préfèrent la tranquilité avec cet "inconvénient"

avatar karayuschij | 

Eh fanboy, calme toi !!
Je ne dis pas que c'est une connerie, mais il n'y a pas de quoi entrer en paranoïa comme le font certains…
Et puis moi je m'en fout : 1) je n'ai pas ce problème 2) j'utilise Little Snitch

La meilleure technique pour toujours plus fliquer les gens c'est de leur faire croire en un manque croissant de sécurité…

avatar XiliX | 

@karayuschij
"Eh fanboy, calme toi !!"

Ah mais tu vas te calmer toi même... si ce sont les autres qui sont paranoia... va dire aux autres et pas à mon poste !!! Fanboy de mes deux !

"2) j'utilise Little Snitch.
La meilleure technique pour toujours plus fliquer les gens c'est de leur faire croire en un manque croissant de sécurité…"

Et tu oses dire que ce sont les autres qui sont paranos !!! Non mais tu te fous du monde !!!

avatar jipeca | 

Des logiciels plus sur... C'est une reponse qui devient trèèèès largement bâteau. C'est loin d'être plus sur, et c'est surtout beaucoup plus emmerdant. Et le mot est encore loin de la vérité. Jamais le moindre problème avec un logiciel installé depuis 30 ans. Faut arrêter de raconter et d'avaler n'importe quoi.

Et faudrait aussi essayer de rester en effet un peu plus calme, parce que là on situe effectivement le niveau de l'individu.

avatar XiliX | 

@jipeca

Il est évident que les anciens logiciels sont plus surs et pour cause, sinon ils se seraient déjà faits descendre il y a un moment. Le problème est surtout avec les plus récents et surtout beaucoup de gens n'ont cette compétence de déceler les vrais des faux.

Signer les logiciels est une des méthodes qui permet de s'assurer qu'il ne s'agit pas d'un crapware, malware...etc Il est évident qu'il est faillible (XCode gate), mais c'est toujours mieux que rien...

avatar Stegue | 

Le prix de la qualité ! Vous ne trouvez pas que c'est de pire en pire depuis quelques années ?

Pages

CONNEXION UTILISATEUR