Mises à jour Mac OS X, ce qui colle et ce qui cale

Florian Innocente |
Coup sur coup Apple a livré deux révisions pour Tiger (10.4.11) et Leopard (10.5.1). Le recul n'est pas suffisant pour évaluer si elles amènent davantage de déboires que de réconfort, mais dans un cas comme dans l'autre, des informations et retours d'utilisateurs commencent à arriver.

Certains ont subit des plantages avec le Safari 3 fourni avec la 10.4.11, notamment lors de la fermeture d'une fenêtre via son bouton rouge. La faute en revient principalement (sinon uniquement) aux extensions ajoutées au navigateur (telles que PicLens ou Speed Download, etc). A retirer donc. Elles sont le plus souvent logées dans le sous dossier InputManagers du dossier Bibliothèque à la racine du disque dur. Certaines comme PicLens ont leur propre désinstalleur (Menu Présentation dans Safari). A l'inverse, sous Leopard, ces problèmes avec Safari 3 ne semblent pas se poser.

Dans notre forum Leopard et autres Mac OS X deux utilisateurs du 10.4 ont signalé que leurs périphériques USB et/ou FireWire refusaient de fonctionner après l'application de la mise à jour de Tiger. Cas isolés ou pas, le dossier est ouvert.

Dans la 10.5.1 de Leopard, Apple a répondu à des critiques émises à l'encontre du Coupe-feu (notre dépêche). D'abord en changeant l'intitulé de deux options, qui deviennent ainsi plus explicites sur leur périmètre d'activité. Ainsi "Bloquer toutes les connexions entrantes" est devenu "Autoriser uniquement les services essentiels" et "Définir l'accès aux applications et services spécifiques" s'intitule désormais "Définir l'accès de certains services et applications". Ensuite les changements réalisés par l'utilisateur s'appliquent immédiatement et non plus à l'issue d'un redémarrage.

Autre bug qui avait défrayé la chronique, celui qui supprimait des fichiers dans certains cas de déplacements d'éléments d'un volume à un autre (notre dépêche). Il se trouve résolu.

Mais d'autres bugs sont en bonne santé dans le 10.5. Dans la note 307033, Apple évoque le cas du Dossier de Départ de l'utilisateur qui disparaît tout bonnement au démarrage. Pas de panique rassure le rédacteur, il suffit de sortir la clef de 12, à savoir le Terminal, et de saisir puis valider la ligne de commande suivante pour voir réapparaître la petite maison :

chflags nohidden ~/

Autre péripétie racontée cette fois par la note 307035, iChat qui refuse toute conversation audio et vidéo dans Leopard alors même qu'il est installé sur un G4 à 867 MHz, une machine qui répond aux critères minimaux pour Leopard. Et d'enfoncer le clou par un message d'erreur expliquant peu ou prou que non, votre ordinateur est trop âgé pour s'engager dans de telles activités sociales. Là encore, clef de 12, et une fois dans le Terminal tapez la commande suivante puis relancez iChat.

defaults write com.apple.iChat newbwdup 300000

Enfin, la note 306561 fait état d'un problème de chargement d'un widget créé avec la fonction ad-hoc de Safari 3 (Clip Web), puis un message d'erreur enjoint l'utilisateur d'ouvrir Safari. Mieux (ou pire) le widget en question est supprimé si l'on a demandé sa synchronisation avec un autre Mac via le service .Mac. Apple conseille de recréer ce widget dans Safari sur l'un ou l'autre des Mac, de le lancer pour vérifier son bon fonctionnement et si tout est OK, alors de réactiver sa synchronisation.


avatar Anonyme (non vérifié) | 
Réponse à @bdi123 Même problème de blocage chez moi au moment de la mise à jour de Tiger vers Leopard (Power Mac G5 3 (avec 1 024 Mo DDR SDRAM) Mon compte utilisateur "Admin" s'est transformé en "standard" et, depuis, je ne peux plus refaire toute installation avec le disque Leopard, ni modifier mon compte personnel. Mon mot de passe habituel est toujours refusé. Premier gros problème depuis 1990 A vous lire, je ne sais vraiment pas quoi faire, n'ayant que ce mac. Que faire? Merci pour tout conseil.
avatar LeConcombreMaske | 
Presque 20 ans que j'utilise des Macs, et presque 20 ans que je dis : "attendez un peu avant de vous précipiter sur une nouvelle machine, une nouvelle version d'OS..." Je suis de tout coeur avec celles et ceux qui font une allergie au dernier félin d'Apple et je m'en vais de ce pas installer Mac OS 9.1 sur mon iMac G3... :D ;)
avatar gg90fr | 
sous OSX 10.411 a tout hasard Comment tenter de réinstaller safari qui ne fonctionne pas bien que sauf erreur de ma part il n'y a pas de plug d'installé ? merci réponse gg90
avatar nlex | 
bizarre j'ai PicLens et ça ne me pause aucun probleme avec Safari et 10.4.11
avatar debione | 
Ben je comprend pas, les problemes n'arrivent qu'aux autres? Perso aucun bug sur leopard et sa mise a jour..... Des fois je me demande comment font les gens pour avoir autant de problemes..... deux mains gauches?
avatar Anonyme (non vérifié) | 
On dirait du Windows cette mise à jour ... Vive la concurrence...
avatar magic.ludovic | 
Pourtant tous les employés d'Apple travail d'arrache pied pour vous satisfaire ... Immersion totale dans la peau de la bête ... : http://www.scalespace.org/2003/images/leopard%20man%20of%20skye.jpg
avatar Anonyme (non vérifié) | 
Réponse à [b]bdi123[/b] et [b]Jo85[/b] Attendez... sur l'utilitaire de réinitialisation des mots de Passe du DVD OS X, vous n'arrivez pas à créer un mot de passe pour le "System Administrator", root quopi...?!!? C'est grisé? les champs sont inactifs? avez-vous bien pensé à "enregistré" (bouton idoine) la double saisie ? C'est bien embêtant car l'accès à root permet de redonner des droits admin ou même d'en créer un de nouveau. On pourrait passer par un boot en Single User (pomme-S au démarrage-->Console + lignes de code spécifiques) mais je ne peux donner ubliquement ici une méthode qui peut s'averer malveillante pour certains qui pourraient vouloir l'utiliser à mauvais escient... Sorry. Attention toutefois, si jamais vous réussissez à y accéder, limitez vos actions dans ce domaine : Il faut savoir CE qu'on y fait et COMMENT on le fait, car root a Tous les droits de manière transparente (on ne voit rien ou presque... Donc attention...
avatar Almux | 
Dans l'ensemble: sensiblement plus rapide (démarrage, Safari en tout cas) Dans le détail: j'ai des recouvrements (pas toujours et pas catastrophiques) de caractères, dans certains documents. Si je fais un copié-collé des textes alliénés, j'obtiens un résultat irréprochable... donc, je pense qu'il devra bientôt y avoir un patch de firmware de la carte graphique (sur MacPro, du moins). Quelqu'un d'autre a cela de temps à autre?
avatar peyret | 
Tiens ! Golive9 veut pas s'installer...le coupable 10.5.1 ou Adobe ? Faut dire qu'Adobe avec son installeur "maison" !
avatar Anonyme (non vérifié) | 
bonjour, je viens d'installer la 10.4.11 sur un G4 quicksilver 733 et il bloque au démarrage ! QUELQU'UN a une idée ?
avatar Anonyme (non vérifié) | 
Mea culpa : finalement tout fonctionne contrairement à ma première impression. Gain apparent avec 10.4.11 : Safari parle en français et semble en effet un peu plus véloce.
avatar vincent.l1 | 
il y a t il des gens qui ont essayé d'upgrader de 10,4,11 en leopard ??? lorsque j'essaye il ne reconnait aucune de mes partitions comme contenant une version de tiger ..... moralité il veut absolument formatter en HFS , impossible de faire une mise à jour.... sympa....
avatar Feroce | 
Pour la question concernant GoLive 9, j'ai constaté que d'anciens installeurs Adobe ne supportaient pas du tout (mais vraiment pas du tout!) le format HFS+ avec sensibilité à la casse.
avatar Yaourt | 
Il y avait aussi un bug vraiment lourd : Avec un Macbook (pro dans mon cas) si on fait une mise en veille câble d'alimentation branché, et qu'on réactive la machine câble débranche (ou inversement), l'ordi se fige. La 10.5.1 a corrigé ça. Merci Apple !
avatar ange | 
Sur safari 3, j'ai eu un pb au lancement : message indiquant un pb d'incompatibilité de AcidSearch. J'ai mis à jour Acidsearch (0.62 > 0.7.3), j'avais encore une erreur (au lancement) qui disait que c'était les SMBL (en fait il restait dans la Library un AcidSearch.bundle !). Une fois celui-ci supprimé, plus de soucis au lancement. si cela peut aider..
avatar Sergio_bzh | 
Oui le réseau ne s'est pas amélioré avec cette mise à jour. Auparavant , mon Mac détextait sans pb et rapidement mon PC Linux. Maintenant il faut que j'aille faire "connecter au serveur ...". Après ça va mais la connexion est bien plus lente.
avatar alrog | 
Oulala ca bug! sur mon powerbook 12'' 1ghz, mise à jour 10.5.1, et là c'est le drame: Safari refuse de s'ouvrir "incompatible avec cette version de mac os x", idem pour adresses et ical ...
avatar Anonyme (non vérifié) | 
Mauvaise pioche, cette MAJ en 10.4.11 ! Depuis, sur mon PowerPC, Safari repeint en 3.0.4 quitte inpinément avec une fréquence alarmante. C'est d'ailleurs la seule chose plus rapide : se planter plus vite…
avatar stephparis | 
ET J'AI TOUJOURS LES MACHINES RESEAUX QUI DISPARAISSENT PAR MAGIE....super mise a jour bravo...
avatar biniou | 
A part safari 3 d'autres problèmes avec la 10.4.11 ?
avatar Nihondjin | 
Je ne comprends pas, je n'ai aucun problème ?! 10.4.11 la sortie ? là =>
avatar So6 | 
Ca frise le foutage de gueule quand même cette mise à jour. Tout le monde attendait une résolution massive des bugs, et on nous sort 30 malheureux mégas, qu'ils ont mis presque un mois à produire. Le tout pour que les bugs repartent de plus belle sur les forums US. Sans compter que les problèmes latents n'ont pas été résolus : PC réseau toujours invisibles, Mail3 encore instable, TimeMachine qui pose tjs autant de problèmes...
avatar noAr | 
@so6 : bon bah je vais peut-être attendre avant d'upgrader alors… ;-)
avatar kubernan | 
@So6:"Tout le monde attendait une résolution massive des bugs, et on nous sort 30 malheureux mégas" Ben faut croire que "tout le monde" se raconte des histoires.
avatar mfam | 
Cette mise à jour n'est pas très convaincante. Certains petits "bugs" sont toujours présents. Exemple cette configuration réseau qui ne retient toujours pas certaines informations dans le mode avancé... pour le reste c'est à suivre on dirait.
avatar bdc | 
"...il suffit de sortir la clef de 12, à savoir le Terminal" "...Là encore, clef de 12, et une fois dans le Terminal tapez la commande suivante puis relancez iChat" On frole l'univers Windosien, non ?
avatar Ninety | 
@ Nihondjin : Idem ;) On voit la difference entre ceux qui savent utiliser un Mac et ceux ... qui savent pas ^^ Ok ok je sors aussi xD
avatar boulifb | 
Et bien de mon côté, j'ai toujours ce problème concernant le changement des droits d'un fichier via le "Get Info" du Finder. Ça plante à tous les coups. Ça arrive sur des disques durs formatés sous Tiger en HFS+ journalisé. Le disque formaté par Leopard est OK. J'espère ne pas être un cas isolé. Cordialement.
avatar jeffhouilles | 
Chez moi Léopard marche nickel, je suis rassuré quant à la correction du bug sur la copie de fichiers. Ni plus ni moins de plantage que sous Tiger. @bdc : La clé de 12 sur windows est plutot regedt32 ou format c:
avatar Chardin | 
Problème avec la mise à jour10.4.11. Certaines vidéo ne fonctionnent plus. Ex les tutoriels d'Adobe me laissent un bel écran noir. (fonctionne sur mon Pc !) En espérant un rapide retour à la normal !!!!
avatar gg90fr | 
pas terrible cette maj (emac 1,25 ) - les autres mac connectés par reseau disparaissent sans raison ( lorsqu'ils arrivent à monter) ( alors que s/tiger pas de probleme) - machine lente au démarrage - systeme pâs très réactif ( moins qur Tiger ) bref encore du chemin pour etre convaincu, je reste sous Tiger pour travailler ... dommage
avatar Didier Guillion | 
Ahh ! Ca y est la béta de Léopard a commencée ! Super... Cordialement
avatar PA5CAL | 
J'ai fait la mise-à-jour combo 10.4.11 PowerPC il y a trois jours. Malgré une utilisation variée et intensive, jusque là tout ce passe bien. Aucun des problèmes évoqués plus haut n'est apparu. Aucun plantage, les périphériques USB fonctionnent bien, les DD externes montent correctement, les vidéos passent. Et Safari 3.0.4 semble résoudre les derniers problèmes gênant de la version 2.0.4.
avatar jeremyl | 
gros soucis chez mois avec la 10.4.11!!! Sur mon MBP 17': -au telechargement: "impossible de decompresser le paquet" -Je redemarre le MBP et la pouf impossible de le rallumer il bloque, ( j'ai laissé deux heures pour etre sur...) -REINSTALLATION OBLIGATOIRE AVEC LES CDS DE RESTAURATION!!!! donc pas cool, et comme j'ai pas pu faire une clean install, le syteme est un bancal je trouve, je suis donc bon pour un reformatage etc... merci Bill heu Steeve. Faut qu'il fasse gaffe quand meme, j'ai justement switcher pour ne plus etre emmerder avec ca..... bon sino je l'adore quand meme mon macccccc
avatar Sexualpolice | 
J'ai aucun bug apparent ou génant...
avatar Anonyme (non vérifié) | 
10.4.11 faite. Aucun soucis, sauf Piclens qui me bloquait Safari 3.0.4. Safari 3 excellent ;) Après mise à jour de Piclens, tout roule... (iMac24"/2,33ghz)
avatar Anonyme (non vérifié) | 
La mise a jour Leopard a conduit a un Bug qui transforme mon compte administrateur en compte "standard", impossible d'utiliser mon mot de passe pour tte opération impliquant le DD. la procédure Apple ne marche pas et les conseils de la hotline sont NULS...mon conseil : attendez !!! si qqun a une idée je suis preneur.
avatar Anonyme (non vérifié) | 
[b]jeremyl[/b]: même problème pour moi. J'avais une erreur pendant l'installation me disant d'essayer d'installer le package depuis le Finder (l'installateur l'avait placé dans la corbeille). L'installation manuelle ne marchait pas plus et le système semblait bloqué (je ne pouvais plus lancer aucune application). Le redémarrage n'a pas abouti. Mais j'ai trouvé une solution plus simple qui a marché pour moi : J'ai téléchargé l'update combo en démarrant depuis une autre partition et je l'ai installée. Plus de problèmes ensuite
avatar NicoR | 
Oula vous me faites peur avec tout vos truc !! ca fait 2 semaines que j ai un mac et j y connais pas encore tout les trucs ! mon leopard marche bien du moins je pense vu que je n'ai pas de point de comparaison... mais afin d etre sur et de pas planté mon compte admin sans savoir quoi faire apres je vais peut etre attendre pour la mise a jour....
avatar Anonyme (non vérifié) | 
Je suis le troisième dont les ports usb ne fonctionnent plus après le passage à 10.4.11 et évidemment je n'ai aucune idée de comment revenir à le version précédente. J'avais également un petit problème avec Safari mais je l'ai résolu grâce à ce forum (merci). Globalement, à nous lire, j'ai quand même l'impression que cette Maj ne s'imposait pas et qu'elle souffre un peu d'improvisation. Il me reste maintenant à attendre qu'une correction ou qu'un participant éclairé de ce forum me fasse changer d'avis...
avatar Anonyme (non vérifié) | 
NB: j'ai évoqué des problèmes de fonctionnement du port USB. Plus précisément, c'est la souris qui ne fonctionne plus. En revanche, une clef USB est bien lue.
avatar Gabone | 
Mises à jour nickel avec léopard a++
avatar Anonyme (non vérifié) | 
@ [b]bdi123[/b] Je ne connais pas le problème réel, mais à vu de nez, j'appliquerai la methode de créer un compte root par le DVD d'instal; OSX. En gros : -1/ mettre le DVD et redémarrer dessus (comme pour une install -2/arrivé au début de l'install , choisir la langue -3/ et aller au menu "Outils (je crois) -->Rétablir le mot de passe -4/ choisir le "System Administrator" (root) et créer son mot de passe (2 fois)->Enregistrer -quitter l'installation et redémarrer sur le DD OS X -6/arrivé dans sa session, menu Pomm-->Fermer la session... -7/ dans le panneau d'authentification cliquer sur "Autre" et marque root dans le 1er champ et le mdp dans le 2nd-->Ouvrir -8/arrivé dans la session root, aller à menu Pomme--> Preferences Système-->Compte -9/ choisis ton compte et clique sur "Autorisation à administrer cet ordinateur"... -10/ cliques ensuite sur "Modifier le mot de passe" que tu retapes 2 fois-->"Modifier le mdp". -11/fermer la session-->et ouvres la tienne avec ton nouveau mdp. Voilà, c'est ce que je ferais personnellement, mais je ne suis pas au fait de ton problème précis... ;-)
avatar CBi | 
Je suis peut-être chanceux, mais 10.4.11 installé et 10.5 pour l'instant en test sur un disque externe ne semblent poser d'autres problèmes que ceux liés... à des plug-in externes installés ici et là. Une fois ceux-ci retirés, tout semble rentrer dans l'ordre. Les machines à problèmes ne sont-elles pas fortement customisées ?... Ou alors c'est parce que je suis sur Power PC, pas sur Macintel ;-)
avatar Anonyme (non vérifié) | 
cité : Didier Guillion [16/11/2007 18:31] "Ahh ! Ca y est la béta de Léopard a commencée ! Super... Cordialement" J'aime bien ton humour Didier, et je dois bien avouer que je vais attendre avant de passer sous leopard, d'une part parce que mon soft pro ne tourne pas encore dessus mais aussi parce que tout le monde essuie les plâtres comme moi même l'ai fait en achetant la 1 re version des MBP 17 : résultat, déjà 2 cgt de carte mère...à chacun son tour, c'est comme ça que l'on apprend mais tout comme pour l'Iphone, je ne me précipiterai plus sur les 1 res gén de produits tant que ces produits n'auront pas atteint leur stade de maturité (terme marketing avéré). Je laisserai donc ma nana se faire les dents sur leopard lorsqu'elle s'achètera son macbook en janvier après la macworld expo... sans commentaire...
avatar Pym | 
Pour ma part, la disparition de mon dossier d'utilisateur m'est arrivée sous Tiger. RIen à faire, tout disparu. Même en affichant tout les fichiers (même ceux masqués), pffffuit... parti :( Seule fois en 20 ans que j'ai hurlé contre un Mac.
avatar Anonyme (non vérifié) | 
Pareil que jeremyl et Camon.Moi aussi l'installaton devait se faire depuis le finder après un message d'erreur et a fini dans la corbeille. Réinstallation du système bloqué avec les cds.
avatar Anonyme (non vérifié) | 
Réponse a b?ber1: Merci pour l'info que j'avais éssayé d'appliquer a la suite des conseils de la hotline; pas de chance pour moi la procédure bloque au point 4: le systeme n'accepte pas le nouveau mot de passe...? Une autre idée ?

CONNEXION UTILISATEUR