Apple annonce Safari 5 [maj]

Florian Innocente |
Comme dévoilé ce week-end, Apple annonce Safari 5. Le navigateur n'est pas encore proposé au téléchargement. Un communiqué de presse daté du 7 juin est apparu en ligne chez PRNewswire avant d'être précipitamment retiré… Il n'est pas encore très clair si cette version sera d'abord offerte aux développeurs ou à tout le monde. Le communiqué de presse suggérait la seconde hypothèse.

[maj] Safari 5 est disponible [5.0 - 37,5 Mo Snow Leopard - 46,7 Mo Leopard - VF]

La plupart des nouveautés sont déjà connues et confirmées, par exemple l'ajout de Bing et de Yahoo sur Safari Mac (lire Exclu : Mac OS 10.6.4 et Safari 5 pour la WWDC) mais comme cela nous avait été dit, il restait une ou deux surprises.

Ainsi le support des extensions. À la manière de celles de Chrome, elles devront être écrites en HTML5, JavaScript et CSS3. Leur développement pourra se faire sur Mac avec Extension Builder. Ces extensions évolueront dans un espace cloisonné pour des raisons de sécurité et contiendront une signature numérique émise par Apple.

La fonction Top Site paraît plus réactive dans son affichage. La jauge bleue de chargement d'une page, disparue avec Safari 4, est revenue. Deux boutons bascule permettent de passer de Top Sites à l'historique plus rapidement.

La nouvelle fonction "Lecteur" se présente sous la forme d'un bouton qui apparaît dans le champ d'adresses une fois un article chargé. D'un clic, Safari va afficher uniquement le texte et les images (non publicitaires) de cet article, en surimposition à la page originale.

lecteur5a
Avant


Et si le texte coulait sur plusieurs pages, elles sont toutes réunies sur une seule et même longue page que l'on fait défiler. Cette page expurgée peut être imprimée ou envoyée par mail. Et l'on peut varier la taille de sa police.

lecteur5b
Après


Les performances du moteur JavaScript Nitro sont données comme 30% plus rapides que celles de Safari 4, un tout petit 3% plus véloce que chez Chrome 5 mais de deux fois plus rapide que Firefox 3.6.

Safari 5 met de côté Tiger et exige désormais Leopard (10.5.8 au minimum) ou le 10.6.2. Côté Windows il faudra XP SP2 minimum. Apple en a profité pour indiquer que Safari était en fonction sur 200 appareils (Mac, PC ou famille iPhone) et que les déclinaisons du WebKit, le moteur de rendu de pages, l'était sur 500 millions de machines diverses et variées.
Tags
avatar Gimli fils de Gloin | 
prem's
avatar Pierre Mickael Marchand | 
Le communiqué de presse n'est plus disponible ! ... @Gimli fils de Gloin : J'aime ce genre de comportement de Kevin...
avatar quentinms | 
Le communiqué de presse n'est plus dispo ! Publié par erreur ?
avatar Fiozo | 
Gimli fils de Gloin : Bravo tu as gagné un pin's
avatar Julobox | 
Jobs avait oublié son post-it lors de la Keynote.. J'vois bien les mecs d'Apple là... -Hey les mecs, ont fait quoi, on met un communiqué en ligne? -T'es pas fou, vire ça de là, on attendra l'année prochaine!
avatar pseudo714 | 
Les nouvelles extentions avec ce nouveau support auront quoi comme differences par rapport aux plugins qu'on a déjà? C'est seulement pour centraliser le telechargement des extensions?
avatar Nesus | 
Ça devient une habitude chez Apple de se concentrer sur un truc dans les keynote et de nous offrir autre chose un peu après (comme pour les iMac). Finalement ils vont peut être bien sortir de nouveau pro ou autre après sans annonces (encore une fois). Enfin un nouveau safari c'est une joie ;-)
avatar pseudo714 | 
Au fait glims il marchera plus avec safari 5?
avatar pseudo714 | 
Ils ont annoncé xcode aussi je crois
avatar Pierre Mickael Marchand | 
@Pseudo714 : Ben comme : Adblock,Adflash, Glims, Antidote and co ;)
avatar pseudo714 | 
@toximytix : je n'ai pas compris ta réponse. Ou tu n'as pas compris ma question. Je voulais connaitre la différence entre les plugins qu'on déjà et ceux qu'on aura avec safari 5 via la nouvelle fonctionnalité
avatar Pierre Mickael Marchand | 
@Pseudo714 : Je crois qu'aucun sera compatible...
avatar divoli | 
[quote]Safari 5 met de côté Tiger et exige désormais Leopard (10.5.8 au minimum) ou le 10.6.2. Côté Windows il faudra XP SP2 minimum.[/quote] Mouarf...
avatar pseudo714 | 
@toximityx : merci en fait tu répondais à ma deuxième question.
avatar crapule | 
ca y est : il est sorti http://www.apple.com/safari/download/
avatar daphone | 
Safari 5 dispo !!
avatar Anonyme (non vérifié) | 
Ca y est c'est disponible via les mises à jour...
avatar daphone | 
je suis en train de le DL par l'utilitaire de mise à jour du mac
avatar tgravs | 
euh, il est là http://www.apple.com/safari/download/ (ah ben zut, le temps que je retrouve ce foutu mot de passe, je me suis fait griller tiens :-)
avatar daphone | 
ça y est, redemarré ! Oh je suis trop content d'avoir retrouvé la barre bleue de chargement !!
avatar crapule | 
c'est genial le lecteur ) ( dans la barre de telechargement)
avatar leonzeur | 
oui génial le lecteur mais le RSS il est où maintenant ? edit je me réponds à moi même ..il suffit de cliquer sur la flèche à droite pour recharger la page et "lecteur" se transforme en "rss" excellent
avatar Dr Troy | 
La fonction "lecteur" s'affiche quand tu es sur l'article, sur la page précédente tu as le RSS. Personnellement je ne trouve pas ça fou, je m'attendais à une amélioration du lecteur RSS. Content de retrouver la barre de chargement de Safari 3 en tout cas.
avatar Dr Troy | 
ClickToFlash n'est pas compatible (Safari affiche Flash comme module manquant quand il est activé). Cookies fonctionne normalement par contre.
avatar Un Touriste | 
Chez moi clickToFlash fonctionne bien (Safari 5 - Snow Leopard)

Pages

CONNEXION UTILISATEUR