Fermer le menu
 

iMac : un bug graphique toujours sans solution officielle

Florian Innocente | | 14:39 |  33
Un bug graphique avec des iMac de 2009 continue d'ennuyer des clients malgré les différentes mises à jour système sorties depuis. La faute serait en fait d'ordre matériel. En mai 2012, un utilisateur a posté sur les forums d'Apple le détail d'un problème avec son iMac : un lot d'artefacts graphiques à l'écran et de kernel panic.



Au fil des discussions, il est apparu que le coupable était très certainement la carte graphique NVIDIA GeForce GT 130 et son pilote OS X. Lancé sous Windows, le même iMac ne reproduit pas ce comportement. Différents témoignages pointent sur une apparition du problème consécutive à l'application de la dernière mise à jour 10.6.8 de Snow Leopard. Le bug a ensuite persisté chez certains jusqu'à Mountain Lion.

La solution radicale testée par plusieurs personnes fut de faire changer la carte graphique de leur machine. Étant hors garantie, l'opération a couté en général un peu moins de 200$.

Ce bug évoque le problème sur lequel Pixelmator a buté en décembre dernier. L'équipe expliquait alors avoir eu des soucis de blocage de son application, d'artefacts graphiques et de redémarrage inopiné du Mac lorsque le logiciel de retouche était utilisé de manière intensive (lire Pixelmator : un bug pour de nombreux Mac sur NVIDIA).

Pixelmator n'a pu résoudre ce problème situé hors de sa portée, il s'en était ouvert auprès d'Apple car il en a tracé l'origine à un dysfonctionnement avec un pilote NVIDIA pour les GeForce GT 120/130/330M, 9400M et 9600. Difficile toutefois de savoir si les deux situations découlent du même bug.

Sur le même sujet :
- MacBook Pro 15" 2010 : le programme de SAV en dernière année
Catégories: 
Tags : 

Les derniers dossiers

Ailleurs sur le Web


33 Commentaires Signaler un abus dans les commentaires

avatar mapiolca 05/03/2013 - 14:45

J'en ai un similaire sur mon MacBook Pro 13" 2010

avatar jgraph 05/03/2013 - 14:53

Et c'est la même chose que sur les MacBook Pro 15" qui disposent de la Nvidia GT 8600. Par contre, dans ce dernier cas, ça causait des Blue screen of death sous Windows de manière plus fréquente qu'habituellement.

avatar fouranto 05/03/2013 - 15:05

La 320m de Nvidia sur mon MPB2010 13" me fait des petits stress graphiques identiques ...


avatar robrob 05/03/2013 - 15:06

C'est la qu'on voit l'avantage de la parfaite integration materielle/logicielle qu'offre Apple. Grace a ca le materiel Mac fonctionne parfaitement avec son OS Windows. oh wait...

avatar patrick86 05/03/2013 - 15:13

@robrob : Merci de ce commentaire très instructif. Tu veux qu'on provoque ce genre de bug avec Windows ? Ou non, mieux ! On fou la merde dans les registres mémoire d'interruption système, ça peut être drôle… ^^ Plus sérieusement, j'ai jamais eu ce bug, mais ça doit être embêtant en effet. L'informatique n'est pas parfait !

avatar Yohmi 05/03/2013 - 15:24

Je précise, concernant Pixelmator, que ce n'est pas uniquement en cas d'utilisation intensive. C'est un comportement totalement aléatoire, qui peut survenir rien qu'en maniant le rectangle de sélection sur une image à un calque. À ce niveau-là de susceptibilité, autant dire que je me replie sur Aperçu à chaque fois que c'est possible. J'ai une GeForce GT 330M sur mon MacBook Pro, et j'ai régulièrement des artefacts graphiques. Parfois, un texte illisible sur Safari (il suffit alors de défiler et tout rentre dans l'ordre), parfois l'interface qui est hachurée (bouger la fenêtre concernée ou changer de bureau virtuel résout le problème)… par contre, je n'ai pas les formes violettes que l'on voit sur l'image. Bref, tout ça pour dire que les pilotes Nvidia sur OS X n'ont pas l'air franchement fiables.

avatar oMc 05/03/2013 - 15:29

La même pour moi, 320M de Nvidia sur mon MBP2010 13". Pas beaucoup de glitch graphique sous ML (j'en avais beaucoup sous Lion, avec Chrome ou Acrobat), mais des méchants freezes quand on sollicite trop Pixelmator. Ça fait quand même 1 an et demi que ça dure, il serait temps que Apple fasse quelque chose pour ces pilotes graphiques en papier mâché.

avatar robrob 05/03/2013 - 15:32

@patrick86 Oh faut pas le prendre mal, on a quand meme le droit de faire des petites piques a Apple. Ils se sont jamais genes pour taper sur MS quand il y avait des bugs et autres il y a quelques annees. Et il faut reconnaitre que niveau integration des cartes graphiques ca fait des annees qu'Apple nous sert des drivers pas au niveau.

avatar Oliange 05/03/2013 - 15:35

@patrick86 : oui mais ici tu n'as pas besoin de te forcer à foutre le bordel. C'est livré de base. C'est ça la différence.

avatar patrick86 05/03/2013 - 15:38

@robrob : Je le prend pas mal ;)

avatar patrick86 05/03/2013 - 15:39

@Oliange : Les problèmes de registres d'interruption c'est livré avec aussi ;) Mais c'est pas le sujet de toute façon.

avatar Benz Hine 05/03/2013 - 15:49

De toutes les façons, Apple doit avoir une sacrée équipe de bras cassés en ce qui concerne les pilotes graphiques...Ce n'est ni nouveau ni surprenant. Mais c'est aussi scandaleux que depuis qu'on sait que c'est lent (VS la meme carte sur windows voire sur linux) c'est à dire depuis des années, rien ne notable n'ait été fait.

avatar Cobaltscave 05/03/2013 - 16:15

J'avais le même type de bug sur mon MacPro 2009 (changé il y a quelques semaines) avec Photoshop. Ça n'avait rien de bien gênant puisque ces artefacts n'apparaissaient pas sur l'image elle-même, mais entre l'image et le bord de la fenêtre quand on agrandissait cette dernière.

avatar DrFatalis 05/03/2013 - 16:16

J'ai du mal comprendre.... Ces Macs, au final, fonctionnent mieux sous Windows que sous OSX ? "Something is rotten in the kingdom of Cupertino"...

avatar Orus 05/03/2013 - 16:21

Oh un bug ! Encore un ! Étrange pour le meilleur matériel et le meilleur OS du monde, même que c'est écrit partout chez Apple. Et même que c'est la justification des prix nettement au-dessus du marché PC. Bizarre Apple ne semble rien voir...

avatar en ballade 05/03/2013 - 16:37

@patrick86 : Les drivers sont beaucoup mieux optimisés sous windows que ça soit amd ou nvidia

avatar patrick86 05/03/2013 - 16:46

@en ballade : En oui, encore une conséquence de l'hégémonie de Windows...

avatar joneskind 05/03/2013 - 17:17

@en ballade : Beh je te dirai que ça doit dépendre desquels. Par exemple sur ma tour Hack j'ai une ATI HD5000. Sous OSX, ça tourne impeccable avec Photoshop CS5. Fluide et rapide, l'outil de retouche "Outil Correcteur Localisé" me donne des résultats époustouflants. Par contre sous Windows 8 c'est pas la même chose. Le même Photoshop est plus lent, a des lags un peu bizarre et le même outil est inutilisable (la correction n'est jamais juste). J'ai tourné le problème dans tous les sens et je ne suis pas parvenu à résoudre le problème. Et sur mon MBP 2010 15" équipé de la 330M je n'ai jamais eu le moindre souci. Quant à PixelMator, je ne le conseille pas. Il est terriblement lent et poussif et ne fait absolument rien de plus que Photoshop CS2. Mais ça n'empêche que c'est un bug particulièrement pénible assez scandaleux sur une machine de ce prix.

avatar mistermicro.fr 05/03/2013 - 17:21

Eh oui ça n'a pas que du négatif que Windows soit si répandu, on en arrive à des pilotes optimisés mis à jour régulièrement Mais pas grave, Apple ne va pas se faire ch... à développer des pilotes débuggués, vu la vitesse à laquelle ils veulent qu'on change le matériel avec leur obsolescence programmée et le fait que le Mac devient la cinquième roue du carrosse...

avatar patrick86 05/03/2013 - 18:00

@rhino92 : Tu as compris à l'envers… C'est parce que Windows domine largement, que les pilotes graphiques sont d'abord développés et optimisés pour lui. Les autres OS passent après… C'est exactement comme pour les progiciels développés que pour Windows. Ce ne sont pas les constructeurs qui développent les pilotes dédiés des cartes graphiques ! Ce sont les fabricants de ces dites cartes. Par contre, ils peuvent développer des pilotes génériques, qui fonctionneront pour plusieurs GPU et permettront un minimum de choses… On rencontre du coup le problème avec Linux, ont ne trouve pas toujours le pilote de sa CG pour Linux… Et c'est aussi ce qui limite le nombre de PC avec lesquels on peut faire un hackintosh : il faut qu'un pilote pour Os X soit disponible.

avatar patrick86 05/03/2013 - 18:02

@joneskind : Windows 8… c'est pas simple. Tu as un bon noyau, très amélioré par rapport aux précédentes versions. Mais par dessus il y a une sur-couche graphique et une interface, disons… → no comment. As-tu eu l'occasion de comparer avec Windows 7 ?

avatar Jiminy Panoz 05/03/2013 - 18:36

Hum, pour info, y'a un encore plus gros problème de ce type avec freezes à la clé (plusieurs par jour) sur iMac de 2008-2009 depuis 10.6.3 aussi, avec carte graphique ATI, et si vous allez voir les forums de support Apple, vous vous rendrez même compte que les Mac qui boguent avec une cg nvidia sont bien bien minoritaires par rapport au nombre incalculable de gens qui ont ce problème avec du ATI... C'est même dans les threads ATI qu'on a découvert que le même problème existait pour les cg nvidia... Je dis ça, je dis rien. Et il existe même un fix : changer les kext par ceux de mac os 10.6.2.

avatar Carcintosh 05/03/2013 - 20:47

Wahou !! J'ai jamais eu ça… et heureusement !! Sinon… c'est retour windaube vista.

avatar albinoz 05/03/2013 - 22:05

Il faudrait qu'apple mettes le paquet sur Open GL - Open CL, ou qu'il délègues, comme pour java, mais en mieux ^^

avatar Hari-seldon 05/03/2013 - 22:11

Ah Apple les et les pilotes graphiques ... Une grande histoire d amour

Pages