Fermer le menu

Pas encore prêts pour High Sierra : Wacom, Razer, Illustrator, Serato…

Stéphane Moussie | | 14:15 |  47

À quelques heures de la sortie de macOS High Sierra en version finale, plusieurs éditeurs recommandent à leurs clients de ne pas mettre à jour leur Mac dès maintenant.

C’est le cas de Wacom, qui prévient que son pilote actuel ne fonctionne pas avec le nouveau système. Une nouvelle version compatible avec High Sierra sera disponible au plus tard fin octobre.

Le fabricant de périphériques Razer a indiqué il y a deux jours que son logiciel Synapse n’était pas non plus compatible avec le nouveau système. Pas de date annoncée pour la mise à jour.

Adobe a publié une fiche d’assistance le 12 septembre mentionnant des problèmes graphiques et d’autres liés à APFS touchant Illustrator. Ce week-end, l’éditeur disait encore travailler à leur résolution avec Apple.

Serato, spécialisé dans les applications pour DJ, déconseille à ses clients de passer à macOS 10.13 avant son feu vert. Le blocage des extensions de kernel a déjà causé quelques soucis.

Plusieurs logiciels édités en France par Tri-Edre ne sont pas compatibles : Data Rescue 4, Drive Genius 5, TechTool Pro 9. L’outil de clonage SuperDuper ne sait pas encore gérer APFS pour sa part.

La liste n’est pas exhaustive. Vous trouverez des renseignements sur d’autres logiciels dans ce fil de discussion sur notre forum ainsi que sur le répertoire RoaringApps.


Les derniers dossiers

Ailleurs sur le Web


47 Commentaires Signaler un abus dans les commentaires

avatar tempest 25/09/2017 - 14:21

Quelqu’un de qualifié serait-il en mesure de m’expliquer comment des boîtes peuvent ne pas être capables de délivrer leurs applis à jour et compatible avec un système annoncé plusieurs mois à l’avance et dispo pour les développeurs au minimum 4/5 mois avant la release publique ????? C’est insensé.
Et nous ne parlons pas là de petites structure mono personnel ou d'applications de niches mais d'éditeurs majeurs et de programmes relativement mainstream…

avatar jean512 25/09/2017 - 14:28

Ce sont des boites qui ont plusieurs produits en vente et surement que leur appli macOS représente qu'une petite parti de leur chiffre d'affaire, donc ils ne mettent pas tous les moyens pour avoir l'appli compatible le jour J.
Tout est une question de priorité en fonction.

avatar Feflefoo 25/09/2017 - 19:48

@ jean512

Je serais curieux de connaître la part des utilisateurs de Mac dans la clientèle Wacom... Sans blague...



avatar ErGo_404 25/09/2017 - 14:31 (edité)

Il y a plusieurs raisons :
- Les roadmaps sont souvent décidées parfois plus en avance que 5 ou 6 mois, surtout dans les grosses boîtes. Si la compatibilité avec le nouveau système demande une refonte importante, ça se planifie et ce n'est pas si évident.
- Les éditeurs pensent avoir prévu le temps mais finalement des retours indiquent que leur correctif n'est pas totalement prêt, et avec les temps de modification / validation ça peut repousser d'un mois la sortie du produit.
- Les changements sont peut être vraiment majeurs pour certaines applications, du genre, API qui était indiquée "dépréciée" (mais toujours fonctionnelle) et qui passe maintenant à "abandonnée".

Si ton OS sort tous les ans et qu'il intègre à chaque fois des changements qui cassent la compatibilité, c'est usant pour un développeur de devoir corriger ça au lieu de se concentrer sur le développement de nouvelles fonctionnalités.

avatar r e m y 25/09/2017 - 14:33 via iGeneration pour iOS (edité)

@tempest

L'absence quasi totale d'informations sur APFS de la part d'Apple explique beaucoup de ces retards...(aucun utilitaire de récupération de fichier, comme data rescue, file salvage, techtool,... ne sait travailler sur un disque APFS faute d'avoir la doc suffisante sur ce nouveau système de fichiers).

Quant aux bugs détectés durant les bêta tests, certains sont imputables à HighSierra et doivent être corrigés par Apple et pas par les développeurs de ces applications qui ne peuvent qu'attendre le correctif.

avatar chammer 25/09/2017 - 14:37

Je ne me prétends pas nécessairement qualifié.
Mais le changement imposé de format de fichiers sur SSD, sans documentation exhaustive de l'APFS, et avec des spécifications qui ont changées depuis la beta, est un sérieux frein.
C'est un problème pour les développeurs, mais aussi et surtout pour les utilisateurs, car rien ni personne n'est actuellement en mesure de récupérer les données sous APFS.
À vous de voir quelle est l’attitude la plus raisonnable et responsable, en fonction de l’importance de vos données.

avatar kubernan 25/09/2017 - 14:46 (edité)

@tempest : Ce n’est pas si simple... Il y a sûrement des boîtes qui gèrent mal leur calendrier mais s’adapter à une évolution majeure d’un nouveau système n’est pas forcément si facile quand les bêtas sont beuguées, incomplètes ou mal documentées, quand tu dois parallèlement gérer la maintenance courante etc. etc. Il y a aussi des logiciels dont la conception même demande plus d’efforts pour s’adapter...

avatar oomu 25/09/2017 - 15:06

parce qu'Apple ne donne des documentation qu'à partir de la WWDC et que le système continue d'évoluer APRES (les beta ne sont pas de simples tests, ils sont du retour et test par Apple elle même et elle modifie parfois les APIS en plein pendant la beta)

cela laisse donc entre juin et fin septembre pour des éditeurs.
donc:
- se former aux nouveautés
- décider quoi en faire
- faire le travail
- test, retour, régression, correction
- ASSURANCE QUALITÉ ! Toute modification importante ou non vous oblige à refaire tester le logiciel. Cela bouffe un temps considérable.

Ici on parle soit de logiciels complexes et CRITIQUES : ceux qui modifient le système de fichier et APFS est un GROS morceaux à avaler et vous ne pouvez pas improviser avec vos utilisateurs

ou des logiciels qui touchent de près au système alors qu'Apple a pour habitude de tout chambouler sans aucune considération pour les développeurs (extensions kernel avec énième nouvelle sécurité)

et des logiciels titanesques (ceux de Adobe) avec 30 ans de fonctionnalités et historiques accumulées.

Alors on prend Robert le Stagiaire et on lui dit : "Alors Bob, je peux t'appeler Bob ? Tu prends tous nos programmes et services, et tu le testes sur le nouvel os d'Apple, ha et tu me feras la dernière mise à jour de windows aussi, celle d'y a 5mn. tu me fais le rapport pour vendredi, coco."

ben non ! c'est LONG.

-
et je crève d'envie de faire le jeu de mot pourri avec le nom "tempest" mais je la ferai pas de peur de vexer et cette auto-censure personnelle me navre. Monde de merde :)

avatar areayoko 25/09/2017 - 15:54

LOL ! 😂

Carrément insensé quoi ! 😶

Non mais sérieusement ! :)

C'est d'ailleurs souvent les petites applications qui sont compatibles le plus tôt.

avatar Ducletho 25/09/2017 - 20:04 via iGeneration pour iOS

@tempest

Trop de Rtt dans ces boîtes.
Et le jeu du solitaire qui a tué la productivité . En plus un développeur est un fainéant par nature

avatar Mr Bob 25/09/2017 - 14:25

Le site Roaring apps renseigne sur les compatibilités apps/OS.
https://roaringapps.com/apps?platform=osx

Ça vaut le coup d'y jeter un œil.

avatar chammer 25/09/2017 - 14:46

Ce site est remarquable et mérite d'être consulté avant chaque mise à jour de système.
Mais il ne référence pas pour High Sierra les problèmes liés au changement de format de fichiers sur SSD d'origine.. ou d'autres marques.
Les utilitaires de réparation, récupération et copie sont tous HS. La fiabilité de CarbonCopyCloner avec APFS est à vérifier, puisque l'éditeur de SuperDuper estime qu'elle est actuellement impossible à garantir.

avatar Stéphane Moussie macG 25/09/2017 - 14:47

@Mr Bob : ah oui, je l'avais oublié. Je l'ajoute à l'article.

avatar Orus 25/09/2017 - 14:29

Bon ben vu l'ambiance je vais attendre février ou mars pour passer sur ce MacOS.
Toute manière mon Mac fonctionne très bien sans High Sierra, source de problèmes pour quelques nouveautés de plus non indispensables.

avatar xDave 25/09/2017 - 14:30 via iGeneration pour iOS

Ah ben Adobe va bien en profiter pour rendre obsolète toutes les anciennes versions non cloud de la suite, APFS obligé.
Ils étaient déjà incapables d'être compatibles HFS+ sensible à la casse après tout.

avatar oomu 25/09/2017 - 15:09

oui, c'est un long héritage d'Adobe de vivre dans un monde merveilleux d'insensibilité à la casse et du coup d'avoir conservé une tonne de potentiels bugs tapis dans l'ombre.

avatar andre.mordi 25/09/2017 - 14:34 via iGeneration pour iOS (edité)

Razer: la pire entreprise au monde pour les mises à jour.
Gameurs, évitez ces produits

avatar ArnaudB 25/09/2017 - 19:10

Ho Wacom n'est pas mieux en la matière ! Non seulement cela fait vingt ans qu'à chaque mise à jour de Mac OS on patiente des semaines pour avoir des pilotes à jour, mais en général pour que cela fonctionne vraiment il faut en fait downgrader ses pilotes avec une version antérieur de celle qui est officiellement soutenu. Va comprendre.

avatar mctos 25/09/2017 - 14:36 via iGeneration pour iOS

Personnellement, c’est InDesign qui a des soucis d’affichage du curseur.
Lorsque vous souhaitez par exemple redimensionner un bloc ou faire une rotation, celui-ci devient carré ou transparent. Je n’ai pas fait la dernière mise à jour CC mais je vous préviens par avance au cas où.
Rien de bien grave cependant, ça reste entièrement utilisable, juste un peu contraignant.

Aucun problème cependant avec Illustrator de mon côté.

avatar Arpee 25/09/2017 - 18:11 via iGeneration pour iOS

@mctos

J’ai le même fâcheux problème, et cela n’est absolument pas utilisable. Heureusement que je garde une autre machine sous Sierra pour continuer à travailler. Pour le reste, tvb.

avatar ty971 25/09/2017 - 20:13 (edité)

tu as bien de la chance car moi j'ai de gros problèmes d'affichage dont entre autre des triangles rectangles gris qui apparaissent n'importe ou sur mes pages. Difficile de travailler dans ces conditions.

avatar nicolasnwf 25/09/2017 - 14:53

Même chose pour les souris LOGITECH, le Control Center permettant de personnaliser les boutons de sa souris (par exemple la Performance Mouse MX que j'ai) n'est pas compatible High Sierra, donc attention...

http://support.logitech.com/en_us/software/logitech-control-center-for-m...

avatar Ultranova 25/09/2017 - 21:37

Ma MX Master fonctionne très bien et l'outil de paramétrage aussi.

Sauf que le logiciel ne s'appelle plus Control Center mais Logitech Options

avatar Yoskiz 25/09/2017 - 14:58 via iGeneration pour iOS

Moi personnellement j’ai CCC5 comptable donc ça va.

Ayant une Fusion Drive, pas de APFS pour le moment.

Et du moment que Lightroom 6, 1Password et Antidote fonctionnent... ça me va dans un premier temps.

avatar moon21 25/09/2017 - 15:31

Ca promet des jours heureux....

Pages